解决无需升级,您的WordPress数据库已经是最新的了!

在线升级到WordPress最新版本登录后台时,出现提示:

  • “无需升级,你的WordPress数据库已经是最新的了” ▼

无需升级,你的WordPress数据库已经是最新的了

  • 单击继续会转到首页,并发生无限死循环,导致站点无法登录……

解决方案如下:

1)哪里出问题?

大多数出现此现象的用户,都启用了object缓存,或Memcached缓存。

wp-content文件夹中有一个object-cache.php文件,这是导致你无法登录缓存的主要原因。

2)如何解决?

第 1 步:删除或重命名object-cache.php文件

  • 我们只需要进入wp-content文件夹,来删除object-cache.php文件。
  • 或者更改后缀名称,例如:object-cache.php.bak

第 2 步:登录后台

然后再次登录后台,就不会出现无限循环。

如何找到和解决问题?

这类问题通常是由WordPress建站程序的缓存引起的:

  • 你还记得你的WordPress程序,是否安装了一些缓存插件?
  • 然后转到FTP,直接更改缓存插件名称,或删除所有生成的缓存缓存文件夹(如窗口小部件缓存,对象缓存,WP缓存,WP插件缓存等)

注意事项

  • 多数缓存文件位于plugins文件夹中。
  • 某些插件缓存文件位于wp-content目录中,或你未注意到的其它位置。
  • 更改完成后,就能如常登录WordPress后台了。