Cyfeiriadur Erthygl
Rydym fel arfer yn hyrwyddo cadwyn allanol ac mae angen monitro optimeiddio cyswllt cyfeillgarwch.
Os byddwn yn colli ein backlinks a'n cysylltiadau cilyddol, bydd ein safle SEO hefyd yn dirywio. Felly, mae monitro statws tudalennau gwefannau â backlinks yn bwysig iawn.
Pam Defnyddio Kuma Uptime i Fonitro Gwefannau?
Sut i fonitro backlinks at ddibenion SEO?
Ar ôl ychwanegu backlinks a chyfnewid cysylltiadau cilyddol, fel arfer rydym yn ffurfweddu monitro gwefannau ar blatfform monitro cwmwl Uptime Robot i wirio cysylltedd y tudalennau backlink ar bob gwefan.
Fodd bynnag, wrth i nifer y cadwyni allanol a chadwyni ffrind gynyddu, mae gan lwyfan cwmwl Uptime Robot gyfyngiad ar nifer yr eitemau monitro, a rhaid i chi uwchraddio a thalu i barhau i ychwanegu mwy o eitemau monitro cwmwl.
Felly, gallwn ddefnyddio'r offeryn meddalwedd monitro gweinydd cwmwl Linux ffynhonnell agored – Uptime Kuma.
Pa feddalwedd yw Uptime Kuma?
Offeryn monitro gweinydd Linux ffynhonnell agored yw Uptime Kuma gyda swyddogaethau tebyg i Uptime Robot.
O'i gymharu ag offer monitro gwefannau tebyg eraill, mae Uptime Kuma yn cefnogi gwasanaethau hunangynhaliol gyda llai o gyfyngiadau.
Bydd yr erthygl hon yn cyflwyno gosod a defnyddio Uptime Kuma.
Sut i osod offeryn monitro Uptime Kuma?
Uptime Kuma, yn cefnogi gosodiad Docker.
Mae'r canlynol yn diwtorial o gamau gosod ar gyfer Uptime Kuma.
Mae'r gorchmynion canlynol ar gyfer gosod y rhaglen drwy CLI [Ubuntu/ CentOS ]. Gosodwr CLI rhyngweithiol, gyda neu heb gefnogaeth Docker ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
- Ni argymhellir defnyddio'r gorchymyn gosod uchod: oherwydd bod Uptime Kuma wedi'i osod mewn ffordd nad yw'n Docker, mae'n hawdd methu'r gosodiad.
- (Rydym yn argymell y gorchymyn gosod isod)
Gan fod angen i chi osod Docker cyn gosod Uptime Kuma gan ddefnyddio Docker, gosodwch Docker yn gyntaf.
Gosod Docker a Docker-compose
Diweddaru a gosod meddalwedd angenrheidiol ▼
apt-get update && apt-get install -y wget vim
Os bydd gwall 404 yn digwydd yn ystod y diweddariad, gwiriwch yr ateb isod ▼
Gosod Docker
Os yw'n weinydd tramor, defnyddiwch y gorchymyn canlynol ▼
curl -sSL https://get.docker.com/ | sh
Os yw'n weinydd domestig yn Tsieina, defnyddiwch y gorchymyn canlynol ▼
curl -sSL https://get.daocloud.io/docker | sh
Gosodwch Docker i gychwyn yn awtomatig wrth gychwyn ▼
systemctl start docker systemctl enable docker
Gosod Docker-compose
Os yw'n weinydd tramor, defnyddiwch y gorchymyn canlynol ▼
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose sudo chmod +x /usr/local/bin/docker-compose
Os yw'n weinydd domestig yn Tsieina, defnyddiwch y gorchymyn canlynol ▼
curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose
Ailgychwyn y gorchymyn gwasanaeth docwr▼
service docker restart
Sut i osod offeryn monitro statws gwefan am ddim Uptime Kuma?
docker volume create uptime-kuma
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1- Yna, gallwch chi basio
IP:3001Ewch i Uptime-Kuma.
Os ydych chi wedi galluogi wal dân CSF, efallai y bydd angen i chi agor porthladd 3001 ar wal dân CSF▼
vi /etc/csf/csf.conf # Allow incoming TCP ports TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001"
Ailgychwyn y wal dân CSF ▼
csf -rGosod Rheolwr Dirprwy Nginx
Meddalwedd dirprwy gwrthdro wedi'i seilio ar Docker yw Nginx Proxy Manager.
Gan nad oes angen Rheolwr Dirprwy Nginx, gallwch hepgor peidio â gosod Rheolwr Dirprwy Nginx os nad ydych chi am wastraffu amser.
Creu cyfeiriadur ▼
mkdir -p data/docker_data/npm cd data/docker_data/npm
Creu ffeil docker-compose.yml ▼
nano docker-compose.yml
Llenwch y cynnwys canlynol yn y ffeil, yna pwyswch Ctrl+X i gadw, pwyswch Y i adael ▼
version: "3"
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
restart: unless-stopped
ports:
# These ports are in format :
- '80:80' # Public HTTP Port
- '443:443' # Public HTTPS Port
- '81:81' # Admin Web Port
# Add any other Stream port you want to expose
# - '21:21' # FTP
environment:
DB_MYSQL_HOST: "db"
DB_MYSQL_PORT: 3306
DB_MYSQL_USER: "npm"
DB_MYSQL_PASSWORD: "npm"
DB_MYSQL_NAME: "npm"
# Uncomment this if IPv6 is not enabled on your host
# DISABLE_IPV6: 'true'
volumes:
- ./data:/data
- ./letsencrypt:/etc/letsencrypt
depends_on:
- db
db:
image: 'jc21/mariadb-aria:latest'
restart: unless-stopped
environment:
MYSQL_ROOT_PASSWORD: 'npm'
MYSQL_DATABASE: 'npm'
MYSQL_USER: 'npm'
MYSQL_PASSWORD: 'npm'
volumes:
- ./data/mysql:/var/lib/mysql rhedeg ▼
docker-compose up -d
Os bydd neges gwall tebyg i'r canlynol yn ymddangos: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼
[root@ten npm]# docker-compose up -d npm_db_1 is up-to-date Starting npm_app_1 ... error ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: Encountered errors while bringing up the project.
- Mae'n golygu bod porthladd 443 eisoes wedi'i feddiannu, ac mae angen golygu'r ffeil docker-compose.yml sydd newydd ei chreu.
Mae angen newid porthladd 443 i 442 ▼
- '442:442' # Public HTTPS Port
Yna, rhedeg y gorchymyn eto docker-compose up -d
Bydd neges gwall yn ymddangos:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"
Hefyd mae angen newid porthladd 80 i 882 ▼
- '882:882' # Public HTTP Port
trwy agor http:// IP:81 Ewch i Nginx Proxy Manager.
Ar gyfer y mewngofnodi cyntaf, defnyddiwch y cyfrif cychwynnol diofyn a'r cyfrinair ▼
Email: [email protected] Password: changeme
- Ar ôl mewngofnodi, gwnewch yn siŵr eich bod yn newid eich cyfeiriad e-bost a'ch cyfrinair ar unwaith.
Gwrthdroi dirprwy Uptime Kuma
Ar ôl gosod Uptime Kuma, y rhagosodiad yw ei ddefnyddioIP:3001Ewch i Uptime Kuma.
Gallwn gyrchu'r enw parth a ffurfweddu'r dystysgrif SSL trwy ddirprwy, yn union fel yr URL a ddangoswyd yn gynharach.
Nesaf, byddwn yn perfformio gweithrediadau cynhyrchu gwrthdro, gan ddefnyddio'r Rheolwr Dirprwy Nginx a adeiladwyd yn flaenorol.
Pasio http:// IP:81 Agor Rheolwr Dirprwy Nginx.
Ar ôl mewngofnodi am y tro cyntaf, mae angen i chi newid yr enw defnyddiwr a'r cyfrinair, os gwelwch yn dda ffurfweddu eich hun.
Nesaf, mae camau gweithredu Rheolwr Dirprwy Nginx fel a ganlyn:
第 1 步 :trowch ymlaen Proxy Hosts ▼

第 2 步 :Cliciwch ar y gornel dde uchaf Add Proxy Hosts▼

Cam 3: Ffurfweddu yn ôl y ffigur,Cliciwch Save 保存 ▼

第 4 步 :cliciwchEidtAgorwch y dudalen ffurfweddu ▼

Cam 5: Cyhoeddi tystysgrif SSL a galluogi mynediad HTTPS gorfodol ▼

- Ar y pwynt hwn, mae'r genhedlaeth wrth gefn wedi'i chwblhau, ac yna gallwch chi ddefnyddio'r enw parth rydych chi newydd ei benderfynu i gael mynediad i Uptime Kuma.
- Mae cyfluniad Uptime Kuma yn syml iawn.
- Mae ganddo ryngwyneb Tsieineaidd, rwy'n credu y byddwch chi'n gallu ei ddefnyddio'n fuan.
Uptime Kuma Gorchmynion PM2 Defnyddiol
Cychwyn, stopio, ac ailgychwyn gorchmynion Uptime Kuma (mae'r gorchymyn hwn wedi'i neilltuo ar gyfer gosod nad yw'n Docker) ▼
pm2 start uptime-kuma pm2 stop uptime-kuma pm2 restart uptime-kuma
Gweld allbwn consol cyfredol Uptime Kuma (mae'r gorchymyn hwn yn ymroddedig i osod nad yw'n Docker) ▼
pm2 monit
Rhedeg Uptime Kuma wrth gychwyn (mae'r gorchymyn hwn yn ymroddedig i osodiadau nad ydynt yn Docker) ▼
pm2 save && pm2 startup
Sut i sefydlu copi wrth gefn awtomatig o feddalwedd monitro Uptime Kuma?
Oherwydd y gallai fod rhai problemau gyda'r swyddogaeth wrth gefn yng ngosodiadau cefndir Uptime Kuma, nid yw'r datblygwr wedi cynnal y swyddogaeth wrth gefn bellach.
Eisiau gwybod mwy am sut i ddelio ag dibrisiant nodwedd wrth gefn Uptime Kuma? Cliciwch ar y ddolen isod i barhau i ddarllen y tiwtorial manwl ▼
Sut i ddadosod meddalwedd monitro Uptime Kuma?
Os na chafodd Uptime Kuma ei osod gan ddefnyddio Docker, sut ydw i'n ei ddadosod?
Er enghraifft, os ydych chi'n defnyddio'r gorchymyn hwn i osod mewn ffordd nad yw'n Docker▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
I ddadosod Uptime Kuma, defnyddiwch y gorchymyn canlynol ▼
- allan o wasanaeth
pm2 stop uptime-kuma - dileu cyfeiriadur
rm -rf /opt/uptime-kuma
Sut i ddadosod Uptime Kuma os ydych chi'n ei osod gan ddefnyddio Docker?
Rhedeg y gorchymyn ymholiad canlynol ▼
docker ps -a
- ysgrifennwch eich
kumaEnw'r cynhwysydd, a all foduptime-kuma
gorchymyn stop ▼
- Anfonwch
container_nameNewid i'r ymholiad uchodkumaEnw'r cynhwysydd.
docker stop container_name docker rm container_name
Dadosod Uptime Kuma ▼
docker volume rm uptime-kuma docker rmi uptime-kuma
Casgliad
Mae rhyngwyneb Uptime Kuma yn lân ac yn syml, ac mae'n hawdd iawn ei ddefnyddio a'i ddefnyddio.
Mae Uptime Kuma yn ddewis da iawn os nad oes gennych chi ofynion uchel ar gyfer monitro gwefan.
Gobeithio y bydd yr erthygl "Offeryn Monitro Statws Gwefan Am Ddim Uptime Kuma ar gyfer Gweinyddion Linux" a rennir ar flog Chen Weiliang ( https://www.chenweiliang.com/ ) o gymorth i chi.
Mae croeso i chi rannu'r ddolen erthygl hon: https://www.chenweiliang.com/cwl-29041.html


