Uptime Kuma tasuta veebisaidi oleku jälgimise tööriist Linuxi serveri jälgimise tarkvara

Tavaliselt teeme välise keti reklaami ja sõpruse lingi optimeerimist tuleb jälgida.

Kui kaotame oma tagasilingid ja vastastikused lingid, langeb ka meie SEO edetabel. Seetõttu on tagasilinkidega veebilehtede oleku jälgimine väga oluline.

Miks kasutada veebisaitide jälgimiseks Uptime Kumat?

Kuidas jälgida tagasilinke SEO eesmärgil?

Pärast tagasilinkide lisamist ja vastastikuste linkide vahetamist konfigureerime tavaliselt veebisaidi jälgimise Uptime Roboti pilvepõhisel jälgimisplatvormil, et kontrollida iga veebisaidi tagasilinkide lehtede ühenduvust.

Väliste kettide ja sõbrakettide arvu suurenemise tõttu on Uptime Roboti pilveplatvormil aga jälgimiste arv piiratud ning pilveseire üksuste lisamise jätkamiseks peate uuendama ja maksma.

Seetõttu saame kasutada avatud lähtekoodiga Linuxi pilveserveri jälgimistarkvara tööriista – Uptime Kuma.

Mis tarkvara on Uptime Kuma?

Uptime Kuma on avatud lähtekoodiga Linuxi serveri jälgimise tööriist, millel on Uptime Robotiga sarnased funktsioonid.

Võrreldes teiste sarnaste veebisaitide jälgimise tööriistadega, toetab Uptime Kuma isehostitavaid teenuseid vähemate piirangutega.

See artikkel tutvustab Uptime Kuma installimist ja kasutamist.

Kuidas installida Uptime Kuma jälgimistööriista?

Uptime Kuma, toetab Dockeri installimist.

Järgmine on Uptime Kuma installietappide õpetus.

Järgmised käsud on programmi installimiseks CLI kaudu [Ubuntu/ CentOS ]. Interaktiivne CLI installija, Dockeri toega või ilma ▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
  • Ülaltoodud installikäsku ei ole soovitatav kasutada: kuna Uptime Kuma installimiseks on mitte-Docker, on installimine lihtne ebaõnnestuda.
  • (Soovitame allolevat installikäsku)

Kuna enne Uptime Kuma installimist Dockeri abil peate installima Dockeri, installige esmalt Docker.

Installige Docker ja Docker-compose

Värskendage ja installige vajalik tarkvara ▼

apt-get update && apt-get install -y wget vim

Kui värskendamise ajal ilmneb tõrge 404, kontrollige allolevat lahendust▼

Installige Docker

Kui see on välisserver, kasutage järgmist käsku ▼

 curl -sSL https://get.docker.com/ | sh 

Kui tegemist on Hiinas asuva kodumaise serveriga, kasutage järgmist käsku ▼

 curl -sSL https://get.daocloud.io/docker | sh 

Määrake Docker alglaadimisel automaatselt käivituma ▼

systemctl start docker 

systemctl enable docker

Installige Docker-compose 

Kui see on välisserver, kasutage järgmist käsku ▼

sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

Kui tegemist on Hiina kodumaise serveriga, kasutage järgmist käsku▼

curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
chmod +x /usr/local/bin/docker-compose

Taaskäivitage dokiteenuse käsk▼

service docker restart

Kuidas installida Uptime Kuma tasuta veebisaidi oleku jälgimise tööriist?

🐳 Installige Dockeri režiimis, looge konteiner nimega uptime-kuma ▼

docker volume create uptime-kuma
Käivitage konteiner ▼
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1
  • Siis saate läbidaIP:3001Külastage Uptime-Kumat.

Kui olete CSF-i tulemüüri lubanud, peate võib-olla avama CSF-tulemüüri pordi 3001▼

vi /etc/csf/csf.conf
# Allow incoming TCP ports
 TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001" 

Taaskäivitage CSF-i tulemüür ▼

csf -r

Installige Nginx Proxy Manager

Nginx Proxy Manager on Dockeril põhinev pöördpuhverserveri tarkvara.

Kuna Nginx Proxy Manager pole vajalik, võite Nginx Proxy Manageri installimata jätta, kui te ei soovi aega raisata.

Loo kataloog ▼

mkdir -p data/docker_data/npm
cd data/docker_data/npm

Looge fail docker-compose.yml ▼

nano docker-compose.yml

Täitke failis järgmine sisu, seejärel vajutage salvestamiseks klahvikombinatsiooni Ctrl+X, ▼ väljumiseks vajutage Y

version: "3"
services:
  app:
    image: 'jc21/nginx-proxy-manager:latest'
    restart: unless-stopped
    ports:
      # These ports are in format :
      - '80:80' # Public HTTP Port
      - '443:443' # Public HTTPS Port
      - '81:81' # Admin Web Port
      # Add any other Stream port you want to expose
      # - '21:21' # FTP
    environment:
      DB_MYSQL_HOST: "db"
      DB_MYSQL_PORT: 3306
      DB_MYSQL_USER: "npm"
      DB_MYSQL_PASSWORD: "npm"
      DB_MYSQL_NAME: "npm"
      # Uncomment this if IPv6 is not enabled on your host
      # DISABLE_IPV6: 'true'
    volumes:
      - ./data:/data
      - ./letsencrypt:/etc/letsencrypt
    depends_on:
      - db

  db:
    image: 'jc21/mariadb-aria:latest'
    restart: unless-stopped
    environment:
      MYSQL_ROOT_PASSWORD: 'npm'
      MYSQL_DATABASE: 'npm'
      MYSQL_USER: 'npm'
      MYSQL_PASSWORD: 'npm'
    volumes:
      - ./data/mysql:/var/lib/mysql

jooksma▼

docker-compose up -d

Kui kuvatakse järgmisega sarnane tõrketeade: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼

[root@ten npm]# docker-compose up -d
npm_db_1 is up-to-date
Starting npm_app_1 ... error

ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use
ERROR: Encountered errors while bringing up the project.
  • See tähendab, et port 443 on juba hõivatud ja äsja loodud faili docker-compose.yml tuleb redigeerida.

Port 443 tuleb muuta 442-ks ▼

      - '442:442' # Public HTTPS Port

Seejärel käivitage käsk uuesti docker-compose up -d

Ilmub veateade:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"

Samuti tuleb muuta port 80 vastu 882 ▼

      - '882:882' # Public HTTP Port

avamise teel http:// IP:81 Külastage Nginxi puhverserveri haldurit.

Esimesel sisselogimisel kasutage algset vaikekontot ja parooli▼

Email: [email protected]
Password: changeme
  • Pärast sisselogimist muutke kindlasti koheselt oma e-posti aadress ja parool.

Vastupidine puhverserver Uptime Kuma

Pärast Uptime Kuma installimist on vaikimisi kasutadaIP:3001Külastage Uptime Kuma.

Juurdepääs domeeninimele ja SSL-sertifikaadi konfigureerimine on pöördpuhverserveri kaudu, täpselt nagu varem näidatud URL.

Järgmisena teostame pöördgenereerimise toimingud, kasutades varem ehitatud Nginxi puhverserveri haldurit.

Pass http:// IP:81 Avage Nginxi puhverserveri haldur.

Pärast esmast sisselogimist peate muutma kasutajanime ja parooli, palun seadistage see ise.

Järgmisena on Nginxi puhverserveri halduri tööetapid järgmised:

第 1 步:Avatud Proxy Hosts ▼

Uptime Kuma tasuta veebisaidi oleku jälgimise tööriist Linuxi serveri jälgimise tarkvara

第 2 步:Klõpsake paremas ülanurgas Add Proxy Hosts▼

2. samm: Klõpsake paremas ülanurgas nuppu „Lisa puhverserveri hostid”.

3. samm: konfigureerige vastavalt joonisele,点击 Save 保存 ▼ 

3. samm: Konfigureerige sätted pildil näidatud viisil ja seejärel klõpsake nuppu Salvesta.

第 4 步:klõpsaEidtAvage konfiguratsioonileht ▼

4. samm: Konfiguratsioonilehe avamiseks klõpsake nuppu Eidt

5. samm: väljastage SSL-sertifikaat ja lubage sunnitud HTTPS-juurdepääs ▼

5. samm: väljastage SSL-sertifikaat ja lubage kohustuslik juurdepääs HTTPS-ile 

  • Sel hetkel on vastupidine genereerimine lõpetatud ja seejärel saate kasutada äsja otsustatud domeeninime, et pääseda juurde Uptime Kumale.
  • Uptime Kuma konfiguratsioon on väga lihtne.
  • Sellel on Hiina liides, usun, et saate seda varsti kasutada.

Tööaeg Kuma Kasulikud PM2 käsud

Uptime Kuma käivitus-, peatamis- ja taaskäivituskäsud (see käsk on mõeldud mitte-Dockeri installimiseks)▼

pm2 start uptime-kuma
pm2 stop uptime-kuma
pm2 restart uptime-kuma

Vaadake Uptime Kuma praegust konsooli väljundit (see käsk on mõeldud mitte-Dockeri installimiseks)▼

pm2 monit

Käivitage Uptime Kuma käivitamisel (see käsk on mõeldud mitte-Dockeri installidele) ▼

pm2 save && pm2 startup

Kuidas seadistada Uptime Kuma seiretarkvara automaatset varundamist?

Kuna Uptime Kuma taustaseadetes võib esineda probleeme varundusfunktsiooniga, ei ole arendaja varundusfunktsiooni säilitanud. Nüüd ei saa varundusfunktsioon enam täielikku varukoopiat luua ja kõiki seadeid taastada...

Kas soovite lisateavet selle kohta, kuidas toimida Uptime Kuma varundusfunktsiooni aegumise korral? Üksikasjaliku õpetuse lugemise jätkamiseks klõpsake alloleval lingil ▼

Kuidas desinstallida Uptime Kuma seiretarkvara?

Kui Uptime Kuma ei installitud Dockeri abil , kuidas ma selle desinstallin?

Näiteks kui kasutate seda käsku installimiseks mitte-Dockeri viisil▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh

Uptime Kuma desinstallimiseks kasutage järgmist käsku ▼

  1. rikkis  pm2 stop uptime-kuma
  2. kustutada kataloog rm -rf /opt/uptime-kuma

Kuidas Uptime Kuma desinstallida, kui installite selle Dockeri abil?

Käivitage järgmine päringukäsk▼

docker ps -a
  • kirjuta oma kuma Konteineri nimi, mis võib olla uptime-kuma

seiskamiskäsk ▼

  • Paluncontainer_nameValige ülaltoodud päringkuma Konteineri nimi.
docker stop container_name
docker rm container_name

Desinstallige Uptime Kuma ▼

docker volume rm uptime-kuma
docker rmi uptime-kuma

Järeldus

Uptime Kuma liides on puhas ja lihtne ning seda on väga lihtne juurutada ja kasutada.

Uptime Kuma on väga hea valik, kui sul ei ole kõrgeid nõudmisi veebilehe jälgimisele.

发表 评论

您的邮箱地址不会被公开.必填项已用*标注

Leidke Top