Conas monatóireacht seirbhíse a chumasú i CWP Control Panel ServicesMonitor (systemd)

Tá sé ríthábhachtach go gcoinneofaí oibriú seirbhíse cobhsaí ar fhreastalaithe Linux le haghaidh Sinsearach Gréasáin.

Cabhróidh painéal rialaithe CWP leat le huirlisí monatóireachta seirbhíse.

Conas monatóireacht seirbhíse a chumasú i CWP Control Panel ServicesMonitor (systemd)

Conas ServicesMonitor (systemd) a chumasú i bpainéal rialaithe CWP?

Chun monatóireacht seirbhíse a chumasú i CWP:

  1. ceangal le doCWP安装
  2. FaighCumraíocht Seirbhísí-> ServicesMonitor( córas )Roghchlár
  3. Roghnaigh/Iontráil:
    Chumasú dhíchumasú- Déanfaidh sé seo monatóireacht ar sheirbhís a chumasú/a dhíchumasú.
    Email fógraíSeol chuig - Cuir isteach an seoladh ríomhphoist ina bhfaighidh tú fógraí.
    Seiceáil gach- eatramh ama idir seiceálacha
  4. Roghnaigh an tseirbhís is mian leat chun monatóireacht a dhéanamh, mar shampla: mariadb.service, monit.service
  5. cliceáil提交cnaipe.Feicfidh tú teachtaireacht deimhnithe:
Service Monitoring is not enabled
Enabling monitoring in cron
MAILTO=cwp1@ chenweilaing.com
*/15 * * * * root /usr/local/bin/svcMonitor-systemd
Monitoring Enabled: Yes

rabhadh:

  • 如果stádas córasachtá seirbhísUnknown,Ní oibreoidh an mhonatóireacht ar sheirbhísí.
  • Déanfar na seirbhísí roghnaithe chun monatóireacht a dhéanamh a shábháil i gcomhad /usr/local/etc/services-monitor-systemdin.
  • Is féidir jabanna monatóireachta cron a fháil sa chomhad/etc/cron.d/svcMonitor-systemd中dul suas.

Is féidir leat seirbhísí a chur leis/a bhaint de láimh freisin ag baint úsáide as an ordú chkconfig :

chkconfig service_name on
chkconfig service_name off

Mar shampla, nuair a bheidh gach seirbhís atá ar fáil cumasaithe, taispeánfaimid teachtaireachtaí cron mar:

From: (Cron Daemon) <[email protected]>
Subject: Cron <root@cwp1> /usr/local/bin/svcMonitor-systemd

Restarted service amavisd.service on cwp1 at Sat Mar 31 01:00:01 EDT 2018 Job for amavisd.service failed because the control process exited with error code. See “systemctl status amavisd.service” and “journalctl -xe” for details.

Restarted service arp-ethers.service on cwp1 at Sat Mar 31 01:00:03 EDT 2018 Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:04 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name.

See system logs and ‘systemctl status [email protected]‘ for details.

Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name.

Failed to start [email protected]: Unit name [email protected] is missing the instance name.

See system logs and ‘systemctl status [email protected]‘ for details.

Restarted service console-shell.service on cwp1 at Sat Mar 31 01:00:05 EDT 2018 Restarted service garb.service on cwp1 at Sat Mar 31 01:00:06 EDT 2018 Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:07 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name.

See system logs and ‘systemctl status [email protected]‘ for details.

Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name.

Failed to start [email protected]: Unit name [email protected] is missing the instance name.

See system logs and ‘systemctl status [email protected]‘ for details.

Restarted service ntalk.service on cwp1 at Sat Mar 31 01:00:09 EDT 2018 Job for ntalk.service failed because a configured resource limit was exceeded. See “systemctl status ntalk.service” and “journalctl -xe” for details.

Restarted service rdisc.service on cwp1 at Sat Mar 31 01:00:10 EDT 2018 Job for rdisc.service failed because the control process exited with error code. See “systemctl status rdisc.service” and “journalctl -xe” for details.

Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:17 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name.

See system logs and ‘systemctl status [email protected]‘ for details.

Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name.

Failed to start [email protected]: Unit name [email protected] is missing the instance name.

See system logs and ‘systemctl status [email protected]‘ for details.

Restarted service svnserve.service on cwp1 at Sat Mar 31 01:00:18 EDT 2018 Job for svnserve.service failed because the control process exited with error code. See “systemctl status svnserve.service” and “journalctl -xe” for details.

Restarted service tcsd.service on cwp1 at Sat Mar 31 01:00:19 EDT 2018 Job for tcsd.service failed because the control process exited with error code. See “systemctl status tcsd.service” and “journalctl -xe” for details.

Restarted service vzfifo.service on cwp1 at Sat Mar 31 01:00:20 EDT 2020

Painéal Rialaithe CWP Cumasaigh ServicesMonitor (systemd) Físeán Teagaisc

Seo thíos físeán teagaisc YouTube ar conas ServicesMonitor (systemd) a chumasú i bpainéal rialaithe CWP ▼

发表 评论

您的邮箱地址不会被公开。必填项已用*标注

Scrollaigh go dtí an Barr