Cikkkönyvtár
Általában külső lánc promóciót végzünk, és a baráti kapcsolatok optimalizálását ellenőrizni kell.
Ha elveszítjük a backlinkjeinket és a kölcsönös linkjeinket, a SEO- rangsorolásunk is romlik. Ezért nagyon fontos a backlinkelt weboldalak állapotának figyelése.
Miért használja az Uptime Kumát a webhelyek figyelésére?
Hogyan lehet SEO célból monitorozni a backlinkeket?
A backlinkek hozzáadása és a kölcsönös linkek cseréje után általában webhelyfigyelést konfigurálunk az Uptime Robot felhőalapú monitorozó platformon, hogy ellenőrizzük az egyes webhelyek backlink oldalainak kapcsolatát.
A külső láncok és baráti láncok növekvő számával azonban az Uptime Robot felhőplatform korlátozza a megfigyelések számát, ezért frissítenie kell, és fizetnie kell, ha további felhőfigyelő elemeket szeretne hozzáadni.
Ezért használhatjuk a nyílt forráskódú Linux felhőszerver-figyelő szoftvereszközt – az Uptime Kumát.
Milyen szoftver az Uptime Kuma?
Az Uptime Kuma egy nyílt forráskódú Linux szerverfigyelő eszköz, amely hasonló funkciókkal rendelkezik, mint az Uptime Robot.
A többi hasonló webhelyfigyelő eszközhöz képest az Uptime Kuma kevesebb korlátozással támogatja a saját üzemeltetésű szolgáltatásokat.
Ez a cikk bemutatja az Uptime Kuma telepítését és használatát.
Hogyan telepítsem az Uptime Kuma megfigyelő eszközt?
Uptime Kuma, támogatja a Docker telepítését.
Az alábbiakban az Uptime Kuma telepítési lépéseit ismertetjük.
A következő parancsok a program CLI-n keresztüli telepítéséhez használhatók [Ubuntu/ CentOS ]. Interaktív CLI telepítő, Docker támogatással vagy anélkül ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
- Nem ajánlott a fenti telepítési parancs használata: mivel az Uptime Kuma nem Docker módon van telepítve, könnyen meghiúsulhat a telepítés.
- (Az alábbi telepítési parancsot ajánljuk)
Mivel az Uptime Kuma Docker használatával történő telepítése előtt telepítenie kell a Dockert, először telepítse a Dockert.
Telepítse a Dockert és a Docker-compose-t
Frissítse és telepítse a szükséges szoftvert ▼
apt-get update && apt-get install -y wget vim
Ha 404-es hiba lép fel a frissítés során, ellenőrizze az alábbi megoldást▼
Telepítse a Dockert
Ha ez egy idegen szerver, használja a következő parancsot ▼
curl -sSL https://get.docker.com/ | sh
Ha belföldi szerverről van szó Kínában, használja a következő ▼ parancsot
curl -sSL https://get.daocloud.io/docker | sh
Állítsa be a Dockert úgy, hogy automatikusan elinduljon rendszerindításkor ▼
systemctl start docker systemctl enable docker
Telepítse a Docker-compose-t
Ha ez egy idegen szerver, használja a következő parancsot ▼
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose sudo chmod +x /usr/local/bin/docker-compose
Ha belföldi szerverről van szó Kínában, használja a következő parancsot▼
curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose
Indítsa újra a dokkoló szolgáltatás parancsot▼
service docker restart
Hogyan telepítsem az Uptime Kuma ingyenes webhelyállapot-figyelő eszközt?
docker volume create uptime-kuma
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1- Akkor átmehet
IP:3001Látogassa meg az Uptime-Kuma-t.
Ha engedélyezte a CSF tűzfalat, előfordulhat, hogy meg kell nyitnia a 3001-es portot a CSF tűzfalon.
vi /etc/csf/csf.conf # Allow incoming TCP ports TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001"
Indítsa újra a CSF tűzfalat ▼
csf -rTelepítse az Nginx Proxy Managert
Az Nginx Proxy Manager egy Docker-alapú fordított proxyszoftver.
Mivel az Nginx Proxy Manager nem szükséges, ha nem akarja vesztegetni az időt, kihagyhatja az Nginx Proxy Manager telepítését.
Könyvtár létrehozása ▼
mkdir -p data/docker_data/npm cd data/docker_data/npm
Hozzon létre docker-compose.yml fájlt ▼
nano docker-compose.yml
Töltse ki a következő tartalmat a fájlban, majd nyomja le a Ctrl+X billentyűkombinációt a mentéshez, nyomja meg az Y gombot a kilépéshez ▼
version: "3"
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
restart: unless-stopped
ports:
# These ports are in format :
- '80:80' # Public HTTP Port
- '443:443' # Public HTTPS Port
- '81:81' # Admin Web Port
# Add any other Stream port you want to expose
# - '21:21' # FTP
environment:
DB_MYSQL_HOST: "db"
DB_MYSQL_PORT: 3306
DB_MYSQL_USER: "npm"
DB_MYSQL_PASSWORD: "npm"
DB_MYSQL_NAME: "npm"
# Uncomment this if IPv6 is not enabled on your host
# DISABLE_IPV6: 'true'
volumes:
- ./data:/data
- ./letsencrypt:/etc/letsencrypt
depends_on:
- db
db:
image: 'jc21/mariadb-aria:latest'
restart: unless-stopped
environment:
MYSQL_ROOT_PASSWORD: 'npm'
MYSQL_DATABASE: 'npm'
MYSQL_USER: 'npm'
MYSQL_PASSWORD: 'npm'
volumes:
- ./data/mysql:/var/lib/mysql fuss▼
docker-compose up -d
Ha a következőhöz hasonló hibaüzenet jelenik meg: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼
[root@ten npm]# docker-compose up -d npm_db_1 is up-to-date Starting npm_app_1 ... error ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: Encountered errors while bringing up the project.
- Ez azt jelenti, hogy a 443-as port már foglalt, és az imént létrehozott docker-compose.yml fájlt szerkeszteni kell.
A 443-as portot 442 ▼-ra kell módosítani
- '442:442' # Public HTTPS Port
Ezután futtassa újra a parancsot docker-compose up -d
Megjelenik egy hibaüzenet:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"
A 80-as portot is módosítani kell 882-re ▼
- '882:882' # Public HTTP Port
nyitással http:// IP:81 Keresse fel az Nginx Proxy Manager oldalt.
Az első bejelentkezéshez használja az alapértelmezett kezdeti fiókot és jelszót▼
Email: [email protected] Password: changeme
- Bejelentkezés után kérjük, azonnal változtassa meg e-mail címét és jelszavát.
Fordított proxy Uptime Kuma
Az Uptime Kuma telepítése után az alapértelmezett a használatIP:3001Látogassa meg az Uptime Kumát.
Fordított proxyn keresztül érhetjük el a domain nevet és konfigurálhatjuk az SSL-tanúsítványt, akárcsak a korábban bemutatott URL.
Ezután fordított generálási műveleteket hajtunk végre a korábban beépített Nginx Proxy Manager használatával.
által http:// IP:81 Nyissa meg az Nginx Proxy Managert.
Az első bejelentkezés után meg kell változtatnia a felhasználónevet és a jelszót, kérjük, saját maga állítsa be.
Ezután az Nginx Proxy Manager műveleti lépései a következők:
1. lépés:bekapcsol Proxy Hosts ▼

2. lépés:Kattintson a jobb felső sarokra Add Proxy Hosts▼

3. lépés: Konfigurálja az ábra szerint,Kattints Save mentés ▼

4. lépés:KattintsonEidtNyissa meg a konfigurációs oldalt ▼

5. lépés: SSL-tanúsítvány kiadása és kényszerített HTTPS-hozzáférés engedélyezése ▼

- Ezen a ponton a fordított generálás befejeződik, és az imént feloldott domain nevet használhatja az Uptime Kuma eléréséhez.
- Az Uptime Kuma konfigurációja nagyon egyszerű.
- Kínai felülettel rendelkezik, azt hiszem, hamarosan használható lesz.
Üzemidő Kuma Hasznos PM2 parancsok
Az Uptime Kuma indítási, leállítási és újraindítási parancsai (ezt a parancsot nem Docker-telepítésre szánták)▼
pm2 start uptime-kuma pm2 stop uptime-kuma pm2 restart uptime-kuma
Tekintse meg az Uptime Kuma aktuális konzolkimenetét (ezt a parancsot nem Docker-telepítésre szánják)▼
pm2 monit
Futtassa az Uptime Kumát indításkor (ez a parancs nem Docker-telepítésekre vonatkozik) ▼
pm2 save && pm2 startup
Hogyan állíthatom be az Uptime Kuma megfigyelő szoftver automatikus biztonsági mentését?
Mivel az Uptime Kuma háttérbeállításaiban előfordulhatnak problémák a biztonsági mentés funkcióval, a fejlesztő nem tartotta fenn a biztonsági mentés funkciót.
Szeretne többet megtudni arról, hogyan kezelheti az Uptime Kuma biztonsági mentési funkciójának megszűnését? Kattintson az alábbi linkre a részletes oktatóanyag olvasásának folytatásához ▼
Hogyan lehet eltávolítani az Uptime Kuma megfigyelő szoftvert?
Ha az Uptime Kuma nem a Dockerrel lett telepítve , hogyan távolíthatom el?
Például, ha ezt a parancsot nem Docker módon történő telepítéshez használja▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
Az Uptime Kuma eltávolításához használja a következő parancsot ▼
- nem működik
pm2 stop uptime-kuma - könyvtár törlése
rm -rf /opt/uptime-kuma
Hogyan távolítható el az Uptime Kuma, ha a Docker használatával telepíti?
Futtassa a következő lekérdezési parancsot▼
docker ps -a
- írd le a te
kumaA tároló neve, amely lehetuptime-kuma
stop parancs ▼
- kérlek, küldj
container_nameVáltson a fenti lekérdezésrekumaA tároló neve.
docker stop container_name docker rm container_name
Távolítsa el az Uptime Kuma ▼ alkalmazást
docker volume rm uptime-kuma docker rmi uptime-kuma
Következtetés
Az Uptime Kuma felülete letisztult és egyszerű, és nagyon könnyen telepíthető és használható.
Az Uptime Kuma nagyon jó választás, ha nem támaszt magas követelményeket a webhelyfigyeléssel szemben.
Remélhetőleg hasznosnak találod a Chen Weiliang blogján ( https://www.chenweiliang.com/ ) megosztott "Uptime Kuma Free Website Status Monitoring Tool for Linux Server Monitoring" című cikket .
Nyugodtan oszd meg a cikk linkjét: https://www.chenweiliang.com/cwl-29041.html


