სტატიების დირექტორია
ჩვენ ჩვეულებრივ ვაკეთებთ გარე ჯაჭვის პოპულარიზაციას და მეგობრობის ბმულის ოპტიმიზაციას მონიტორინგი სჭირდება.
თუ ჩვენ დავკარგავთ ბექლინკებსა და ორმხრივ ბმულებს, ჩვენი SEO რეიტინგიც დაეცემა. ამიტომ, ბექლინკირებული ვებსაიტების სტატუსის მონიტორინგი ძალიან მნიშვნელოვანია.
რატომ გამოვიყენოთ Uptime Kuma ვებსაიტების მონიტორინგისთვის?
როგორ ვაკონტროლოთ ბექლინკები SEO მიზნებისთვის?
ბექლინკების დამატების და ორმხრივი ბმულების გაცვლის შემდეგ, ჩვენ, როგორც წესი, ვაკონფიგურირებთ ვებსაიტის მონიტორინგს Uptime Robot-ის ღრუბლოვანი მონიტორინგის პლატფორმაზე, რათა შევამოწმოთ თითოეულ ვებსაიტზე ბექლინკების გვერდების დაკავშირებადობა.
თუმცა, გარე ჯაჭვებისა და მეგობრების ჯაჭვების მზარდი რაოდენობის გამო, Uptime Robot ღრუბლოვან პლატფორმას აქვს ლიმიტი მონიტორინგის რაოდენობაზე და თქვენ უნდა განაახლოთ და გადაიხადოთ, რომ გააგრძელოთ ღრუბლოვანი მონიტორინგის მეტი ელემენტის დამატება.
ამიტომ, ჩვენ შეგვიძლია გამოვიყენოთ ღია კოდის Linux ღრუბლოვანი სერვერის მონიტორინგის პროგრამული უზრუნველყოფა - Uptime Kuma.
რა პროგრამაა Uptime Kuma?
Uptime Kuma არის ღია კოდის Linux სერვერის მონიტორინგის ინსტრუმენტი Uptime Robot-ის მსგავსი ფუნქციებით.
ვებსაიტების მონიტორინგის სხვა მსგავს ინსტრუმენტებთან შედარებით, Uptime Kuma მხარს უჭერს თვითმმართველობის ჰოსტინგის სერვისებს ნაკლები შეზღუდვით.
ეს სტატია გაგაცნობთ Uptime Kuma-ს ინსტალაციას და გამოყენებას.
როგორ დავაყენოთ Uptime Kuma მონიტორინგის ინსტრუმენტი?
Uptime Kuma, მხარს უჭერს Docker ინსტალაციას.
ქვემოთ მოცემულია გაკვეთილი Uptime Kuma-ს ინსტალაციის საფეხურებზე.
შემდეგი ბრძანებები განკუთვნილია პროგრამის CLI-ის [Ubuntu/ CentOS ] მეშვეობით ინსტალაციისთვის. ინტერაქტიული CLI ინსტალერი, Docker-ის მხარდაჭერით ან მის გარეშე ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
- არ არის რეკომენდებული ზემოაღნიშნული ინსტალაციის ბრძანების გამოყენება: იმის გამო, რომ Uptime Kuma დაინსტალირებულია არადოკერის გზით, ადვილია ინსტალაციის წარუმატებლობა.
- (ჩვენ გირჩევთ ინსტალაციის ბრძანებას ქვემოთ)
ვინაიდან თქვენ უნდა დააინსტალიროთ Docker Uptime Kuma-ს დაყენებამდე Docker-ის გამოყენებით, ჯერ დააინსტალირეთ Docker.
დააინსტალირეთ Docker და Docker-compose
განაახლეთ და დააინსტალირეთ საჭირო პროგრამული უზრუნველყოფა ▼
apt-get update && apt-get install -y wget vim
თუ განახლების დროს მოხდა 404 შეცდომა, გთხოვთ, შეამოწმოთ ქვემოთ მოცემული გამოსავალი ▼
დააინსტალირეთ Docker
თუ ეს არის უცხოური სერვერი, გთხოვთ გამოიყენოთ შემდეგი ბრძანება ▼
curl -sSL https://get.docker.com/ | sh
თუ ეს არის შიდა სერვერი ჩინეთში, გთხოვთ, გამოიყენოთ შემდეგი ბრძანება ▼
curl -sSL https://get.daocloud.io/docker | sh
დააყენეთ Docker ავტომატურად ჩატვირთვისას ▼
systemctl start docker systemctl enable docker
დააინსტალირეთ Docker-compose
თუ ეს არის უცხოური სერვერი, გთხოვთ გამოიყენოთ შემდეგი ბრძანება ▼
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose sudo chmod +x /usr/local/bin/docker-compose
თუ ეს არის შიდა სერვერი ჩინეთში, გთხოვთ, გამოიყენოთ შემდეგი ბრძანება ▼
curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose
გადატვირთეთ დოკერის სერვისის ბრძანება ▼
service docker restart
როგორ დავაყენოთ Uptime Kuma ვებსაიტის სტატუსის მონიტორინგის უფასო ინსტრუმენტი?
docker volume create uptime-kuma
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1- შემდეგ, შეგიძლიათ გაიაროთ
IP:3001ეწვიეთ Uptime-Kuma-ს.
თუ ჩართული გაქვთ CSF firewall, შეიძლება დაგჭირდეთ 3001 პორტის გახსნა CSF firewall–ზე ▼
vi /etc/csf/csf.conf # Allow incoming TCP ports TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001"
გადატვირთეთ CSF firewall ▼
csf -rდააინსტალირეთ Nginx Proxy Manager
Nginx Proxy Manager არის Docker-ზე დაფუძნებული საპირისპირო მარიონეტული პროგრამა.
ვინაიდან Nginx Proxy Manager არ არის საჭირო, თუ არ გსურთ დროის დაკარგვა, შეგიძლიათ გამოტოვოთ Nginx Proxy Manager-ის ინსტალაცია.
შექმენით დირექტორია ▼
mkdir -p data/docker_data/npm cd data/docker_data/npm
შექმენით docker-compose.yml ფაილი ▼
nano docker-compose.yml
შეავსეთ შემდეგი შინაარსი ფაილში, შემდეგ დააჭირეთ Ctrl+X შესანახად, დააჭირეთ Y-ს გასასვლელად ▼
version: "3"
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
restart: unless-stopped
ports:
# These ports are in format :
- '80:80' # Public HTTP Port
- '443:443' # Public HTTPS Port
- '81:81' # Admin Web Port
# Add any other Stream port you want to expose
# - '21:21' # FTP
environment:
DB_MYSQL_HOST: "db"
DB_MYSQL_PORT: 3306
DB_MYSQL_USER: "npm"
DB_MYSQL_PASSWORD: "npm"
DB_MYSQL_NAME: "npm"
# Uncomment this if IPv6 is not enabled on your host
# DISABLE_IPV6: 'true'
volumes:
- ./data:/data
- ./letsencrypt:/etc/letsencrypt
depends_on:
- db
db:
image: 'jc21/mariadb-aria:latest'
restart: unless-stopped
environment:
MYSQL_ROOT_PASSWORD: 'npm'
MYSQL_DATABASE: 'npm'
MYSQL_USER: 'npm'
MYSQL_PASSWORD: 'npm'
volumes:
- ./data/mysql:/var/lib/mysql run▼
docker-compose up -d
თუ გამოჩნდება შეცდომის მსგავსი შეტყობინება: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use" ▼
[root@ten npm]# docker-compose up -d npm_db_1 is up-to-date Starting npm_app_1 ... error ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: Encountered errors while bringing up the project.
- ეს ნიშნავს, რომ პორტი 443 უკვე დაკავებულია და ახლად შექმნილი docker-compose.yml ფაილი საჭიროებს რედაქტირებას.
პორტი 443 უნდა შეიცვალოს 442 ▼-ით
- '442:442' # Public HTTPS Port
შემდეგ კვლავ გაუშვით ბრძანება docker-compose up -d
გამოჩნდება შეცდომის შეტყობინება:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"
ასევე საჭიროა 80-ის პორტის შეცვლა ▼ 882-ზე
- '882:882' # Public HTTP Port
გახსნით http:// IP:81 ეწვიეთ Nginx პროქსი მენეჯერს.
პირველი შესვლისთვის გამოიყენეთ ნაგულისხმევი საწყისი ანგარიში და პაროლი ▼
Email: [email protected] Password: changeme
- სისტემაში შესვლის შემდეგ, გთხოვთ, დაუყოვნებლივ შეცვალოთ თქვენი ელ.ფოსტის მისამართი და პაროლი.
Reverse Proxy Uptime Kuma
Uptime Kuma-ს დაყენების შემდეგ, ნაგულისხმევი გამოყენებააIP:3001ეწვიეთ Uptime Kuma.
ჩვენ შეგვიძლია დომენის სახელზე წვდომა და SSL სერთიფიკატის კონფიგურაცია საპირისპირო პროქსის მეშვეობით, ისევე როგორც ადრე ნაჩვენები URL.
შემდეგი, ჩვენ შევასრულებთ საპირისპირო გენერირების ოპერაციებს, ადრე აშენებული Nginx Proxy მენეჯერის გამოყენებით.
გაივლის http:// IP:81 გახსენით Nginx Proxy Manager.
პირველად შესვლის შემდეგ, თქვენ უნდა შეცვალოთ მომხმარებლის სახელი და პაროლი, გთხოვთ, თავად დააკონფიგურიროთ.
შემდეგი, Nginx Proxy Manager-ის მუშაობის ეტაპები შემდეგია:
1:打開 Proxy Hosts ▼

2:დააწკაპუნეთ ზედა მარჯვენა კუთხეში Add Proxy Hosts▼

ნაბიჯი 3: კონფიგურაცია ფიგურის მიხედვით,დააჭირეთ Save შენახვა ▼

4:დააწკაპუნეთEidtგახსენით კონფიგურაციის გვერდი ▼

ნაბიჯი 5: გასცეთ SSL სერტიფიკატი და ჩართეთ იძულებითი HTTPS წვდომა ▼

- ამ ეტაპზე, საპირისპირო გენერაცია დასრულებულია და შემდეგ შეგიძლიათ გამოიყენოთ დომენის სახელი, რომელიც ახლახან გადაწყვიტეთ Uptime Kuma-ზე წვდომისთვის.
- Uptime Kuma-ს კონფიგურაცია ძალიან მარტივია.
- აქვს ჩინური ინტერფეისი, მჯერა, რომ მალე შეძლებთ მის გამოყენებას.
სასარგებლო PM2 ბრძანებები Uptime Kuma-სთვის
Uptime Kuma-ს ბრძანებების დაწყება, გაჩერება და გადატვირთვა (ეს ბრძანება ეძღვნება არადოკერის ინსტალაციას) ▼
pm2 start uptime-kuma pm2 stop uptime-kuma pm2 restart uptime-kuma
იხილეთ Uptime Kuma-ის კონსოლის მიმდინარე გამომავალი (ეს ბრძანება ეძღვნება Docker-ის ინსტალაციას) ▼
pm2 monit
გაუშვით Uptime Kuma გაშვებისას (ეს ბრძანება ეძღვნება Docker-ის ინსტალაციას) ▼
pm2 save && pm2 startup
როგორ დავაყენოთ Uptime Kuma მონიტორინგის პროგრამული უზრუნველყოფის ავტომატური სარეზერვო ასლი?
იმის გამო, რომ Uptime Kuma-ს ფონურ პარამეტრებში შეიძლება იყოს სარეზერვო ფუნქციის გარკვეული პრობლემები, დეველოპერს არ აქვს შენახული სარეზერვო ფუნქცია. ახლა სარეზერვო ფუნქციას აღარ შეუძლია სრული სარეზერვო ასლის შექმნა და ყველა პარამეტრის აღდგენა.
გსურთ იცოდეთ მეტი, თუ როგორ უნდა გაუმკლავდეთ Uptime Kuma-ს სარეზერვო ფუნქციის გაუქმებას? დააჭირეთ ქვემოთ მოცემულ ბმულს, რომ გააგრძელოთ დეტალური სახელმძღვანელო ▼
როგორ წავშალო Uptime Kuma მონიტორინგის პროგრამული უზრუნველყოფა?
თუ Uptime Kuma Docker-ის გამოყენებით არ იყო დაინსტალირებული , როგორ უნდა წავშალო ის?
მაგალითად, თუ ამ ბრძანებას იყენებთ არადოკერის მეთოდით ინსტალაციისთვის ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
Uptime Kuma-ს დეინსტალაციისთვის გამოიყენეთ შემდეგი ბრძანება ▼
- სამსახურის გარეშე
pm2 stop uptime-kuma - დირექტორიას წაშლა
rm -rf /opt/uptime-kuma
როგორ წაშალოთ Uptime Kuma, თუ დააინსტალირებთ Docker-ის გამოყენებით?
გაუშვით შემდეგი შეკითხვის ბრძანება ▼
docker ps -a
- ჩაწერეთ თქვენი
kumaკონტეინერის სახელი, რომელიც შეიძლება იყოსuptime-kuma
შეჩერების ბრძანება ▼
- გთხოვთ
container_nameშეცვალეთ ზემოთ მოყვანილი შეკითხვაkumaკონტეინერის სახელი.
docker stop container_name docker rm container_name
Uninstall Uptime Kuma ▼
docker volume rm uptime-kuma docker rmi uptime-kuma
დასკვნა
Uptime Kuma-ს ინტერფეისი არის სუფთა და მარტივი და ძალიან მარტივია განლაგება და გამოყენება.
Uptime Kuma არის ძალიან კარგი არჩევანი, თუ არ გაქვთ მაღალი მოთხოვნები ვებსაიტის მონიტორინგისთვის.
იმედია, ჩენ ვეილიანგის ბლოგზე ( https://www.chenweiliang.com/ ) გამოგადგებათ სტატია „Uptime Kuma Free Website Status Monitoring Tool for Linux Server Monitoring“ .
თავისუფლად გაგვიზიარეთ ამ სტატიის ბმული: https://www.chenweiliang.com/cwl-29041.html


