Uptime Kuma Amûra Çavdêriya Rewşa Malpera Belaş Nermalava Çavdêriya Servera Linux

Em bi gelemperî pêşveçûna girêdana derveyî û xweşbîniya girêdana heval dikin û pêdivî ye ku were şopandin.

Ger em paşgirêdan û girêdanên hevber winda bikin, rêza me ya SEO jî dê kêm bibe. Ji ber vê yekê, şopandina rewşa rûpelên malperên paşgirêdan pir girîng e.

Çima Uptime Kuma bikar bînin ku malpera xwe bişopînin?

Meriv çawa ji bo mebestên SEO-yê backlinks dişopîne?

Piştî zêdekirina paşgirêdan û danûstandina girêdanên hevbeş, em bi gelemperî çavdêriya malperê li ser platforma çavdêriya ewr a Uptime Robot mîheng dikin da ku girêdana rûpelên paşgirêdan li ser her malperê kontrol bikin.

Lêbelê, her ku hejmara girêdanên derveyî û girêdanên hevalan zêde dibe, platforma cloudê ya Uptime Robot li ser hejmara tomarên çavdêriyê sînorek heye, û divê hûn nûve bikin û bidin da ku hûn bêtir tiştên çavdêriya ewr zêde bikin.

Ji ber vê yekê, em dikarin nermalava çavdêriya servera ewr a Linux-ê ya çavkaniya vekirî bikar bînin - Uptime Kuma.

Uptime Kuma çi nermalavê ye?

Uptime Kuma amûrek çavdêriya servera Linux ya çavkaniya vekirî ye ku fonksiyonên mîna Uptime Robot heye.

Li gorî amûrên din ên çavdêriya malperê yên mîna hev, Uptime Kuma bi kêm sînorkirî karûbarên xwemalî piştgirî dike.

Ev gotar dê sazkirin û karanîna Uptime Kuma bide nasandin.

Meriv çawa amûrê çavdêriya Uptime Kuma saz dike?

Uptime Kuma, sazkirina Docker piştgirî dike.

Ya jêrîn dersek li ser gavên sazkirinê yên Uptime Kuma ye.

Fermanên jêrîn ji bo sazkirina bernameyê bi rêya CLI [Ubuntu/ CentOS ] in. Sazkerê CLI yê înteraktîf, bi piştgiriya Docker an bê piştgirî ▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
  • Ne pêşniyar kirin ku emrê sazkirinê ya jorîn bikar bînin: ji ber ku Uptime Kuma bi rengek ne-Docker hatî saz kirin, sazkirin hêsan e ku têk bibe.
  • (Em fermanên sazkirinê yên li jêr pêşniyar dikin)

Ji ber ku berî ku Docker bikar bîne da ku Uptime Kuma saz bike pêdivî ye ku Docker were saz kirin, pêşî Docker saz bikin.

Docker û Docker-compose saz bikin

Nermalava pêwîst ▼ nûve bikin û saz bikin

apt-get update && apt-get install -y wget vim

Ger di dema nûvekirinê de xeletiyek 404 çêbibe, ji kerema xwe çareseriyên jêrîn binihêrin ▼

Docker saz bikin

Heke ew serverek biyanî ye, ji kerema xwe emrê jêrîn ▼ bikar bînin

 curl -sSL https://get.docker.com/ | sh 

Ger ew li Chinaînê serverek navxweyî ye, ji kerema xwe emrê jêrîn ▼ bikar bînin

 curl -sSL https://get.daocloud.io/docker | sh 

Docker saz bikin ku di boot-ê de bixweber dest pê bike

systemctl start docker 

systemctl enable docker

Docker-compose saz bikin 

Ger ew serverek biyanî ye, ji kerema xwe fermana jêrîn bikar bînin ▼

sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

Heke ew li Chinaînê serverek navxweyî ye, ji kerema xwe fermana jêrîn bikar bînin ▼

curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
chmod +x /usr/local/bin/docker-compose

Fermana karûbarê dokerê ji nû ve bidin destpêkirin ▼

service docker restart

Meriv çawa amûra şopandina rewşa malpera belaş Uptime Kuma saz dike?

🐳 Di moda Docker de saz bikin, konteynirek bi navê uptime-kuma ▼ biafirînin

docker volume create uptime-kuma
Destpêkirina konteynerê▼
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1
  • Hingê hûn dikarin derbas bibinIP:3001Serdana Uptime-Kuma bikin.

Ger we dîwarê CSF-ê çalak kiribe, dibe ku hûn hewce bike ku porta 3001 li ser dîwarê CSF-ê vekin ▼

vi /etc/csf/csf.conf
# Allow incoming TCP ports
 TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001" 

CSF Firewall ▼ ji nû ve bidin destpêkirin

csf -r

Rêvebirê Nginx Proxy saz bikin

Rêvebirê Nginx Proxy nermalava berevajî ya berevajî ya Docker-ê ye.

Ji ber ku Gerînendeyê Nginx Proxy ne hewce ye, heke hûn nexwazin wextê wenda bikin hûn dikarin sazkirina Rêvebirê Nginx Proxy berdin.

Navnîşana ▼ çêbikin

mkdir -p data/docker_data/npm
cd data/docker_data/npm

Docker-compose.yml pelê ▼ biafirîne

nano docker-compose.yml

Naveroka jêrîn di pelê de dagirin, paşê Ctrl+X ji bo hilanînê, Yê bikirtînin ku ji ▼ derkeve

version: "3"
services:
  app:
    image: 'jc21/nginx-proxy-manager:latest'
    restart: unless-stopped
    ports:
      # These ports are in format :
      - '80:80' # Public HTTP Port
      - '443:443' # Public HTTPS Port
      - '81:81' # Admin Web Port
      # Add any other Stream port you want to expose
      # - '21:21' # FTP
    environment:
      DB_MYSQL_HOST: "db"
      DB_MYSQL_PORT: 3306
      DB_MYSQL_USER: "npm"
      DB_MYSQL_PASSWORD: "npm"
      DB_MYSQL_NAME: "npm"
      # Uncomment this if IPv6 is not enabled on your host
      # DISABLE_IPV6: 'true'
    volumes:
      - ./data:/data
      - ./letsencrypt:/etc/letsencrypt
    depends_on:
      - db

  db:
    image: 'jc21/mariadb-aria:latest'
    restart: unless-stopped
    environment:
      MYSQL_ROOT_PASSWORD: 'npm'
      MYSQL_DATABASE: 'npm'
      MYSQL_USER: 'npm'
      MYSQL_PASSWORD: 'npm'
    volumes:
      - ./data/mysql:/var/lib/mysql

Run▼

docker-compose up -d

Ger peyamek xeletiyek mîna ya jêrîn xuya bibe: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use" ▼

[root@ten npm]# docker-compose up -d
npm_db_1 is up-to-date
Starting npm_app_1 ... error

ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use
ERROR: Encountered errors while bringing up the project.
  • Ev tê wê wateyê ku ev porta 443 hatiye dagirkirin û hûn hewce ne ku pelê docker-compose.yml ku we nû çêkiriye biguherînin.

Pêdivî ye ku porta 443 bi 442 ▼ biguhezîne

      - '442:442' # Public HTTPS Port

Dûv re, emrê dîsa bimeşînin docker-compose up -d

Dê peyamek xeletiyek xuya bibe:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"

Her weha hûn hewce ne ku porta 80 bi 882 ▼ biguhezînin

      - '882:882' # Public HTTP Port

bi vekirina http:// IP:81 Serdana Gerînendeyê Nginx Proxy bikin.

Dema ku yekem car têketinê, hesabê destpêkê û şîfreya xwerû ▼ bikar bînin

Email: [email protected]
Password: changeme
  • Piştî têketinê, ji kerema xwe re e-name û şîfreya xwe tavilê biguherînin.

Reverse proxy Uptime Kuma

Piştî sazkirina Uptime Kuma, xwerû tê bikar anînIP:3001Serdana Uptime Kuma bikin.

Em dikarin xwe bigihînin navê domainê û sertîfîkaya SSL-ê bi navgîniya berevajî ve mîheng bikin, mîna URL-ya ku berê hatî destnîşan kirin.

Dûv re, em ê operasyona hilberîna berevajî bikin û Rêvebirê Proxy Nginx-ê ku berê hatî çêkirin bikar bînin.

Bi nav http:// IP:81 Rêvebirê Nginx Proxy vekin.

Piştî ku hûn cara yekem têketinê, hûn hewce ne ku navê bikarhêner û şîfreya xwe biguherînin, ji ber vê yekê ji kerema xwe wan bixwe mîheng bikin.

Dûv re, gavên operasyonê yên Gerînendeyê Nginx Proxy wiha ne:

Gav 1:vekirin Proxy Hosts ▼

Uptime Kuma Amûra Çavdêriya Rewşa Malpera Belaş Nermalava Çavdêriya Servera Linux

Gav 2:Li goşeya rastê ya jorîn bikirtînin Add Proxy Hosts▼

Pêngava 2: Li quncikê jorîn ê rastê "Add Proxy Hosts" bikirtînin.

Gav 3: Mîna ku di wêneyê de tê xuyang kirin mîheng bikin,点击 Save rizgarkirin ▼ 

Pêngava 3: Mîhengan wekî ku di wêneyê de tê xuyang kirin saz bikin, dûv re li ser Tomar bike bikirtînin.

Gav 4:bitikîneEidtRûpelê veavakirinê ▼ veke

Gava 4: Ji bo vekirina rûpela mîhengkirinê li ser Eidt bikirtînin

Gava 5: Sertîfîkayek SSL derxîne û gihîştina HTTPS-ya bi zorê çalak bike ▼

Gav 5: Sertîfîkayek SSL derxînin û ketina zorê ya HTTPS çalak bikin 

  • Di vê nuqteyê de, nifşa berevajî qediya, û dûv re hûn dikarin bi navê domainê ku we nû çareser kir bigihîjin Uptime Kuma.
  • Veavakirina Uptime Kuma pir hêsan e.
  • Têkiliyek çînî heye, û ez bawer dikim ku hûn ê di demek nêzîk de dest bi karanîna wê bikin.

Uptime Kuma Fermanên Kêrhatî yên PM2

Fermanên destpêk, rawestandin û ji nû ve destpêkirina Uptime Kuma (ev ferman ji bo sazkirina ne-Docker ve hatî veqetandin) ▼

pm2 start uptime-kuma
pm2 stop uptime-kuma
pm2 restart uptime-kuma

Derketina konsolê ya heyî ya Uptime Kuma bibînin (ev ferman ji bo sazkirina ne-Docker ve hatî veqetandin) ▼

pm2 monit

Di destpêkê de Uptime Kuma bimeşînin (ev ferman bi taybetî ji bo sazkirina ne-Docker e) ▼

pm2 save && pm2 startup

Meriv çawa paşvekêşana otomatîkî ya nermalava çavdêriya Uptime Kuma saz dike?

Ji ber ku di mîhengên paşîn ên Uptime Kuma de dibe ku hin pirsgirêk bi fonksiyona hilanînê hebin, pêşdebir fonksiyona hilanînê neparastiye Naha fonksiyona paşvekişandinê nema dikare hilberek bêkêmasî çêbike û hemî mîhengan vegerîne.

Dixwazin bêtir zanibin ka meriv çawa bi betalkirina taybetmendiya hilanînê ya Uptime Kuma re mijûl dibe? Li ser lînka jêrîn bikirtînin da ku hûn xwendina dersa berfireh ▼ bidomînin

Meriv çawa nermalava çavdêriya Uptime Kuma rakirin?

Eger Uptime Kuma bi karanîna Docker nehatibe sazkirin , ez çawa dikarim wê rakim?

Mînakî, heke hûn rêbaza ne-Docker ya vê fermanê bikar bînin da ku ▼ saz bikin

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh

Ji bo rakirina Uptime Kuma, emrê jêrîn ▼ bikar bînin

  1. bezê rawestîne  pm2 stop uptime-kuma
  2. pelrêça jêbirin rm -rf /opt/uptime-kuma

Ger hûn Docker bikar bînin ku wê saz bikin meriv Uptime Kuma çawa rakirin?

Fermana pirsê ya jêrîn bişopînin ▼

docker ps -a
  • xwe binivîse kuma Navê konteynerê, ku dibe uptime-kuma

Fermana rawestîne ▼

  • Ji kerema xwe vecontainer_nameGuhertina ya ku li jor hatî pirsînkuma Navê konteynerê.
docker stop container_name
docker rm container_name

Uptime Kuma ▼ Rake

docker volume rm uptime-kuma
docker rmi uptime-kuma

Xelasî

Têkiliya Uptime Kuma paqij û berbiçav e, û ew pir hêsan e ku were danîn û bikar anîn.

Ger ji bo şopandina malperê hewcedariyên we yên zêde nînin, Uptime Kuma bijarek pir baş e.

评论

您的邮箱地址不会被公开。必填项已用*标注

Scroll to Top