Uptime Kuma အခမဲ့ ဝဘ်ဆိုဒ် အခြေအနေ စောင့်ကြည့်ရေး ကိရိယာ Linux ဆာဗာ စောင့်ကြည့်ရေး ဆော့ဖ်ဝဲလ်

ကျွန်ုပ်တို့သည် အများအားဖြင့် ပြင်ပ ကွင်းဆက်မြှင့်တင်ရေးနှင့် ချစ်ကြည်ရင်းနှီးမှု လင့်ခ်များကို ပိုမိုကောင်းမွန်အောင် ပြုလုပ်ရန် စောင့်ကြည့်ရန် လိုအပ်ပါသည်။

ကျွန်ုပ်တို့၏ backlink များနှင့် reciprocal link များ ဆုံးရှုံးသွားပါက ကျွန်ုပ်တို့၏ SEO အဆင့်သတ်မှတ်ချက်လည်း ကျဆင်းသွားမည်ဖြစ်သည်။ ထို့ကြောင့် backlinked ဝဘ်ဆိုက်စာမျက်နှာများ၏ အခြေအနေကို စောင့်ကြည့်ခြင်းသည် အလွန်အရေးကြီးပါသည်။

ဝဘ်ဆိုဒ်များကို စောင့်ကြည့်ရန် အဘယ်ကြောင့် Uptime Kuma ကို အသုံးပြုသနည်း။

SEO ရည်ရွယ်ချက်အတွက် backlink တွေကို ဘယ်လိုစောင့်ကြည့်မလဲ ။

backlink များထည့်သွင်းပြီး အပြန်အလှန်လင့်ခ်များဖလှယ်ပြီးနောက်၊ ဝက်ဘ်ဆိုက်တစ်ခုစီရှိ backlink စာမျက်နှာများ၏ ချိတ်ဆက်မှုကိုစစ်ဆေးရန် Uptime Robot cloud monitoring platform တွင် ဝက်ဘ်ဆိုက်စောင့်ကြည့်ခြင်းကို ကျွန်ုပ်တို့ပုံမှန်အားဖြင့် configure လုပ်လေ့ရှိသည်။

သို့ရာတွင်၊ ပြင်ပကွင်းဆက်များနှင့် သူငယ်ချင်းကွင်းဆက်များ တိုးလာခြင်းကြောင့် Uptime Robot cloud ပလပ်ဖောင်းတွင် စောင့်ကြည့်စစ်ဆေးသည့်အရေအတွက်အပေါ် ကန့်သတ်ချက်ရှိပြီး cloud စောင့်ကြည့်စစ်ဆေးသည့်အရာများကို ဆက်လက်ထည့်သွင်းရန်အတွက် အဆင့်မြှင့်ပြီး ငွေပေးချေရပါမည်။

ထို့ကြောင့်၊ ကျွန်ုပ်တို့သည် open-source Linux cloud server monitoring software tool – Uptime Kuma ကို အသုံးပြုနိုင်ပါသည် ။

Uptime Kuma က ဘာဆော့ဖ်ဝဲလ်လဲ။

Uptime Kuma သည် Uptime Robot နှင့်ဆင်တူသောလုပ်ဆောင်ချက်များပါရှိသော open source Linux ဆာဗာစောင့်ကြည့်ရေးကိရိယာတစ်ခုဖြစ်သည်။

အခြားအလားတူ ဝဘ်ဆိုက်စောင့်ကြည့်ရေးကိရိယာများနှင့် နှိုင်းယှဉ်ပါက၊ Uptime Kuma သည် ကန့်သတ်ချက်အနည်းငယ်ဖြင့် ကိုယ်တိုင်လက်ခံဆောင်ရွက်ပေးသည့် ဝန်ဆောင်မှုများကို ပံ့ပိုးပေးပါသည်။

ဤဆောင်းပါးတွင် Uptime Kuma ၏တပ်ဆင်မှုနှင့်အသုံးပြုမှုကိုမိတ်ဆက်ပေးပါမည်။

Uptime Kuma စောင့်ကြည့်ရေးကိရိယာကို မည်သို့ထည့်သွင်းရမည်နည်း။

Uptime Kuma၊ Docker ထည့်သွင်းခြင်းကို ပံ့ပိုးပေးသည်။

အောက်တွင်ဖော်ပြထားသည်မှာ Uptime Kuma ၏တပ်ဆင်မှုအဆင့်များအကြောင်းသင်ခန်းစာတစ်ခုဖြစ်သည်။

အောက်ပါ command များသည် CLI [Ubuntu/ CentOS ] မှတစ်ဆင့် ပရိုဂရမ်ကို ထည့်သွင်းရန် ဖြစ်သည် ။ Docker ပံ့ပိုးမှုပါဝင်သည်ဖြစ်စေ မပါဝင်သည်ဖြစ်စေ အပြန်အလှန်အကျိုးပြု CLI installer ▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
  • အထက်ဖော်ပြပါ တပ်ဆင်မှုအမိန့်ကို အသုံးပြုရန် အကြံပြုလိုသည်မဟုတ်ပါ- Uptime Kuma ကို Docker မဟုတ်သောနည်းဖြင့် ထည့်သွင်းထားသောကြောင့် တပ်ဆင်မှုကို ပျက်ကွက်ရန် လွယ်ကူပါသည်။
  • (အောက်ပါ installation command ကိုကျွန်ုပ်တို့အကြံပြုပါသည်။)

Docker ကိုအသုံးပြု၍ Uptime Kuma ကိုမထည့်သွင်းမီ Docker ကိုထည့်သွင်းရန်လိုအပ်သောကြောင့် Docker ကို ဦးစွာထည့်သွင်းပါ။

Docker နှင့် Docker-compose ကို ထည့်သွင်းပါ။

▼ လိုအပ်သောဆော့ဖ်ဝဲကို အပ်ဒိတ်လုပ်ပြီး ထည့်သွင်းပါ။

apt-get update && apt-get install -y wget vim

အပ်ဒိတ်လုပ်နေစဉ်အတွင်း 404 အမှားဖြစ်ပေါ်ပါက၊ ကျေးဇူးပြု၍ အောက်ပါဖြေရှင်းချက်ကို ▼ စစ်ဆေးပါ။

Docker ကို install လုပ်ပါ။

၎င်းသည် နိုင်ငံခြားဆာဗာဖြစ်ပါက၊ ကျေးဇူးပြု၍ အောက်ပါ command ▼ ကိုအသုံးပြုပါ။

 curl -sSL https://get.docker.com/ | sh 

၎င်းသည် တရုတ်နိုင်ငံရှိ ပြည်တွင်းဆာဗာဖြစ်ပါက၊ ကျေးဇူးပြု၍ အောက်ပါ command ▼ ကို အသုံးပြုပါ။

 curl -sSL https://get.daocloud.io/docker | sh 

▼ boot တွင် အလိုအလျောက်စတင်ရန် Docker ကို သတ်မှတ်ပါ။

systemctl start docker 

systemctl enable docker

Docker-compose ကို ထည့်သွင်းပါ။ 

၎င်းသည် နိုင်ငံခြားဆာဗာဖြစ်ပါက၊ ကျေးဇူးပြု၍ အောက်ပါ command ▼ ကိုအသုံးပြုပါ။

sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

၎င်းသည် တရုတ်နိုင်ငံရှိ ပြည်တွင်းဆာဗာဖြစ်ပါက၊ ကျေးဇူးပြု၍ အောက်ပါ command ▼ ကိုအသုံးပြုပါ။

curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
chmod +x /usr/local/bin/docker-compose

docker ဝန်ဆောင်မှုညွှန်ကြားချက်▼ကို ပြန်လည်စတင်ပါ။

service docker restart

Uptime Kuma အခမဲ့ ဝဘ်ဆိုဒ် အခြေအနေ စောင့်ကြည့်ရေး ကိရိယာကို မည်သို့ ထည့်သွင်းရမည်နည်း။

🐳 Docker မုဒ်တွင် ထည့်သွင်းပါ၊ uptime-kuma ▼ အမည်ရှိ ကွန်တိန်နာတစ်ခုကို ဖန်တီးပါ။

docker volume create uptime-kuma
▼ ကွန်တိန်နာကို စတင်ပါ။
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1
  • ဒါဆိုရင် ကျော်သွားနိုင်ပါတယ်။IP:3001Uptime-Kuma သို့ သွားရောက်ပါ။

အကယ်၍ သင်သည် CSF firewall ကိုဖွင့်ထားပါက၊ သင်သည် CSF firewall တွင် port 3001 ကိုဖွင့်ရန် လိုအပ်နိုင်သည်▼

vi /etc/csf/csf.conf
# Allow incoming TCP ports
 TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001" 

CSF firewall ▼ ကို ပြန်လည်စတင်ပါ။

csf -r

Nginx Proxy Manager ကို ထည့်သွင်းပါ။

Nginx Proxy Manager သည် Docker-based reverse proxy software တစ်ခုဖြစ်သည်။

Nginx Proxy Manager မလိုအပ်သောကြောင့် အချိန်မဖြုန်းလိုပါက Nginx Proxy Manager ကိုထည့်သွင်းခြင်းမပြုဘဲ ကျော်သွားနိုင်ပါသည်။

လမ်းညွှန် ▼ ဖန်တီးပါ။

mkdir -p data/docker_data/npm
cd data/docker_data/npm

docker-compose.yml ဖိုင် ▼ ဖန်တီးပါ။

nano docker-compose.yml

ဖိုင်တွင်အောက်ပါအကြောင်းအရာကိုဖြည့်ပါ၊ ထို့နောက်သိမ်းဆည်းရန် Ctrl+X ကိုနှိပ်ပါ၊ ထွက်ရန် Y ကိုနှိပ်ပါ ▼

version: "3"
services:
  app:
    image: 'jc21/nginx-proxy-manager:latest'
    restart: unless-stopped
    ports:
      # These ports are in format :
      - '80:80' # Public HTTP Port
      - '443:443' # Public HTTPS Port
      - '81:81' # Admin Web Port
      # Add any other Stream port you want to expose
      # - '21:21' # FTP
    environment:
      DB_MYSQL_HOST: "db"
      DB_MYSQL_PORT: 3306
      DB_MYSQL_USER: "npm"
      DB_MYSQL_PASSWORD: "npm"
      DB_MYSQL_NAME: "npm"
      # Uncomment this if IPv6 is not enabled on your host
      # DISABLE_IPV6: 'true'
    volumes:
      - ./data:/data
      - ./letsencrypt:/etc/letsencrypt
    depends_on:
      - db

  db:
    image: 'jc21/mariadb-aria:latest'
    restart: unless-stopped
    environment:
      MYSQL_ROOT_PASSWORD: 'npm'
      MYSQL_DATABASE: 'npm'
      MYSQL_USER: 'npm'
      MYSQL_PASSWORD: 'npm'
    volumes:
      - ./data/mysql:/var/lib/mysql

▼ ပြေး

docker-compose up -d

အောက်ပါကဲ့သို့ အမှားအယွင်း မက်ဆေ့ချ်တစ်ခု ပေါ်လာပါက- "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use“▼

[root@ten npm]# docker-compose up -d
npm_db_1 is up-to-date
Starting npm_app_1 ... error

ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use
ERROR: Encountered errors while bringing up the project.
  • ဆိုလိုသည်မှာ port 443 ကို သိမ်းပိုက်ထားပြီးဖြစ်ပြီး၊ ယခုဖန်တီးထားသော docker-compose.yml ဖိုင်ကို တည်းဖြတ်ရန် လိုအပ်ပါသည်။

Port 443 ကို 442 ▼ သို့ ပြောင်းရန် လိုအပ်သည်။

      - '442:442' # Public HTTPS Port

ထို့နောက် command ကိုထပ်မံလုပ်ဆောင်ပါ။ docker-compose up -d

error message ပေါ်လာပါလိမ့်မယ်“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"

Port 80 မှ 882 ▼ ကိုပြောင်းရန်လည်း လိုအပ်ပါသည်။

      - '882:882' # Public HTTP Port

ဖွင့်လှစ်ခြင်းဖြင့် http:// IP:81 Nginx Proxy Manager သို့သွားပါ။

ပထမဆုံးဝင်ရောက်မှုအတွက်၊ မူရင်းအကောင့်နှင့် စကားဝှက်▼ ကို အသုံးပြုပါ။

Email: [email protected]
Password: changeme
  • အကောင့်ဝင်ပြီးနောက်၊ သင်၏အီးမေးလ်လိပ်စာနှင့် စကားဝှက်ကို ချက်ချင်းပြောင်းရန် သေချာပါစေ။

ပြောင်းပြန် proxy Uptime Kuma

Uptime Kuma ကိုထည့်သွင်းပြီးနောက်၊ ပုံသေကိုအသုံးပြုရန်ဖြစ်သည်။IP:3001Uptime Kuma သို့သွားပါ။

ကျွန်ုပ်တို့သည် အစောပိုင်းကပြသခဲ့သည့် URL ကဲ့သို့ ပြောင်းပြန် proxy မှတစ်ဆင့် ဒိုမိန်းအမည်ကို ဝင်ရောက်ကြည့်ရှုနိုင်ပြီး SSL လက်မှတ်ကို ပုံစံသတ်မှတ်နိုင်သည်။

ထို့နောက်၊ ယခင်တည်ဆောက်ထားသော Nginx Proxy Manager ကို အသုံးပြု၍ ပြောင်းပြန်မျိုးဆက်လည်ပတ်မှုများကို လုပ်ဆောင်ပါမည်။

မှတဆင့် http:// IP:81 Nginx Proxy Manager ကိုဖွင့်ပါ။

ပထမဆုံးအကြိမ် လော့ဂ်အင်ဝင်ပြီးနောက်၊ အသုံးပြုသူအမည်နှင့် စကားဝှက်ကို ပြောင်းလဲရန် လိုအပ်ပြီး ၎င်းကို သင်ကိုယ်တိုင် စီစဉ်သတ်မှတ်ပါ။

ထို့နောက် Nginx Proxy Manager ၏ လုပ်ဆောင်ချက်အဆင့်များမှာ အောက်ပါအတိုင်းဖြစ်သည်။

第1步:ဖွင့်သည် Proxy Hosts ▼

Uptime Kuma အခမဲ့ ဝဘ်ဆိုဒ် အခြေအနေ စောင့်ကြည့်ရေး ကိရိယာ Linux ဆာဗာ စောင့်ကြည့်ရေး ဆော့ဖ်ဝဲလ်

第2步:ညာဘက်အပေါ်ထောင့်ကိုကလစ်နှိပ်ပါ။ Add Proxy Hosts▼

အဆင့် ၂: အပေါ်ညာဘက်ထောင့်ရှိ "Add Proxy Hosts" ကိုနှိပ်ပါ။

အဆင့် 3: ပုံအရ configure၊ကိုနှိပ်ပါ Save သိမ်းဆည်းပါ ▼ 

အဆင့် ၃: ပုံတွင်ပြထားသည့်အတိုင်း setting များကို configure လုပ်ပြီး Save ကိုနှိပ်ပါ။

第4步:နှိပ်ပါ။Eidtဖွဲ့စည်းမှုစာမျက်နှာ ▼ ကိုဖွင့်ပါ။

အဆင့် ၄: ပြင်ဆင်မှုစာမျက်နှာကိုဖွင့်ရန် Eidt ကိုနှိပ်ပါ

အဆင့် ၅: SSL လက်မှတ်ထုတ်ပေးပြီး HTTPS ဝင်ရောက်ခွင့်ကို အတင်းအကျပ်ဖွင့်ပါ ▼

အဆင့် 5- SSL လက်မှတ်ထုတ်ပေးပြီး မဖြစ်မနေ Https အသုံးပြုခွင့်ကို ဖွင့်ပါ။ 

  • ဤအချိန်တွင်၊ ပြောင်းပြန်မျိုးဆက်ပြီးသွားသည်၊ ထို့နောက် Uptime Kuma သို့ဝင်ရောက်ရန် သင်ဆုံးဖြတ်ထားသော ဒိုမိန်းအမည်ကို သင်အသုံးပြုနိုင်ပါသည်။
  • Uptime Kuma ဖွဲ့စည်းမှုပုံစံသည် အလွန်ရိုးရှင်းပါသည်။
  • ၎င်းတွင် တရုတ်အင်တာဖေ့စ်ပါရှိပြီး မကြာမီ သင်အသုံးပြုနိုင်မည်ဟု ယုံကြည်ပါသည်။

အလုပ်ချိန် Kuma အသုံးဝင်သော PM2 အမိန့်များ

Uptime Kuma ၏ ညွှန်ကြားချက်များကို စတင်ရန်၊ ရပ်တန့်ကာ ပြန်လည်စတင်ပါ (ဤအမိန့်ကို Docker တပ်ဆင်ခြင်းမဟုတ်သည့်အတွက် ရည်ရွယ်သည်)▼

pm2 start uptime-kuma
pm2 stop uptime-kuma
pm2 restart uptime-kuma

Uptime Kuma ၏ လက်ရှိ ကွန်ဆိုးလ်အထွက်ကို ကြည့်ပါ (ဤအမိန့်ကို Docker တပ်ဆင်ခြင်းမဟုတ်သည့်အတွက် ရည်ရွယ်သည်)▼

pm2 monit

စတင်ချိန်တွင် Uptime Kuma ကိုဖွင့်ပါ (ဤအမိန့်ကို Docker မဟုတ်သောထည့်သွင်းမှုများအတွက် ရည်ရွယ်သည်) ▼

pm2 save && pm2 startup

Uptime Kuma စောင့်ကြည့်ရေးဆော့ဖ်ဝဲ၏ အလိုအလျောက် အရန်ကူးခြင်းကို မည်သို့သတ်မှတ်ရမည်နည်း။

Uptime Kuma ၏ နောက်ခံဆက်တင်များတွင် မိတ္တူလုပ်ဆောင်မှုတွင် ပြဿနာအချို့ရှိနိုင်သောကြောင့် ဆော့ဖ်ဝဲရေးသားသူသည် အရန်သိမ်းခြင်းလုပ်ဆောင်ချက်ကို မထိန်းသိမ်းနိုင်တော့ဘဲ ယခုအခါ အရန်သိမ်းခြင်းလုပ်ဆောင်ချက်သည် ပြီးပြည့်စုံသော အရန်သိမ်းခြင်းကို ထုတ်ပေးပြီး ဆက်တင်အားလုံးကို ပြန်လည်ရယူနိုင်တော့မည်မဟုတ်ပါ။

Uptime Kuma မိတ္တူအင်္ဂါရပ်ကို ငြင်းပယ်ခြင်းအား မည်သို့ကိုင်တွယ်ရမည်ကို ပိုမိုသိရှိလိုပါသလား။ အသေးစိတ်သင်ခန်းစာ ▼ ဆက်လက်ဖတ်ရှုရန် အောက်ပါလင့်ခ်ကို နှိပ်ပါ။

Uptime Kuma စောင့်ကြည့်ရေးဆော့ဖ်ဝဲကို ဘယ်လိုဖြုတ်မလဲ။

Uptime Kuma ကို Docker သုံးပြီး install မလုပ်ထား ဘူးဆိုရင် ဘယ်လို uninstall လုပ်ရမလဲ။

ဥပမာအားဖြင့်၊ သင်သည် Docker မဟုတ်သောနည်းလမ်းတွင် ထည့်သွင်းရန် ဤ command ကိုအသုံးပြုပါက ▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh

Uptime Kuma ကို ဖြုတ်ရန်၊ အောက်ပါ command ▼ ကို အသုံးပြုပါ။

  1. ပျက်နေသည်  pm2 stop uptime-kuma
  2. လမ်းညွှန်ကိုဖျက်ပါ။ rm -rf /opt/uptime-kuma

Docker ကို အသုံးပြု၍ ထည့်သွင်းပါက Uptime Kuma ကို မည်သို့ ဖြုတ်မည်နည်း။

အောက်ပါ query command ▼ ကို run ပါ။

docker ps -a
  • သင့်အား ချရေးပါ။ kuma ကွန်တိန်နာအမည်၊ uptime-kuma

stop command ▼

  • ကျေးဇူးပြုပြီးပို့ပါcontainer_nameအထက်ပါမေးခွန်းကိုပြောင်းပါ။kuma ကွန်တိန်နာအမည်။
docker stop container_name
docker rm container_name

Uptime Kuma ▼ ကိုဖြုတ်ပါ။

docker volume rm uptime-kuma
docker rmi uptime-kuma

နိဂုံး

Uptime Kuma ၏ မျက်နှာပြင်သည် သန့်ရှင်းပြီး ရိုးရှင်းပြီး အသုံးပြုရန်နှင့် အသုံးပြုရန် အလွန်လွယ်ကူသည်။

ဝဘ်ဆိုဒ်စောင့်ကြည့်ခြင်းအတွက် မြင့်မားသောလိုအပ်ချက်များ မရှိပါက Uptime Kuma သည် အလွန်ကောင်းမွန်သော ရွေးချယ်မှုတစ်ခုဖြစ်သည်။

Chen Weiliang ရဲ့ဘလော့ဂ် ( https://www.chenweiliang.com/ ) မှာ မျှဝေထားတဲ့ "Uptime Kuma Free Website Status Monitoring Tool for Linux Server Monitoring" ဆောင်းပါးက သင့်အတွက် အထောက်အကူဖြစ်လိမ့်မယ်လို့ မျှော်လင့်ပါတယ်။

ဒီဆောင်းပါးလင့်ခ်ကို မျှဝေပေးဖို့ မတွန့်ဆုတ်ပါနဲ့- https://www.chenweiliang.com/cwl-29041.html

နောက်ထပ်လျှို့ဝှက်လှည့်ကွက်များကိုသော့ဖွင့်ရန်🔑၊ ကျွန်ုပ်တို့၏ Telegram ချန်နယ်တွင် ပါဝင်ရန် ကြိုဆိုလိုက်ပါ။

ကြိုက်ရင် Share ပြီး Like လုပ်ပါ။ သင်၏ မျှဝေမှုများနှင့် ကြိုက်နှစ်သက်မှုများသည် ကျွန်ုပ်တို့၏ ဆက်လက်လှုံ့ဆော်မှုဖြစ်သည်။

 

မှတ်ချက်များ

您的邮箱地址不会被公开。必填项已用*标注

ထိပ်တန်းမှလှိမ့်