Maqolalar katalogi
Biz odatda tashqi zanjirni targ'ib qilamiz va do'stlik aloqasini optimallashtirishni kuzatish kerak.
Agar biz orqaga va o'zaro havolalarimizni yo'qotsak, SEO reytingimiz ham pasayadi. Shuning uchun, orqaga havola qilingan veb-sayt sahifalarining holatini kuzatish juda muhimdir.
Nima uchun veb-saytlarni kuzatish uchun Uptime Kuma-dan foydalanish kerak?
SEO maqsadlari uchun orqaga qaytish havolalarini qanday kuzatish mumkin?
Orqaga havolalarni qo'shgandan va o'zaro havolalarni almashgandan so'ng, biz odatda har bir veb-saytdagi orqaga havola sahifalarining ulanishini tekshirish uchun Uptime Robot bulutli monitoring platformasida veb-sayt monitoringini sozlaymiz.
Biroq, tashqi zanjirlar va doʻstlar zanjirlari soni ortib borayotganligi sababli, Uptime Robot bulut platformasi monitoring soni boʻyicha cheklovga ega va siz bulut monitoringini qoʻshishni davom ettirish uchun yangilashingiz va toʻlashingiz kerak.
Shuning uchun biz ochiq kodli Linux bulutli server monitoringi dasturi vositasidan - Uptime Kuma dan foydalanishimiz mumkin.
Uptime Kuma qanday dasturiy ta'minot?
Uptime Kuma - bu Uptime robotiga o'xshash funktsiyalarga ega ochiq manbali Linux server monitoringi vositasi.
Boshqa shunga o'xshash veb-sayt monitoringi vositalari bilan solishtirganda, Uptime Kuma kamroq cheklovlar bilan o'z-o'zidan joylashtirilgan xizmatlarni qo'llab-quvvatlaydi.
Ushbu maqola Uptime Kuma-ni o'rnatish va ishlatish bilan tanishtiradi.
Uptime Kuma monitoring vositasini qanday o'rnatish mumkin?
Uptime Kuma, Docker o'rnatilishini qo'llab-quvvatlaydi.
Quyida Uptime Kuma-ni o'rnatish bosqichlari bo'yicha qo'llanma keltirilgan.
Quyidagi buyruqlar dasturni CLI [Ubuntu/ CentOS ] orqali o'rnatish uchun. Interaktiv CLI o'rnatuvchisi, Docker qo'llab-quvvatlashi bilan yoki qo'llab-quvvatlamasdan ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
- Yuqoridagi o'rnatish buyrug'idan foydalanish tavsiya etilmaydi: Uptime Kuma Docker bo'lmagan usulda o'rnatilganligi sababli, o'rnatish muvaffaqiyatsiz bo'lishi mumkin.
- (Quyidagi o'rnatish buyruqlarini tavsiya qilamiz)
Docker yordamida Uptime Kuma-ni o'rnatishdan oldin Docker-ni o'rnatishingiz kerak bo'lganligi sababli, avval Docker-ni o'rnating.
Docker va Docker-compose ni o'rnating
Kerakli dasturiy ta'minotni yangilang va o'rnating ▼
apt-get update && apt-get install -y wget vim
Yangilash vaqtida 404 xatosi yuzaga kelsa, iltimos, quyidagi yechimni tekshiring▼
Docker-ni o'rnating
Agar u xorijiy server bo'lsa, iltimos, quyidagi buyruqdan foydalaning ▼
curl -sSL https://get.docker.com/ | sh
Agar u Xitoyda mahalliy server bo'lsa, iltimos, quyidagi buyruqdan foydalaning ▼
curl -sSL https://get.daocloud.io/docker | sh
Docker-ni yuklashda avtomatik ishga tushirishga sozlang ▼
systemctl start docker systemctl enable docker
Docker-compose dasturini o'rnating
Agar u xorijiy server bo'lsa, iltimos, quyidagi buyruqdan foydalaning ▼
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose sudo chmod +x /usr/local/bin/docker-compose
Agar u Xitoyda mahalliy server bo'lsa, quyidagi buyruqdan foydalaning▼
curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose
Docker xizmati buyrug'ini qayta ishga tushiring▼
service docker restart
Uptime Kuma bepul veb-sayt holatini kuzatish vositasini qanday o'rnatish mumkin?
docker volume create uptime-kuma
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1- Keyin, siz o'tishingiz mumkin
IP:3001Uptime-Kuma-ga tashrif buyuring.
Agar siz CSF xavfsizlik devorini yoqqan bo'lsangiz, CSF xavfsizlik devorida 3001-portni ochishingiz kerak bo'lishi mumkin▼
vi /etc/csf/csf.conf # Allow incoming TCP ports TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001"
CSF xavfsizlik devorini qayta ishga tushiring ▼
csf -rNginx proksi menejerini o'rnating
Nginx Proksi menejeri - bu Docker-ga asoslangan teskari proksi-server dasturi.
Nginx Proksi menejeri kerak emasligi sababli, vaqtni behuda sarflashni xohlamasangiz, Nginx Proksi menejerini o'rnatmaslikni o'tkazib yuborishingiz mumkin.
Katalog yaratish ▼
mkdir -p data/docker_data/npm cd data/docker_data/npm
docker-compose.yml faylini yarating ▼
nano docker-compose.yml
Faylga quyidagi tarkibni toʻldiring, keyin saqlash uchun Ctrl+X, chiqish uchun Y tugmalarini bosing ▼
version: "3"
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
restart: unless-stopped
ports:
# These ports are in format :
- '80:80' # Public HTTP Port
- '443:443' # Public HTTPS Port
- '81:81' # Admin Web Port
# Add any other Stream port you want to expose
# - '21:21' # FTP
environment:
DB_MYSQL_HOST: "db"
DB_MYSQL_PORT: 3306
DB_MYSQL_USER: "npm"
DB_MYSQL_PASSWORD: "npm"
DB_MYSQL_NAME: "npm"
# Uncomment this if IPv6 is not enabled on your host
# DISABLE_IPV6: 'true'
volumes:
- ./data:/data
- ./letsencrypt:/etc/letsencrypt
depends_on:
- db
db:
image: 'jc21/mariadb-aria:latest'
restart: unless-stopped
environment:
MYSQL_ROOT_PASSWORD: 'npm'
MYSQL_DATABASE: 'npm'
MYSQL_USER: 'npm'
MYSQL_PASSWORD: 'npm'
volumes:
- ./data/mysql:/var/lib/mysql yugurish▼
docker-compose up -d
Agar quyidagiga o'xshash xato xabari paydo bo'lsa: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼
[root@ten npm]# docker-compose up -d npm_db_1 is up-to-date Starting npm_app_1 ... error ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: Encountered errors while bringing up the project.
- Bu shuni anglatadiki, 443-port allaqachon band va hozirgina yaratilgan docker-compose.yml fayli tahrir qilinishi kerak.
443 portni 442 ▼ ga o'zgartirish kerak
- '442:442' # Public HTTPS Port
Keyin buyruqni qayta ishga tushiring docker-compose up -d
Xato xabari paydo bo'ladi:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"
Shuningdek, 80 portini 882 ga o'zgartirish kerak ▼
- '882:882' # Public HTTP Port
ochish orqali http:// IP:81 Nginx proksi menejeriga tashrif buyuring.
Birinchi kirish uchun standart hisob qaydnomasi va paroldan foydalaning▼
Email: [email protected] Password: changeme
- Tizimga kirganingizdan so'ng, elektron pochta manzilingiz va parolingizni darhol o'zgartirishni unutmang.
Teskari proksi ish vaqti Kuma
Uptime Kuma-ni o'rnatgandan so'ng, sukut bo'yicha foydalanish kerakIP:3001Uptime Kuma-ga tashrif buyuring.
Biz domen nomiga kirishimiz va SSL sertifikatini teskari proksi-server orqali sozlashimiz mumkin, xuddi ilgari ko'rsatilgan URL.
Keyinchalik, biz ilgari qurilgan Nginx Proksi menejeri yordamida teskari avlod operatsiyalarini bajaramiz.
Pass http:// IP:81 Nginx proksi menejerini oching.
Birinchi marta kirganingizdan so'ng foydalanuvchi nomi va parolni o'zgartirishingiz kerak, uni o'zingiz sozlang.
Keyinchalik, Nginx Proksi menejerining ishlash bosqichlari quyidagicha:
1 yil:yoqish; ishga tushirish Proxy Hosts ▼

2 yil:Yuqori o'ng burchakni bosing Add Proxy Hosts▼

3-qadam: Rasmga muvofiq sozlang,Bosing Save saqlash ▼

4 yil:bosingEidtKonfiguratsiya sahifasini oching ▼

5-qadam: SSL sertifikatini bering va majburiy HTTPS kirishini yoqing ▼

- Shu nuqtada, teskari avlod tugallanadi va keyin siz Uptime Kuma-ga kirish uchun siz hal qilgan domen nomidan foydalanishingiz mumkin.
- Uptime Kuma konfiguratsiyasi juda oddiy.
- U xitoycha interfeysga ega, tez orada undan foydalanishingiz mumkinligiga ishonaman.
Ish vaqti Kuma Foydali PM2 buyruqlari
Uptime Kuma-ni ishga tushirish, to'xtatish va qayta ishga tushirish buyruqlari (bu buyruq Docker bo'lmagan o'rnatishga bag'ishlangan)▼
pm2 start uptime-kuma pm2 stop uptime-kuma pm2 restart uptime-kuma
Uptime Kuma-ning joriy konsol chiqishini ko'ring (bu buyruq Docker bo'lmagan o'rnatishga bag'ishlangan)▼
pm2 monit
Ishga tushganda Uptime Kuma-ni ishga tushiring (bu buyruq Docker bo'lmagan o'rnatishlarga bag'ishlangan) ▼
pm2 save && pm2 startup
Uptime Kuma monitoring dasturining avtomatik zaxira nusxasini qanday sozlash mumkin?
Uptime Kuma-ning fon sozlamalarida zaxira funksiyasi bilan bog'liq ba'zi muammolar bo'lishi mumkinligi sababli, ishlab chiquvchi zaxira funktsiyasini saqlab qolmagan.
Uptime Kuma zaxira funksiyasini bekor qilish bilan qanday kurashish haqida ko'proq bilmoqchimisiz? Batafsil o'quv qo'llanmasini o'qishni davom ettirish uchun quyidagi havolani bosing ▼
Uptime Kuma monitoring dasturini qanday o'chirish mumkin?
Agar Uptime Kuma Docker yordamida o'rnatilmagan bo'lsa, uni qanday o'chirib tashlayman?
Misol uchun, agar siz ushbu buyruqni Docker bo'lmagan usulda o'rnatish uchun foydalansangiz▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
Uptime Kuma-ni o'chirish uchun quyidagi buyruqdan foydalaning ▼
- Xizmatdan tashqari
pm2 stop uptime-kuma - katalogni o'chirish
rm -rf /opt/uptime-kuma
Docker yordamida o'rnatgan bo'lsangiz, Uptime Kuma-ni qanday o'chirish mumkin?
Quyidagi so'rov buyrug'ini bajaring▼
docker ps -a
- o'zingizni yozing
kumaBo'lishi mumkin bo'lgan konteyner nomiuptime-kuma
to'xtatish buyrug'i ▼
- Iltimos, jo'nating
container_nameYuqoridagi so'rovga o'zgartiringkumaKonteynerning nomi.
docker stop container_name docker rm container_name
Uptime Kuma ▼-ni o'chirib tashlang
docker volume rm uptime-kuma docker rmi uptime-kuma
Xulosa
Uptime Kuma interfeysi toza va sodda, uni joylashtirish va ishlatish juda oson.
Agar veb-sayt monitoringi uchun yuqori talablaringiz bo'lmasa, Uptime Kuma juda yaxshi tanlovdir.
Umid qilamizki, Chen Weiliangning blogida ( https://www.chenweiliang.com/ ) ulashilgan "Uptime Kuma Free Website Status Monitoring Tool for Linux Server Monitoring" maqolasi siz uchun foydali bo'ladi.
Ushbu maqola havolasini ulashing: https://www.chenweiliang.com/cwl-29041.html


