የአንቀጽ ማውጫ
እኛ ብዙውን ጊዜ የውጭ ሰንሰለት ማስተዋወቅን እናደርጋለን እና የጓደኝነት አገናኝ ማመቻቸት መከታተል ያስፈልጋል።
የኋላ አገናኞችን እና የተገላቢጦሽ አገናኞችን ካጣን፣ የSEO ደረጃችንም ይቀንሳል። ስለዚህ፣ የኋላ አገናኞችን የድረ-ገጽ ገጾች ሁኔታ መከታተል በጣም አስፈላጊ ነው።
ድረ-ገጾችን ለመከታተል Uptime Kuma ለምን ይጠቀሙ?
ለ SEO ዓላማዎች የኋላ አገናኞችን እንዴት መከታተል እንደሚቻል?
የኋላ አገናኞችን ካከልን እና የተገላቢጦሽ አገናኞችን ከተለዋወጥን በኋላ፣ በእያንዳንዱ ድር ጣቢያ ላይ የኋላ አገናኞችን ግንኙነት ለማረጋገጥ በUptime Robot የደመና ክትትል መድረክ ላይ የድር ጣቢያ ክትትልን እናዋቅራለን።
ነገር ግን፣ የውጭ ሰንሰለቶች እና የጓደኛ ሰንሰለቶች ቁጥር እየጨመረ በመምጣቱ የ Uptime Robot ደመና መድረክ በክትትል ብዛት ላይ ገደብ አለው፣ እና ተጨማሪ የደመና መቆጣጠሪያ እቃዎችን ለመጨመር ማሻሻል እና መክፈል አለቦት።
ስለዚህ፣ ክፍት ምንጭ የሊኑክስ ክላውድ ሰርቨር ክትትል ሶፍትዌር መሳሪያን - Uptime Kuma - መጠቀም እንችላለን።
Uptime Kuma ምን ሶፍትዌር ነው?
Uptime Kuma ከ Uptime Robot ጋር ተመሳሳይ ተግባር ያለው የሊኑክስ አገልጋይ መከታተያ መሳሪያ ነው።
ከሌሎች ተመሳሳይ የድር ጣቢያ መከታተያ መሳሪያዎች ጋር ሲነጻጸር, Uptime Kuma በራስ የሚስተናገዱ አገልግሎቶችን በትንሽ ገደቦች ይደግፋል.
ይህ ጽሑፍ የ Uptime Kumaን መጫን እና መጠቀምን ያስተዋውቃል.
የ Uptime Kuma መቆጣጠሪያ መሳሪያ እንዴት እንደሚጫን?
Uptime Kuma, Docker መጫንን ይደግፋል.
የሚከተለው ስለ Uptime Kuma የመጫኛ ደረጃዎች አጋዥ ስልጠና ነው።
የሚከተሉት ትዕዛዞች ፕሮግራሙን በCLI [ኡቡንቱ/ ሴንትሮስ ] በኩል ለመጫን ናቸው። በይነተገናኝ የCLI ጫኝ፣ ከDocker ድጋፍ ጋር ወይም ያለሱ ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
- ከላይ የተጠቀሰውን የመጫኛ ትዕዛዝ መጠቀም አይመከርም-ምክንያቱም Uptime Kuma የተጫነው ዶከር ባልሆነ መንገድ ነው, መጫኑን ለማሰናከል ቀላል ነው.
- (ከዚህ በታች ያለውን የመጫኛ ትዕዛዝ እንመክራለን)
ዶከርን በመጠቀም Uptime Kumaን ከመጫንዎ በፊት ዶከርን መጫን ስለሚያስፈልግ መጀመሪያ Dockerን ይጫኑ።
Docker እና Docker-Compose ጫን
አስፈላጊውን ሶፍትዌር ያዘምኑ እና ይጫኑ ▼
apt-get update && apt-get install -y wget vim
በዝማኔው ወቅት 404 ስህተት ከተፈጠረ፣ እባክዎ ከታች ያለውን መፍትሄ ይመልከቱ▼
Docker ን ጫን
የውጭ አገልጋይ ከሆነ፣ እባክዎ የሚከተለውን ትዕዛዝ ይጠቀሙ
curl -sSL https://get.docker.com/ | sh
በቻይና ውስጥ የአገር ውስጥ አገልጋይ ከሆነ እባክዎ የሚከተለውን ትዕዛዝ ይጠቀሙ ▼
curl -sSL https://get.daocloud.io/docker | sh
ቡት ▼ በራስ ሰር እንዲጀምር Docker ያቀናብሩ
systemctl start docker systemctl enable docker
Docker-Compose ን ይጫኑ
የውጭ አገልጋይ ከሆነ፣ እባክዎ የሚከተለውን ትዕዛዝ ይጠቀሙ
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose sudo chmod +x /usr/local/bin/docker-compose
በቻይና ውስጥ የአገር ውስጥ አገልጋይ ከሆነ እባክዎ የሚከተለውን ትዕዛዝ ይጠቀሙ▼
curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose
የመትከያ አገልግሎት ትዕዛዙን እንደገና ያስጀምሩ
service docker restart
Uptime Kuma ነፃ የድር ጣቢያ ሁኔታ መከታተያ መሳሪያ እንዴት እንደሚጫን?
docker volume create uptime-kuma
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1- ከዚያ, ማለፍ ይችላሉ
IP:3001Uptime-Kumaን ይጎብኙ።
የሲኤስኤፍ ፋየርዎልን ካነቃህ፣ በCSF ፋየርዎል ላይ ወደብ 3001 መክፈት ያስፈልግህ ይሆናል።
vi /etc/csf/csf.conf # Allow incoming TCP ports TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001"
የሲኤስኤፍ ፋየርዎልን እንደገና ያስጀምሩ ▼
csf -rNginx Proxy Manager ጫን
Nginx Proxy Manager በ Docker ላይ የተመሰረተ የተገላቢጦሽ ፕሮክሲ ሶፍትዌር ነው።
Nginx Proxy Manager አስፈላጊ ስላልሆነ ጊዜ ማባከን ካልፈለጉ Nginx Proxy Managerን አለመጫን መዝለል ይችላሉ።
ማውጫ ይፍጠሩ ▼
mkdir -p data/docker_data/npm cd data/docker_data/npm
docker-compose.yml ፋይል ይፍጠሩ ▼
nano docker-compose.yml
በፋይሉ ውስጥ የሚከተለውን ይዘት ይሙሉ፣ከዚያም ለማስቀመጥ Ctrl+X ይጫኑ፣ለመውጣት Yን ይጫኑ▼
version: "3"
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
restart: unless-stopped
ports:
# These ports are in format :
- '80:80' # Public HTTP Port
- '443:443' # Public HTTPS Port
- '81:81' # Admin Web Port
# Add any other Stream port you want to expose
# - '21:21' # FTP
environment:
DB_MYSQL_HOST: "db"
DB_MYSQL_PORT: 3306
DB_MYSQL_USER: "npm"
DB_MYSQL_PASSWORD: "npm"
DB_MYSQL_NAME: "npm"
# Uncomment this if IPv6 is not enabled on your host
# DISABLE_IPV6: 'true'
volumes:
- ./data:/data
- ./letsencrypt:/etc/letsencrypt
depends_on:
- db
db:
image: 'jc21/mariadb-aria:latest'
restart: unless-stopped
environment:
MYSQL_ROOT_PASSWORD: 'npm'
MYSQL_DATABASE: 'npm'
MYSQL_USER: 'npm'
MYSQL_PASSWORD: 'npm'
volumes:
- ./data/mysql:/var/lib/mysql መሮጥ▼
docker-compose up -d
ከሚከተለው ጋር የሚመሳሰል የስህተት መልእክት ከታየ፡"Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use" ▼
[root@ten npm]# docker-compose up -d npm_db_1 is up-to-date Starting npm_app_1 ... error ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: Encountered errors while bringing up the project.
- ይህ ማለት ወደብ 443 ቀድሞውኑ ተይዟል እና አሁን የተፈጠረውን docker-compose.yml ፋይል ማረም አለበት ማለት ነው።
ወደብ 443 ወደ 442 ▼ መቀየር ያስፈልገዋል
- '442:442' # Public HTTPS Port
ከዚያ ትዕዛዙን እንደገና ያሂዱ docker-compose up -d
የስህተት መልእክት ይመጣል፡-“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"
እንዲሁም ወደብ 80 ወደ 882 ▼ መቀየር ያስፈልጋል
- '882:882' # Public HTTP Port
በመክፈት http:// IP:81 Nginx ፕሮክሲ አስተዳዳሪን ይጎብኙ።
ለመጀመሪያው መግቢያ ነባሪውን የመጀመሪያ መለያ እና የይለፍ ቃል ይጠቀሙ▼
Email: [email protected] Password: changeme
- ከገቡ በኋላ፣ እባክዎ የኢሜል አድራሻዎን እና የይለፍ ቃልዎን ወዲያውኑ መለወጥዎን ያረጋግጡ።
የተገላቢጦሽ ተኪ Uptime Kuma
Uptime Kumaን ከጫኑ በኋላ ነባሪው መጠቀም ነው።IP:3001Uptime Kumaን ይጎብኙ።
ቀደም ሲል እንደታየው ዩአርኤል የጎራ ስም ልንደርስበት እና የኤስኤስኤል እውቅና ማረጋገጫ በተገላቢጦሽ ፕሮክሲ ማዋቀር እንችላለን።
በመቀጠል፣ ከዚህ ቀደም የተሰራውን Nginx Proxy Manager በመጠቀም የተገላቢጦሽ የማመንጨት ስራዎችን እንሰራለን።
ይለፉ http:// IP:81 Nginx Proxy Manager ን ይክፈቱ።
ለመጀመሪያ ጊዜ ከገቡ በኋላ የተጠቃሚ ስም እና የይለፍ ቃል መቀየር አለብዎት, እባክዎን እራስዎ ያዋቅሩት.
በመቀጠል የ Nginx Proxy Manager የስራ ደረጃዎች እንደሚከተለው ናቸው
ደረጃ 1ማዞር Proxy Hosts ▼

ደረጃ 2በላይኛው ቀኝ ጥግ ላይ ጠቅ ያድርጉ Add Proxy Hosts▼

ደረጃ 3: በሥዕሉ መሠረት ያዋቅሩመታ ያድርጉ Save አስቀምጥ ▼

ደረጃ 4ጠቅ ያድርጉEidtየማዋቀሪያ ገጹን ይክፈቱ ▼

ደረጃ 5፡ የኤስኤስኤል ሰርተፊኬት መስጠት እና የግዳጅ የኤችቲቲፒኤስ መዳረሻን ማንቃት ▼

- በዚህ ጊዜ፣ የተገላቢጦሽ ትውልዱ ይጠናቀቃል፣ እና ከዚያ Uptime Kumaን ለማግኘት አሁን የወሰኑትን የጎራ ስም መጠቀም ይችላሉ።
- Uptime Kuma ውቅር በጣም ቀላል ነው።
- የቻይንኛ በይነገጽ አለው፣ በቅርቡ ሊጠቀሙበት እንደሚችሉ አምናለሁ።
Uptime Kuma ጠቃሚ PM2 ትዕዛዞች
የ Uptime Kuma ትዕዛዞችን ይጀምሩ ፣ ያቁሙ እና እንደገና ያስጀምሩ (ይህ ትእዛዝ ለዶከር ጭነት ብቻ የተወሰነ ነው) ▼
pm2 start uptime-kuma pm2 stop uptime-kuma pm2 restart uptime-kuma
የ Uptime Kuma የኮንሶል ውፅዓት ይመልከቱ (ይህ ትእዛዝ ለዶከር ጭነት ብቻ የተሰጠ ነው)▼
pm2 monit
ጅምር ላይ Uptime Kumaን ያሂዱ (ይህ ትእዛዝ ለዶከር ላልሆኑ ጭነቶች የተሰጠ ነው) ▼
pm2 save && pm2 startup
የ Uptime Kuma ክትትል ሶፍትዌር አውቶማቲክ ምትኬን እንዴት ማዘጋጀት ይቻላል?
በኡፕታይም ኩማ ዳራ ቅንጅቶች ውስጥ በመጠባበቂያ ተግባር ላይ አንዳንድ ችግሮች ሊኖሩ ስለሚችሉ፣ ገንቢው የመጠባበቂያ ተግባሩን አላቆየውም አሁን የመጠባበቂያ ተግባሩ ሙሉ መጠባበቂያ መፍጠር እና ሁሉንም መቼቶች ወደነበረበት መመለስ አልቻለም።
የ Uptime Kuma ምትኬ ባህሪ መቋረጥን እንዴት መቋቋም እንደሚቻል የበለጠ ማወቅ ይፈልጋሉ? ዝርዝር አጋዥ ስልጠናውን ማንበብ ለመቀጠል ከታች ያለውን ሊንክ ይጫኑ ▼
የ Uptime Kuma ክትትል ሶፍትዌርን እንዴት ማራገፍ ይቻላል?
Uptime Kuma Dockerን በመጠቀም ካልተጫነ ፣ እንዴት ማራገፍ እችላለሁ?
ለምሳሌ፣ ይህን ትእዛዝ ከዶከር ውጪ ለመጫን ከተጠቀሙ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
Uptime Kumaን ለማራገፍ የሚከተለውን ትዕዛዝ ▼ ይጠቀሙ
- ከአገልግሎት ውጪ
pm2 stop uptime-kuma - ማውጫ ሰርዝ
rm -rf /opt/uptime-kuma
ዶከርን ተጠቅመው ከጫኑ Uptime Kumaን እንዴት ማራገፍ ይቻላል?
የሚከተለውን የጥያቄ ትዕዛዝ ያሂዱ▼
docker ps -a
- የእርስዎን ይፃፉ
kumaየመያዣው ስም, ሊሆን ይችላልuptime-kuma
ትእዛዝ አቁም ▼
- እባክህ ቀይር
container_nameከላይ ወዳለው ጥያቄ ቀይርkumaየመያዣው ስም.
docker stop container_name docker rm container_name
Uptime Kuma ▼ አራግፍ
docker volume rm uptime-kuma docker rmi uptime-kuma
ማጠቃለያ
የ Uptime Kuma በይነገጽ ንጹህ እና ቀላል ነው፣ እና ለማሰማራት እና ለመጠቀም በጣም ቀላል ነው።
ለድር ጣቢያ ክትትል ከፍተኛ መስፈርቶች ከሌሉ Uptime Kuma በጣም ጥሩ ምርጫ ነው።
በቼን ዌይሊያንግ ጦማር ( https://www.chenweiliang.com/ ) ላይ የተጋራው "የሊኑክስ አገልጋይ ክትትል የሚደረግበት የUptime Kuma ነፃ የድረገጽ ሁኔታ ክትትል መሳሪያ" የሚለው ጽሑፍ ለእርስዎ ጠቃሚ እንደሚሆን ተስፋ እናደርጋለን።
የዚህን ጽሑፍ ሊንክ ለማጋራት ነፃነት ይሰማዎ፦ https://www.chenweiliang.com/cwl-29041.html


