Надстройте MySQL базата данни на панела VestaCP до MariaDB версия 10.4.6, използвайки Linux хост .

Неочаквано въведете следната команда▼
mysql -uroot -p
- Въведете парола за влизанеMySQL.
Възниква следната грешка ▼
ГРЕШКА 1045 (28000): Достъпът е отказан за потребител 'root'@'localhost' (с парола: ДА)
Обикновено тази грешка се причинява от грешна потребителска парола на root за MySQL данни, решението разбира се е да нулирате паролата.
Как да коригирате грешката MySQL ERROR 1045 (28000)?
Стъпка 1: След като влезете с помощта на SSH софтуер , въведете следната команда, за да спрете базата данни MySQL ▼
systemctl stop mysqld
Стъпка 2: Стартирайте MySQL, използвайки следната команда, без да проверявате разрешенията ▼
mysqld --skip-grant-tables &
В този момент беше докладвана друга грешка ▼
[ГРЕШКА] Фатална грешка: Моля, прочетете раздела „Сигурност“ на ръководството, за да разберете как да стартирате mysqld като root!
Моля, SSH и въведете следната команда ▼
mysqld --user=root --skip-grant-tables &
Стъпка 3: Влезте в MySQL чрез SSH ▼
mysql -uroot
或
mysql
Стъпка 4: Актуализирайте root паролата
Mysql5.7 или по-нова ▼
UPDATE mysql.user SET Password=PASSWORD('123456') where USER='root';Mysql5.7 версия ▼
UPDATE mysql.user SET authentication_string=PASSWORD('123456') where USER='root';Стъпка 5: Обновяване на разрешенията ▼
flush privileges;
Стъпка 6: Излезте от MySQL ▼
exit
或
quit
Стъпка 7: Влезте отново в MySQL като root потребител ▼
Mysql -uroot -p
- Въведете паролата:
<输入刚改好的密码123456>
Надяваме се, че статията „Solving ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)“, споделена в блога на Чен Вейлианг ( https://www.chenweiliang.com/ ), ще ви бъде полезна.
Чувствайте се свободни да споделите линка към тази статия: https://www.chenweiliang.com/cwl-1094.html
