ওয়েবসাইট এসইও- এর জন্য লিনাক্স সার্ভারে স্থিতিশীল পরিষেবা চালু রাখা অত্যন্ত গুরুত্বপূর্ণ ।
CWP কন্ট্রোল প্যানেল আপনাকে পরিষেবা পর্যবেক্ষণ সরঞ্জামগুলির সাহায্যে সাহায্য করবে।

কিভাবে CWP কন্ট্রোল প্যানেলে ServicesMonitor (systemd) সক্ষম করবেন?
CWP-তে পরিষেবা পর্যবেক্ষণ সক্ষম করতে:
- আপনার সাথে সংযোগ করুনCWP安装
- 找সার্ভিস কনফিগারেশন-> সার্ভিসেস মনিটর( systemd হল )选项
- নির্বাচন করুন/প্রবেশ করুন:
চালু অচল- এটি পরিষেবা পর্যবেক্ষণ সক্ষম/অক্ষম করবে।
Email বিজ্ঞপ্তিপাঠান - ইমেল ঠিকানা লিখুন যেখানে আপনি বিজ্ঞপ্তি পাবেন।
প্রতিটি পরীক্ষা করুন- চেকের মধ্যে সময়ের ব্যবধান - আপনি যে পরিষেবাটি নিরীক্ষণ করতে চান তা নির্বাচন করুন, উদাহরণস্বরূপ: mariadb.service, monit.service৷
- ক্লিক করুন提交বোতামআপনি একটি নিশ্চিতকরণ বার্তা দেখতে পাবেন:
Service Monitoring is not enabled Enabling monitoring in cron MAILTO=cwp1@ chenweilaing.com */15 * * * * root /usr/local/bin/svcMonitor-systemd Monitoring Enabled: Yes
নিরাপত্তা:
- ক্ষেত্রেসিস্টেমড অবস্থাসেবা হল
Unknown,সেবার জন্য মনিটরিং কাজ করবে না। - নিরীক্ষণের জন্য নির্বাচিত পরিষেবাগুলি ফাইলে সংরক্ষণ করা হবে
/usr/local/etc/services-monitor-systemdভিতরে. - মনিটরিং ক্রোন কাজ ফাইলে পাওয়া যাবে
/etc/cron.d/svcMonitor-systemdমাঝারিচালু
এছাড়াও আপনি chkconfig কমান্ড ব্যবহার করে ম্যানুয়ালি সার্ভিস যোগ বা অপসারণ করতে পারেন:
chkconfig service_name onchkconfig service_name off
উদাহরণস্বরূপ, যখন সমস্ত উপলব্ধ পরিষেবাগুলি সক্ষম করা হয়, তখন আমরা ক্রোন বার্তাগুলি প্রদর্শন করব যেমন:
From: (Cron Daemon) <[email protected]> Subject: Cron <root@cwp1> /usr/local/bin/svcMonitor-systemd Restarted service amavisd.service on cwp1 at Sat Mar 31 01:00:01 EDT 2018 Job for amavisd.service failed because the control process exited with error code. See “systemctl status amavisd.service” and “journalctl -xe” for details. Restarted service arp-ethers.service on cwp1 at Sat Mar 31 01:00:03 EDT 2018 Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:04 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name. Failed to start [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Restarted service console-shell.service on cwp1 at Sat Mar 31 01:00:05 EDT 2018 Restarted service garb.service on cwp1 at Sat Mar 31 01:00:06 EDT 2018 Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:07 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name. Failed to start [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Restarted service ntalk.service on cwp1 at Sat Mar 31 01:00:09 EDT 2018 Job for ntalk.service failed because a configured resource limit was exceeded. See “systemctl status ntalk.service” and “journalctl -xe” for details. Restarted service rdisc.service on cwp1 at Sat Mar 31 01:00:10 EDT 2018 Job for rdisc.service failed because the control process exited with error code. See “systemctl status rdisc.service” and “journalctl -xe” for details. Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:17 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name. Failed to start [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Restarted service svnserve.service on cwp1 at Sat Mar 31 01:00:18 EDT 2018 Job for svnserve.service failed because the control process exited with error code. See “systemctl status svnserve.service” and “journalctl -xe” for details. Restarted service tcsd.service on cwp1 at Sat Mar 31 01:00:19 EDT 2018 Job for tcsd.service failed because the control process exited with error code. See “systemctl status tcsd.service” and “journalctl -xe” for details. Restarted service vzfifo.service on cwp1 at Sat Mar 31 01:00:20 EDT 2020
CWP কন্ট্রোল প্যানেল সক্ষম করুন সার্ভিস মনিটর (সিস্টেমডি) ভিডিও টিউটোরিয়াল
CWP কন্ট্রোল প্যানেলে ServicesMonitor (systemd) কীভাবে চালু করবেন, সে বিষয়ে নিচে একটি ইউটিউব ভিডিও টিউটোরিয়াল দেওয়া হলো ▼
আশা করি, চেন ওয়েইলিয়াং-এর ব্লগে ( https://www.chenweiliang.com/ ) শেয়ার করা "CWP কন্ট্রোল প্যানেলে ServicesMonitor (systemd) কীভাবে সক্রিয় করবেন" শীর্ষক নিবন্ধটি আপনার জন্য সহায়ক হবে।
এই নিবন্ধটির লিঙ্কটি নির্দ্বিধায় শেয়ার করুন: https://www.chenweiliang.com/cwl-1414.html
