Uptime Kuma Free Website Status Monitoring Tool Linux Server Monitoring Software

Wy dogge normaal eksterne kettingpromoasje en optimisaasje fan freonskipslinks moatte wurde kontrolearre.

As wy ús backlinks en wjersidige keppelings ferlieze, sil ús SEO- ranglist ek sakje. Dêrom is it kontrolearjen fan 'e status fan backlinked websiden tige wichtich.

Wêrom Uptime Kuma brûke om websiden te kontrolearjen?

Hoe kinne jo backlinks kontrolearje foar SEO-doelen?

Nei it tafoegjen fan backlinks en it útwikseljen fan wjersidige keppelings, konfigurearje wy meastentiids websidemonitoring op it Uptime Robot- wolkemonitoringplatfoarm om de ferbining fan 'e backlink-pagina's op elke webside te kontrolearjen.

Mei it tanimmend oantal eksterne keatlingen en freonketten hat it Uptime Robot-wolkplatfoarm lykwols in limyt op it oantal tafersjoch, en jo moatte opwurdearje en betelje om troch te gean mei it tafoegjen fan mear items foar wolkmonitoring.

Dêrom kinne wy ​​​​de iepen boarne Linux- wolkeservermonitoringsoftware - ark brûke - Uptime Kuma.

Hokker software is Uptime Kuma?

Uptime Kuma is in iepen boarne Linux-servermonitoring-ark mei ferlykbere funksjes as Uptime Robot.

Yn ferliking mei oare ferlykbere ark foar monitoring fan websiden, stipet Uptime Kuma sels-hoste tsjinsten mei minder beheiningen.

Dit artikel sil de ynstallaasje en gebrûk fan Uptime Kuma yntrodusearje.

Hoe kinne jo Uptime Kuma-monitoring-ark ynstallearje?

Uptime Kuma, stipet Docker-ynstallaasje.

It folgjende is in tutorial oer de ynstallaasjestappen fan Uptime Kuma.

De folgjende kommando's binne foar it ynstallearjen fan it programma fia CLI [Ubuntu/ CentOS ]. Ynteraktyf CLI-ynstallearder, mei of sûnder Docker-stipe ▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
  • It is net oan te rieden om it boppesteande ynstallaasjekommando te brûken: om't Uptime Kuma op in net-Docker-manier ynstalleare is, is de ynstallaasje maklik te mislearjen.
  • (Wy riede it ynstallaasjekommando hjirûnder oan)

Om't jo Docker moatte ynstallearje foardat jo Uptime Kuma ynstallearje mei Docker, ynstallearje Docker earst.

Ynstallearje Docker en Docker-compose

Update en ynstallearje nedige software ▼

apt-get update && apt-get install -y wget vim

As in 404-flater foarkomt tidens de fernijing, sjoch dan de oplossing hjirûnder▼

Ynstallearje Docker

As it in bûtenlânske tsjinner is, brûk dan it folgjende kommando ▼

 curl -sSL https://get.docker.com/ | sh 

As it in ynlânske tsjinner is yn Sina, brûk dan it folgjende kommando ▼

 curl -sSL https://get.daocloud.io/docker | sh 

Stel Docker yn om automatysk te begjinnen by it opstarten ▼

systemctl start docker 

systemctl enable docker

Ynstallearje Docker-compose 

As it in bûtenlânske tsjinner is, brûk dan it folgjende kommando ▼

sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

As it in ynlânske server is yn Sina, brûk dan it folgjende kommando▼

curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
chmod +x /usr/local/bin/docker-compose

Docker tsjinst kommando opnij starte▼

service docker restart

Hoe kinne jo Uptime Kuma fergees ark foar monitoring fan websidestatus ynstallearje?

🐳 Ynstallearje yn Docker-modus, meitsje in kontener mei de namme uptime-kuma ▼

docker volume create uptime-kuma
Start de kontener ▼
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1
  • Dan kinne jo trochjaanIP:3001Besykje Uptime-Kuma.

As jo ​​de CSF-brânmuorre ynskeakele hawwe, moatte jo miskien poarte 3001 iepenje op de CSF-brânmuorre▼

vi /etc/csf/csf.conf
# Allow incoming TCP ports
 TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001" 

Start de CSF-firewall opnij ▼

csf -r

Ynstallearje Nginx Proxy Manager

Nginx Proxy Manager is in Docker-basearre reverse proxy-software.

Sûnt Nginx Proxy Manager net nedich is, kinne jo it net ynstallearjen fan Nginx Proxy Manager oerslaan as jo gjin tiid wolle fergrieme.

Meitsje map ▼

mkdir -p data/docker_data/npm
cd data/docker_data/npm

Meitsje docker-compose.yml triem ▼

nano docker-compose.yml

Folje de folgjende ynhâld yn yn it bestân, druk dan op Ctrl+X om op te slaan, druk op Y om ôf te gean ▼

version: "3"
services:
  app:
    image: 'jc21/nginx-proxy-manager:latest'
    restart: unless-stopped
    ports:
      # These ports are in format :
      - '80:80' # Public HTTP Port
      - '443:443' # Public HTTPS Port
      - '81:81' # Admin Web Port
      # Add any other Stream port you want to expose
      # - '21:21' # FTP
    environment:
      DB_MYSQL_HOST: "db"
      DB_MYSQL_PORT: 3306
      DB_MYSQL_USER: "npm"
      DB_MYSQL_PASSWORD: "npm"
      DB_MYSQL_NAME: "npm"
      # Uncomment this if IPv6 is not enabled on your host
      # DISABLE_IPV6: 'true'
    volumes:
      - ./data:/data
      - ./letsencrypt:/etc/letsencrypt
    depends_on:
      - db

  db:
    image: 'jc21/mariadb-aria:latest'
    restart: unless-stopped
    environment:
      MYSQL_ROOT_PASSWORD: 'npm'
      MYSQL_DATABASE: 'npm'
      MYSQL_USER: 'npm'
      MYSQL_PASSWORD: 'npm'
    volumes:
      - ./data/mysql:/var/lib/mysql

rinne ▼

docker-compose up -d

As in flaterberjocht fergelykber mei it folgjende ferskynt: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼

[root@ten npm]# docker-compose up -d
npm_db_1 is up-to-date
Starting npm_app_1 ... error

ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use
ERROR: Encountered errors while bringing up the project.
  • It betsjut dat poarte 443 al beset is, en it krekt makke docker-compose.yml-bestân moat wurde bewurke.

Poarte 443 moat wizige wurde yn 442 ▼

      - '442:442' # Public HTTPS Port

Fier dan it kommando wer út docker-compose up -d

In flater berjocht sil ferskine:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"

Moatte ek poarte 80 feroarje nei 882 ▼

      - '882:882' # Public HTTP Port

troch iepening http:// IP:81 Besykje Nginx Proxy Manager.

Foar de earste oanmelding, brûk it standert initial akkount en wachtwurd▼

Email: [email protected]
Password: changeme
  • Nei it oanmelden, wês wis dat jo jo e-mailadres en wachtwurd fuortendaliks feroarje.

Reverse proxy Uptime Kuma

Nei it ynstallearjen fan Uptime Kuma is de standert te brûkenIP:3001Besykje Uptime Kuma.

Wy kinne tagong krije ta de domeinnamme en it SSL-sertifikaat konfigurearje fia reverse proxy, krekt lykas de URL earder oantoand.

Folgjende sille wy operaasjes foar reverse generaasje útfiere, mei de earder boude Nginx Proxy Manager.

Passearje http:// IP:81 Iepenje Nginx Proxy Manager.

Nei it oanmelden foar de earste kear, moatte jo de brûkersnamme en wachtwurd feroarje, asjebleaft konfigurearje it sels.

Folgjende binne de operaasjestappen fan Nginx Proxy Manager as folget:

第 1 步:Trochbraak Proxy Hosts ▼

Uptime Kuma Free Website Status Monitoring Tool Linux Server Monitoring Software

第 2 步:Klikje op 'e hoek rjochts boppe Add Proxy Hosts▼

Stap 2: Klik op "Proxy-hosts tafoegje" yn 'e rjochter boppeste hoeke.

Stap 3: Konfigurearje neffens de figuer,Klikje op Save rêde ▼ 

Stap 3: Konfigurearje de ynstellings lykas werjûn yn 'e ôfbylding, en klik dan op Bewarje.

第 4 步:klikEidtIepenje de konfiguraasjeside ▼

Stap 4: Klik op Eidt om de konfiguraasjeside te iepenjen

Stap 5: Jou in SSL-sertifikaat út en aktivearje twongen HTTPS-tagong ▼

Stap 5: In SSL-sertifikaat útjaan en ferplichte Https-tagong ynskeakelje 

  • Op dit punt is de omkeargeneraasje foltôge, en dan kinne jo de domeinnamme brûke dy't jo krekt hawwe oplost om tagong te krijen ta Uptime Kuma.
  • Uptime Kuma-konfiguraasje is heul ienfâldich.
  • It hat in Sineeske ynterface, ik leau dat jo it gau kinne brûke.

Uptime Kuma Nuttige PM2-kommando's

Begjinne, stopje en opnij starte kommando's fan Uptime Kuma (dit kommando is wijd oan net-Docker-ynstallaasje)▼

pm2 start uptime-kuma
pm2 stop uptime-kuma
pm2 restart uptime-kuma

Besjoch de hjoeddeistige konsole-útfier fan Uptime Kuma (dit kommando is wijd oan net-Docker-ynstallaasje)▼

pm2 monit

Run Uptime Kuma by it opstarten (dit kommando is wijd oan net-Docker-ynstallaasjes) ▼

pm2 save && pm2 startup

Hoe kinne jo automatyske reservekopy fan Uptime Kuma-monitoringsoftware ynstelle?

Om't d'r miskien problemen binne mei de reservekopyfunksje yn 'e eftergrûnynstellingen fan Uptime Kuma, hat de ûntwikkelder de reservekopyfunksje net ûnderhâlden.

Wolle jo mear witte oer hoe't jo moatte omgean mei ôfskriuwing fan Uptime Kuma-backupfunksjes? Klikje op de link hjirûnder om troch te gean mei it lêzen fan it detaillearre tutorial ▼

Hoe kinne jo Uptime Kuma-monitoringsoftware ferwiderje?

As Uptime Kuma net mei Docker ynstalleare is , hoe kin ik it dan deynstallearje?

Bygelyks, as jo dit kommando brûke om te ynstallearjen op in net-Docker-manier▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh

Om Uptime Kuma te ferwiderjen, brûk it folgjende kommando ▼

  1. bûten gebrûk  pm2 stop uptime-kuma
  2. triemtafel wiskje rm -rf /opt/uptime-kuma

Hoe kinne jo Uptime Kuma ferwiderje as jo it ynstallearje mei Docker?

Run it folgjende query kommando▼

docker ps -a
  • opskriuwe dyn kuma De namme fan 'e kontener, dat kin wêze uptime-kuma

stop kommando ▼

  • Stjoer asjeblyftcontainer_nameFeroarje nei de boppesteande querykuma De namme fan de kontener.
docker stop container_name
docker rm container_name

Uninstall Uptime Kuma ▼

docker volume rm uptime-kuma
docker rmi uptime-kuma

Konklúzje

De ynterface fan Uptime Kuma is skjin en ienfâldich, en it is heul maklik te ynsetten en te brûken.

Uptime Kuma is in heul goede kar as jo gjin hege easken hawwe foar websidemonitoring.

发表 评论

您的邮箱地址不会被公开。必填项已用*标注

Scroll nei boppen