Directory artaigil
Mar as trice bidh sinn a’ dèanamh adhartachadh slabhraidh taobh a-muigh agus feumar sùil a chumail air optimization ceangal càirdeas.
Ma chailleas sinn ar ceanglaichean-cùil agus ar ceanglaichean co-phàirteach, bidh an rangachadh SEO againn a’ crìonadh cuideachd. Mar sin, tha e glè chudromach sùil a chumail air inbhe dhuilleagan-lìn le ceanglaichean-cùil.
Carson a chleachdas tu Uptime Kuma gus sùil a chumail air làraich-lìn?
Ciamar a nì thu sgrùdadh air ceanglaichean-cùil airson adhbharan SEO?
Às dèidh dhuinn ceanglaichean-cùil a chur ris agus ceanglaichean co-phàirteach iomlaid, mar as trice bidh sinn a’ rèiteachadh sgrùdadh làrach-lìn air àrd-ùrlar sgrùdaidh sgòthan Uptime Robot gus sgrùdadh a dhèanamh air ceangal nan duilleagan ceangail-cùil air gach làrach-lìn.
Ach, mar a tha an àireamh de shlabhraidhean taobh a-muigh agus slabhraidhean caraid a’ dol am meud, tha crìoch aig àrd-ùrlar sgòthan Uptime Robot air an àireamh de nithean sgrùdaidh, agus feumaidh tu ùrachadh agus pàigheadh gus leantainn air adhart a’ cur barrachd nithean sgrùdaidh sgòthan ris.
Mar sin, is urrainn dhuinn an inneal bathar-bog sgrùdaidh frithealaiche sgòthan Linux stòr fosgailte a chleachdadh - Uptime Kuma.
Dè am bathar-bog a th’ ann an Uptime Kuma?
Tha Uptime Kuma na inneal sgrùdaidh frithealaiche Linux stòr fosgailte le gnìomhan coltach ri Uptime Robot.
An coimeas ri innealan sgrùdaidh làrach-lìn eile den aon seòrsa, tha Uptime Kuma a’ toirt taic do sheirbheisean fèin-aoigheachd le nas lugha de chuingealachaidhean.
Bheir an artaigil seo a-steach stàladh agus cleachdadh Uptime Kuma.
Mar a stàlaicheas tu inneal sgrùdaidh Uptime Kuma?
Uptime Kuma, a’ toirt taic do stàladh Docker.
Tha na leanas na oideachadh air ceumannan stàlaidh airson Uptime Kuma.
Tha na h-òrdughan a leanas ann airson am prògram a stàladh tro CLI [Ubuntu/ CentOS ]. Stàlaichear CLI eadar-ghnìomhach, le no às aonais taic Docker ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
- Chan eilear a’ moladh an àithne stàlaidh gu h-àrd a chleachdadh: leis gu bheil Uptime Kuma air a chuir a-steach ann an dòigh neo-Docker, tha e furasta an stàladh fàiligeadh.
- (Tha sinn a 'moladh an òrdugh stàlaidh gu h-ìosal)
Leis gu feum thu Docker a stàladh mus stàlaich thu Uptime Kuma a’ cleachdadh Docker, stàlaich Docker an-toiseach.
Stàlaich Docker agus Docker-compose
Ùraich agus stàlaich am bathar-bog riatanach ▼
apt-get update && apt-get install -y wget vim
Ma thachras mearachd 404 rè an ùrachaidh, feuch an toir thu sùil air an fhuasgladh gu h-ìosal▼
Stàlaich Docker
Mas e frithealaiche cèin a th’ ann, cleachd an àithne a leanas ▼
curl -sSL https://get.docker.com/ | sh
Mas e frithealaiche dachaigheil a th’ ann an Sìona, feuch an cleachd thu an àithne a leanas ▼
curl -sSL https://get.daocloud.io/docker | sh
Suidhich Docker gus tòiseachadh gu fèin-ghluasadach aig bròg ▼
systemctl start docker systemctl enable docker
Stàlaich Docker-compose
Mas e frithealaiche cèin a th’ ann, cleachd an àithne a leanas ▼
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose sudo chmod +x /usr/local/bin/docker-compose
Mas e frithealaiche dachaigheil a th’ ann an Sìona, cleachd an àithne a leanas▼
curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose
Ath-thòisich an àithne seirbheis docker ▼
service docker restart
Mar a stàlaicheas tu inneal sgrùdaidh inbhe làrach-lìn an-asgaidh Uptime Kuma?
docker volume create uptime-kuma
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1- An uairsin, faodaidh tu a dhol seachad
IP:3001Tadhail air Uptime-Kuma.
Ma tha thu air am balla-teine CSF a chomasachadh, is dòcha gum feum thu port 3001 fhosgladh air balla-teine CSF▼
vi /etc/csf/csf.conf # Allow incoming TCP ports TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001"
Ath-thòisich am balla-teine CSF ▼
csf -rStàlaich Nginx Proxy Manager
Tha Nginx Proxy Manager na bhathar-bog proxy cùil stèidhichte air Docker.
Leis nach eil feum air Manaidsear Proxy Nginx, faodaidh tu sgiobadh gun a bhith a’ stàladh Nginx Proxy Manager mura h-eil thu airson ùine a chaitheamh.
Cruthaich eòlaire ▼
mkdir -p data/docker_data/npm cd data/docker_data/npm
Cruthaich faidhle docker-compose.yml ▼
nano docker-compose.yml
Lìon a-steach an t-susbaint a leanas san fhaidhle, an uairsin brùth Ctrl + X airson sàbhaladh, brùth Y gus fàgail ▼
version: "3"
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
restart: unless-stopped
ports:
# These ports are in format :
- '80:80' # Public HTTP Port
- '443:443' # Public HTTPS Port
- '81:81' # Admin Web Port
# Add any other Stream port you want to expose
# - '21:21' # FTP
environment:
DB_MYSQL_HOST: "db"
DB_MYSQL_PORT: 3306
DB_MYSQL_USER: "npm"
DB_MYSQL_PASSWORD: "npm"
DB_MYSQL_NAME: "npm"
# Uncomment this if IPv6 is not enabled on your host
# DISABLE_IPV6: 'true'
volumes:
- ./data:/data
- ./letsencrypt:/etc/letsencrypt
depends_on:
- db
db:
image: 'jc21/mariadb-aria:latest'
restart: unless-stopped
environment:
MYSQL_ROOT_PASSWORD: 'npm'
MYSQL_DATABASE: 'npm'
MYSQL_USER: 'npm'
MYSQL_PASSWORD: 'npm'
volumes:
- ./data/mysql:/var/lib/mysql ruith ▼
docker-compose up -d
Ma nochdas teachdaireachd mearachd coltach ris na leanas: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use▼
[root@ten npm]# docker-compose up -d npm_db_1 is up-to-date Starting npm_app_1 ... error ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: Encountered errors while bringing up the project.
- Tha e a’ ciallachadh gu bheil port 443 ann mu thràth, agus feumar am faidhle docker-compose.yml a chaidh a chruthachadh a dheasachadh.
Feumaidh port 443 atharrachadh gu 442 ▼
- '442:442' # Public HTTPS Port
An uairsin, ruith an àithne a-rithist docker-compose up -d
Nochdaidh teachdaireachd mearachd:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"
Cuideachd feumar port 80 gu 882 ▼ atharrachadh
- '882:882' # Public HTTP Port
le fosgladh http:// IP:81 Tadhail air Nginx Proxy Manager.
Airson a’ chiad logadh a-steach, cleachd a’ chiad chunntas tùsail agus am facal-faire▼
Email: [email protected] Password: changeme
- Às deidh dhut logadh a-steach, feuch an atharraich thu do sheòladh puist-d agus facal-faire sa bhad.
Neach-ionaid cùl Uptime Kuma
Às deidh dhut Uptime Kuma a chuir a-steach, is e am prìomh rud a chleachdadhIP:3001Tadhail air Uptime Kuma.
Is urrainn dhuinn faighinn chun ainm fearainn agus an teisteanas SSL a rèiteachadh tro neach-ionaid cùil, dìreach mar an URL a chaidh a nochdadh na bu thràithe.
An uairsin, nì sinn gnìomhachd ginealach air ais, a’ cleachdadh Manaidsear Proxy Nginx a chaidh a thogail roimhe seo.
le bhith a ' http:// IP:81 Fosgail Manaidsear Proxy Nginx.
Às deidh dhut logadh a-steach airson a’ chiad uair, feumaidh tu an t-ainm neach-cleachdaidh agus am facal-faire atharrachadh, feuch an rèiteachadh thu fhèin e.
An ath rud, tha ceumannan obrachaidh Manaidsear Proxy Nginx mar a leanas:
第 1 步 :Cuir air Proxy Hosts ▼

第 2 步 :Cliog air an oisean gu h-àrd air an làimh dheis Add Proxy Hosts▼

Ceum 3: Dèan rèiteachadh a rèir an fhigear,Cliog Save sàbhail ▼

第 4 步 :cliogEidtFosgail an duilleag rèiteachaidh ▼

Ceum 5: Thoir seachad teisteanas SSL agus cuir an comas ruigsinneachd HTTPS èignichte ▼

- Aig an ìre seo, tha an ginealach cùil deiseil, agus an uairsin faodaidh tu an t-ainm fearainn a chuir thu romhpa faighinn gu Uptime Kuma a chleachdadh.
- Tha rèiteachadh Uptime Kuma gu math sìmplidh.
- Tha eadar-aghaidh Sìneach aige, tha mi a’ creidsinn gun urrainn dhut a chleachdadh a dh’ aithghearr.
Òrdughan feumail PM2 Uptime Kuma
Tòisich, stad, agus ath-thòisich òrdughan Uptime Kuma (tha an àithne seo coisrigte do stàladh neo-Docker) ▼
pm2 start uptime-kuma pm2 stop uptime-kuma pm2 restart uptime-kuma
Thoir sùil air toradh tòcan gnàthach Uptime Kuma (tha an àithne seo coisrigte do stàladh neo-Docker) ▼
pm2 monit
Ruith Uptime Kuma aig àm tòiseachaidh (tha an àithne seo coisrigte do ionadan neo-Docker) ▼
pm2 save && pm2 startup
Mar a shuidhicheas tu cùl-taic fèin-ghluasadach de bhathar-bog sgrùdaidh Uptime Kuma?
Leis gum faodadh cuid de dhuilgheadasan a bhith ann leis a ’ghnìomh cùl-taic ann an roghainnean cùl-taic Uptime Kuma, chan eil an leasaiche air a’ ghnìomh cùl-taic a chumail a-nis.
A bheil thu airson tuilleadh fhaighinn a-mach mu mar a dhèiligeas tu ri ìsleachadh feart cùl-taic Uptime Kuma? Cliog air a’ cheangal gu h-ìosal gus leantainn air adhart a’ leughadh an oideachadh mionaideach ▼
Mar a dhì-stàlaicheas tu bathar-bog sgrùdaidh Uptime Kuma?
Mura deach Uptime Kuma a stàladh le Docker, ciamar a dhì-stàlaicheas mi e?
Mar eisimpleir, ma chleachdas tu an àithne seo airson stàladh ann an dòigh neo-Docker▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
Gus Uptime Kuma a dhì-stàladh, cleachd an àithne a leanas ▼
- a-mach à seirbheis
pm2 stop uptime-kuma - sguab às eòlaire
rm -rf /opt/uptime-kuma
Mar a dhì-stàlaicheas tu Uptime Kuma ma stàlaicheas tu e a’ cleachdadh Docker?
Ruith an àithne ceist a leanas ▼
docker ps -a
- sgrìobh sìos do
kumaAinm an t-soithich, a dh'fhaodadh a bhithuptime-kuma
stad àithne ▼
- feuch an atharraich thu
container_nameAtharraich don cheist gu h-àrdkumaAinm an t-soithich.
docker stop container_name docker rm container_name
Dì-stàlaich Uptime Kuma ▼
docker volume rm uptime-kuma docker rmi uptime-kuma
Co-dhùnadh
Tha an eadar-aghaidh de Uptime Kuma glan agus sìmplidh, agus tha e gu math furasta a chleachdadh agus a chleachdadh.
Tha Uptime Kuma na roghainn fìor mhath mura h-eil riatanasan àrda agad airson sgrùdadh làrach-lìn.
Tha mi an dòchas gum bi an t-artaigil "Uptime Kuma Free Website Status Monitoring Tool for Linux Server Monitoring" a chaidh a cho-roinn air blog Chen Weiliang ( https://www.chenweiliang.com/ ) feumail dhut.
Faodaidh sibh ceangal an artaigil seo a cho-roinn: https://www.chenweiliang.com/cwl-29041.html


