기사 디렉토리
- 그는 2개의 데이터베이스와 2개의 사이트를 추가했습니다.
- 오늘은 모든 것이 평소처럼 보입니다.
VestaCP의 오류 문제
하지만 오늘 세 번째 데이터베이스를 추가하려고 시도했을 때 "오류: localhost 연결 실패 " 라는 오류 메시지가 나타났습니다 .

그는 변화를 시도한다/usr/local/vesta/conf/mysql.conf 파일의 암호.
- 기존 데이터베이스가 실행되고 있지 않으며 여전히 새 데이터베이스를 추가할 수 없습니다.
서버를 재시작할 때 다음과 같은 오류가 발생할 수 있습니다. 오류: localhost 연결 실패, VestaCP 연결 실패...
전자 상거래 웹사이트 관리자가 MySQL 데이터베이스를 설정했지만 , 웹사이트에 접속하려고 할 때 동일한 오류가 발생했습니다 .
- 몇 가지 조사를 한 후 암호 값이
/root/.my.cnf에 변화가 없습니다. - 하지만 때
/usr/local/vesta/conf/mysql.conf올바른 비밀번호가 표시되고 패널을 통해 제출된 콘텐츠로 충분합니다.
해결책
1) MySQL 기본 파일 에서 비밀번호를 변경하세요 ▼
vi /usr/local/vesta/conf/mysql.conf
- 이전 비밀번호를 기존 비밀번호로 변경합니다.
2) MySQL 데이터베이스 재시작 ▼
service mariadb restart
- 또는 VestaCP 패널 → 서버 → MySQL 다시 시작에 로그인합니다.
확장 읽기:
Chen Weiliang님의 블로그( https://www.chenweiliang.com/ ) 에 공유된 "VestaCP 오류 해결: localhost 연결 실패" 글이 여러분께 도움이 되기를 바랍니다.
이 기사 링크( https://www.chenweiliang.com/cwl-1452.html )를 자유롭게 공유해 주세요.



