기사 디렉토리
💻🔧【초간단 튜토리얼】 phpMyAdmin 설정 수정 및 MySQL 가져오기 오류 해결 방법 단계별 가이드❗️
테스트를 거쳐 효과가 입증되었습니다! ✅ 단 3분 ⏰ 만에 MySQL이 업로드된 폴더에 접근할 수 없는 문제를 완벽하게 해결할 수 있습니다 📂.
데이터베이스 가져오기로 인한 골칫거리는 이제 그만! 데이터베이스를 간편하게 관리하고 리눅스 시스템을 더욱 원활하게 운영하세요.
리눅스에서 MySQL 데이터베이스 가져오기가 실패하면 어떻게 해야 할까요 ? phpMyAdmin 설정을 수정하는 방법을 알려드립니다!
phpMyAdmin의 설치 경로를 찾으려면 다음 명령을 사용할 수 있습니다.
find / -name pma
或
find / -name phpMyAdmin
다음과 유사한 경로를 찾으면:
/usr/local/cwpsrv/var/services/pma /usr/local/apache/htdocs/phpmyadmin

phpMyAdmin 설치 경로
축하합니다. phpMyAdmin의 설치 위치가 잠겼습니다!
일부 제어판 프로그램은 `pma` 폴더에 설치하는 반면 다른 프로그램은 `phpMyAdmin` 폴더에 설치하는 것을 선호합니다.
다음 경로를 찾을 수 있습니다.
/usr/share/phpmyadmin /usr/share/phpmyadmin/vendor/phpmyadmin /usr/local/hestia/install/rpm/phpmyadmin /usr/local/hestia/install/deb/phpmyadmin /var/lib/mysql/phpmyadmin /var/lib/phpmyadmin /etc/phpmyadmin
테스트를 거쳐 최종적으로 확인되었습니다.헤스티아CPphpMyAdmin 설치 경로:/etc/phpmyadmin
다음으로 phpMyAdmin에 로그인하여 데이터베이스를 선택한 후 "가져오기"를 클릭하세요. 그러나 가져오기 기능은 기본적으로 제한될 수 있습니다.
그러나 서버에서 MySQL 데이터베이스 파일 가져오기를 지원하도록 phpMyAdmin의 구성 파일을 수정할 수 있습니다. 구체적인 단계는 다음과 같습니다:
phpMyAdmin의 구성 파일 수정
`config.inc.php` 파일을 찾아서 편집하세요. `config.sample.inc.php`만 있는 경우 복사본을 만들고 이름을 `config.inc.php`로 바꿉니다.
1. 다음 구성을 찾으십시오.
$cfg['UploadDir'] = ''; $cfg['SaveDir'] = '';
2. 다음과 같이 수정합니다.
$cfg['UploadDir'] = '/tmp'; $cfg['SaveDir'] = '/tmp';
주의 사항
여기서 '/tmp' 폴더는 서버의 루트 디렉터리에 있다는 점에 유의하세요.
그런 다음 MySQL 파일을 이 `/tmp` 디렉터리에 업로드할 수 있습니다. SFTP를 사용하여 파일을 `/tmp`에 넣은 다음 phpMyAdmin의 데이터베이스 관리에서 가져오기를 선택합니다(변경 사항을 보려면 다시 로그인해야 할 수도 있음).
HestiaCP를 사용하는 경우 phpMyAdmin이 기본 경로를 지원하지 않는 경우가 있습니다. 이 경우 phpMyAdmin의 구성 파일을 수정하고 웹사이트 사용자의 'tmp' 디렉터리로 경로를 변경하세요.
$cfg['UploadDir'] = '/home/admin/tmp'; $cfg['SaveDir'] = '/home/admin/tmp';
"웹사이트 서버에서 폴더 업로드`가 발생하는 경우/home/admin/tmp/`'표시'를 선택하세요. 업로드할 파일이 없습니다! ” 상황은 폴더 권한이 부족함을 나타냅니다.
그냥 교체하세요 `/home/admin/tmp`디렉터리 권한을 `755`로 설정합니다.
sudo chown www-data:www-data /home/admin/ -R sudo chmod 755 /home/admin/ -R
이제 이 경로에서 MySQL 파일을 가져올 수 있습니다! 🚀
위의 방법을 시도해 보았는데도 phpMyAdmin을 사용하여 MySQL 데이터베이스를 가져오는 데 실패하거나 MySQL 데이터베이스 가져오기 시 500 오류가 발생하는 경우, 다음 방법을 시도해 보세요▼
Chen Weiliang님의 블로그( https://www.chenweiliang.com/ ) 에 있는 "phpMyAdmin 설정을 수정하여 MySQL 데이터베이스 파일을 업로드할 수 없는 문제를 해결하는 방법"이라는 글이 도움이 되기를 바랍니다.
이 기사 링크( https://www.chenweiliang.com/cwl-157.html )를 자유롭게 공유해 주세요.
