Одржувањето на стабилно работење на услугата на Linux серверите е клучно за SEO на веб-страницата.
Контролната табла на CWP ќе ви помогне со алатките за следење на услугите.

Како да се овозможи ServicesMonitor (системски) во контролниот панел CWP?
За да овозможите мониторинг на услуги во CWP:
- поврзете се со вашиотCWPИнсталирајте
- најдетеServices Config->ServicesMonitor( systemd )Избор
- Изберете/Внесете:
Вклучи исклучи- Ова ќе овозможи/оневозможи следење на услугата.
Email известувањаИспрати до - Внесете ја адресата на е-пошта каде што ќе добивате известувања.
Проверете го секој- временски интервал помеѓу проверките - Изберете ја услугата што сакате да ја следите, на пример: mariadb.service, monit.service
- кликнете提交копче.Ќе видите порака за потврда:
Service Monitoring is not enabled Enabling monitoring in cron MAILTO=cwp1@ chenweilaing.com */15 * * * * root /usr/local/bin/svcMonitor-systemd Monitoring Enabled: Yes
Забелешка:
- во случајсистемски статусуслугата е
Unknown,Мониторингот нема да работи за услугите. - Избраните услуги за следење ќе се зачуваат во датотека
/usr/local/etc/services-monitor-systemdво - Следење cron задачи може да се најде во датотеката
/etc/cron.d/svcMonitor-systemd中се појави.
Исто така, можете рачно да додавате/отстранувате услуги користејќи ја командата chkconfig :
chkconfig service_name onchkconfig service_name off
На пример, кога се овозможени сите достапни услуги, ќе прикажеме cron пораки како што се:
From: (Cron Daemon) <[email protected]> Subject: Cron <root@cwp1> /usr/local/bin/svcMonitor-systemd Restarted service amavisd.service on cwp1 at Sat Mar 31 01:00:01 EDT 2018 Job for amavisd.service failed because the control process exited with error code. See “systemctl status amavisd.service” and “journalctl -xe” for details. Restarted service arp-ethers.service on cwp1 at Sat Mar 31 01:00:03 EDT 2018 Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:04 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name. Failed to start [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Restarted service console-shell.service on cwp1 at Sat Mar 31 01:00:05 EDT 2018 Restarted service garb.service on cwp1 at Sat Mar 31 01:00:06 EDT 2018 Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:07 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name. Failed to start [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Restarted service ntalk.service on cwp1 at Sat Mar 31 01:00:09 EDT 2018 Job for ntalk.service failed because a configured resource limit was exceeded. See “systemctl status ntalk.service” and “journalctl -xe” for details. Restarted service rdisc.service on cwp1 at Sat Mar 31 01:00:10 EDT 2018 Job for rdisc.service failed because the control process exited with error code. See “systemctl status rdisc.service” and “journalctl -xe” for details. Restarted service [email protected] on cwp1 at Sat Mar 31 01:00:17 EDT 2018 Failed to stop [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Failed to get load state of [email protected]: Unit name [email protected] is missing the instance name. Failed to start [email protected]: Unit name [email protected] is missing the instance name. See system logs and ‘systemctl status [email protected]‘ for details. Restarted service svnserve.service on cwp1 at Sat Mar 31 01:00:18 EDT 2018 Job for svnserve.service failed because the control process exited with error code. See “systemctl status svnserve.service” and “journalctl -xe” for details. Restarted service tcsd.service on cwp1 at Sat Mar 31 01:00:19 EDT 2018 Job for tcsd.service failed because the control process exited with error code. See “systemctl status tcsd.service” and “journalctl -xe” for details. Restarted service vzfifo.service on cwp1 at Sat Mar 31 01:00:20 EDT 2020
CWP Control Panel Enable ServicesMonitor (системски) Видео упатство
Подолу е видео упатство на YouTube за тоа како да го овозможите ServicesMonitor (systemd) во контролниот панел на CWP ▼
Се надеваме дека статијата „Како да се овозможи ServicesMonitor (systemd) во CWP Control Panel“ споделена на блогот на Чен Вејлијанг ( https://www.chenweiliang.com/ ) ќе ви биде корисна.
Слободно споделете го линкот до овој напис: https://www.chenweiliang.com/cwl-1414.html
