Како да се реши MySQL ERROR 1045 (28000): Пристапот е одбиен за корисникот 'root'@'localhost'

Кога ќе се обидете да користите MySQL база на податоци, може да се соочите со следната порака за грешка:

Како да се реши MySQL ERROR 1045 (28000): Пристапот е одбиен за корисникот 'root'@'localhost'

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Како да се решиMySQL, ГРЕШКА 1045 (28000): Одбиен е пристапот за корисникот 'root'@'localhost'?

1. Прво запрете го вашиот сервер

service mysql stop
2. Креирајте директориум за услуги на MySQL.
mkdir /var/run/mysqld

3. Дајте му дозвола на MySQL да го користи креираниот директориум.

chown mysql: /var/run/mysqld
4. Стартувајте MySQL без дозвола и проверка на мрежата.
mysqld_safe --skip-grant-tables --skip-networking &
5. Најавете се на вашиот сервер без никаква лозинка.
mysql -u root mysql

или:

mysql -u root mysql

Во клиентот mysql, кажете му на серверот повторно да ги вчита табелите за грантови за да функционираат изјавите за управување со сметката:

mysql> FLUSH PRIVILEGES;

потоа измени'root'@'localhost'лозинка на сметката.Заменете ја лозинката со лозинката што сакате да ја користите.За да ја смените лозинката за root сметката со различен дел од името на домаќинот, изменете ги упатствата за да го користите тоа име на домаќин.

MySQL 5.7.6 и понова верзија:

mysql> ALTER USER 'root'@'localhost' IDENTIFIED BY 'MyNewPass';

MySQL 5.7.5 и порано:

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('MyNewPass');

или директно на табелата со корисници:

UPDATE mysql.user SET password=PASSWORD('mynewpassword') WHERE user='root';

За XAMPP

За да ја запрете MySQL услугата, отворете команден прозорец и одете до директориумот XAMPP MySQL:

> cd \xampp\mysql\bin\

За да ја извршите услугата без безбедност (забележете дека користите mysqld, а не mysql):

> mysqld.exe --skip-grant-tables

Услугата MySQL ќе работи во овој прозорец, затоа отворете друг команден прозорец и префрлете се во директориумот XAMPP MySQL:

> cd \xampp\mysql\bin\

Стартувај го клиентот MySQL:

> mysql

Ажурирајте ја лозинката:

mysql> UPDATE mysql.user SET password=PASSWORD('mynewpassword') WHERE user='root';

Излезете од MySQL:

mysql> \q

Користете го менаџерот за задачи за да го откажете mysqld.exe што сè уште работи и да ја рестартирате услугата MySQL.

Се надеваме дека статијата „Како да се реши грешката 1045 (28000) во MySQL: Пристапот е одбиен за корисникот „root“@'localhost““ споделена на блогот на Чен Вејлијанг ( https://www.chenweiliang.com/ ) ќе ви биде корисна.

Слободно споделете го линкот до овој напис: https://www.chenweiliang.com/cwl-30369.html

За да отклучите повеќе скриени трикови🔑, добредојдени сте да се придружите на нашиот Телеграм канал!

Споделете и лајкнете ако ви се допаѓа! Вашите споделувања и лајкови се наша постојана мотивација!

 

评论

您的邮箱地址不会被公开。必填项已用*标注

Дојдете до врв