مقالې لارښود
موږ معمولا د بهرني زنځیر ترویج او د ملګرتیا لینک اصلاح کوو او د څارنې ته اړتیا لرو.
که موږ خپل بیک لنکونه او متقابل لینکونه له لاسه ورکړو، زموږ د SEO درجه بندي به هم راټیټه شي. له همدې امله، د بیک لینک شوي ویب پاڼو حالت څارنه خورا مهمه ده.
ولې د ویب سایټونو څارلو لپاره اپټایم کوما وکاروئ؟
د SEO موخو لپاره د بیک لنکسونو څارنه څنګه وکړو ؟
د بیک لنکونو اضافه کولو او متقابل لینکونو تبادلې وروسته، موږ معمولا د ویب پاڼې څارنه د اپټایم روبوټ کلاوډ څارنې پلیټ فارم کې تنظیم کوو ترڅو په هره ویب پاڼه کې د بیک لنک پاڼو ارتباط وګورئ.
په هرصورت ، لکه څنګه چې د بهرني زنځیرونو او ملګرو زنځیرونو شمیر ډیریږي ، د اپټایم روبوټ کلاوډ پلیټ فارم د نظارت توکو شمیر محدودیت لري ، او تاسو باید د نور بادل نظارت توکو اضافه کولو ته دوام ورکولو لپاره لوړ او تادیه وکړئ.
له همدې امله، موږ کولی شو د خلاصې سرچینې لینکس کلاوډ سرور څارنې سافټویر وسیله - اپټایم کوما وکاروو.
اپټایم کوما کوم سافټویر دی؟
اپټایم کوما د خلاصې سرچینې لینکس سرور څارنې وسیله ده چې د اپټایم روبوټ ته ورته دندو سره.
د نورو ورته ویب پاڼې څارنې وسیلو په پرتله، Uptime Kuma د لږ محدودیتونو سره د ځان کوربه شوي خدماتو ملاتړ کوي.
دا مقاله به د اپټایم کوما نصب او کارول معرفي کړي.
د اپټایم کوما څارنې وسیله څنګه نصب کړئ؟
اپټایم کوما ، د ډاکر نصبولو ملاتړ کوي.
لاندې د اپټایم کوما نصبولو مرحلو په اړه ښوونه ده.
لاندې کمانډونه د CLI [Ubuntu/ CentOS ] له لارې د پروګرام نصبولو لپاره دي. متقابل CLI انسټالر، د ډاکر ملاتړ سره یا پرته ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
- د پورته نصب کولو کمانډ کارولو سپارښتنه نه کیږي: ځکه چې اپټایم کوما په غیر ډاکر ډول نصب شوی ، د نصب کولو ناکامول اسانه دي.
- (موږ لاندې د نصب کولو کمانډ وړاندیز کوو)
څنګه چې تاسو اړتیا لرئ د ډاکر په کارولو سره د اپټایم کوما نصبولو دمخه ډاکر نصب کړئ ، لومړی ډاکر نصب کړئ.
Docker او Docker-compose نصب کړئ
اړین سافټویر تازه او نصب کړئ ▼
apt-get update && apt-get install -y wget vim
که د تازه کولو پرمهال 404 تېروتنه رامنځته شي، مهرباني وکړئ لاندې حل وګورئ▼
ډاکر نصب کړئ
که دا یو بهرنی سرور وي، مهرباني وکړئ لاندې کمانډ وکاروئ ▼
curl -sSL https://get.docker.com/ | sh
که دا په چین کې کورني سرور وي، مهرباني وکړئ لاندې کمانډ وکاروئ ▼
curl -sSL https://get.daocloud.io/docker | sh
په بوټ ▼ کې په اتوماتيک ډول پیل کولو لپاره ډاکر تنظیم کړئ
systemctl start docker systemctl enable docker
د ډاکر کمپوز نصب کړئ
که دا یو بهرنی سرور وي، مهرباني وکړئ لاندې کمانډ وکاروئ ▼
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose sudo chmod +x /usr/local/bin/docker-compose
که دا په چین کې کورنی سرور وي، مهرباني وکړئ لاندې کمانډ وکاروئ▼
curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose
د ډاکر خدمت کمانډ بیا پیل کړئ▼
service docker restart
د اپټایم کوما وړیا ویب سایټ وضعیت څارنې وسیله څنګه نصب کړئ؟
docker volume create uptime-kuma
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1- بیا، تاسو کولی شئ تېر شئ
IP:3001د Uptime-Kuma څخه لیدنه وکړئ.
که تاسو د CSF فایر وال فعال کړی وي، تاسو ممکن د CSF فایروال کې 3001 پورټ خلاصولو ته اړتیا ولرئ▼
vi /etc/csf/csf.conf # Allow incoming TCP ports TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001"
د CSF فایروال بیا پیل کړئ ▼
csf -rد نګینکس پراکسي مدیر نصب کړئ
د نګینکس پراکسي مدیر د ډاکر میشته ریورس پراکسي سافټویر دی.
څرنګه چې د نګینکس پراکسي مدیر اړین ندي، تاسو کولی شئ د نګینکس پراکسي مدیر نصب نه کړئ که تاسو نه غواړئ وخت ضایع کړئ.
لارښود جوړ کړئ ▼
mkdir -p data/docker_data/npm cd data/docker_data/npm
د docker-compose.yml فایل جوړ کړئ ▼
nano docker-compose.yml
په فایل کې لاندې مواد ډک کړئ، بیا د خوندي کولو لپاره Ctrl+X فشار ورکړئ، د وتلو لپاره Y فشار ورکړئ ▼
version: "3"
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
restart: unless-stopped
ports:
# These ports are in format :
- '80:80' # Public HTTP Port
- '443:443' # Public HTTPS Port
- '81:81' # Admin Web Port
# Add any other Stream port you want to expose
# - '21:21' # FTP
environment:
DB_MYSQL_HOST: "db"
DB_MYSQL_PORT: 3306
DB_MYSQL_USER: "npm"
DB_MYSQL_PASSWORD: "npm"
DB_MYSQL_NAME: "npm"
# Uncomment this if IPv6 is not enabled on your host
# DISABLE_IPV6: 'true'
volumes:
- ./data:/data
- ./letsencrypt:/etc/letsencrypt
depends_on:
- db
db:
image: 'jc21/mariadb-aria:latest'
restart: unless-stopped
environment:
MYSQL_ROOT_PASSWORD: 'npm'
MYSQL_DATABASE: 'npm'
MYSQL_USER: 'npm'
MYSQL_PASSWORD: 'npm'
volumes:
- ./data/mysql:/var/lib/mysql منډې ▼
docker-compose up -d
که لاندې ته ورته د خطا پیغام څرګند شي: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼
[root@ten npm]# docker-compose up -d npm_db_1 is up-to-date Starting npm_app_1 ... error ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: Encountered errors while bringing up the project.
- دا پدې مانا ده چې پورټ 443 لا دمخه نیول شوی ، او د docker-compose.yml فایل یوازې رامینځته شوی ترمیم ته اړتیا لري.
پورټ 443 باید په 442 ▼ بدل شي
- '442:442' # Public HTTPS Port
بیا، کمانډ بیا پرمخ وړئ docker-compose up -d
د خطا پیغام به څرګند شي:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"
همدارنګه اړتیا ده چې پورټ 80 ته 882 ▼ بدل کړئ
- '882:882' # Public HTTP Port
په پرانیستلو سره http:// IP:81 د نګینکس پراکسي مدیر څخه لیدنه وکړئ.
د لومړي ننوتلو لپاره، د ډیفالټ ابتدايي حساب او پټنوم وکاروئ▼
Email: [email protected] Password: changeme
- د ننوتلو وروسته، مهرباني وکړئ ډاډ ترلاسه کړئ چې سمدلاسه خپل بریښنالیک آدرس او پټنوم بدل کړئ.
ریورس پراکسي اپټایم کوما
د اپټایم کوما نصبولو وروسته ، ډیفالټ کارول ديIP:3001د اپټایم کوما څخه لیدنه وکړئ.
موږ کولی شو د ډومین نوم ته لاسرسی ومومئ او د SSL سند د ریورس پراکسي له لارې تنظیم کړئ، لکه څنګه چې مخکې ښودل شوي URL.
بل، موږ به د مخکینۍ جوړ شوي Nginx پراکسي مدیر په کارولو سره د ریورس نسل عملیات ترسره کړو.
پاس http:// IP:81 د نګینکس پراکسي مدیر خلاص کړئ.
د لومړي ځل لپاره د ننوتلو وروسته، تاسو اړتیا لرئ چې د کارن نوم او پټنوم بدل کړئ، مهرباني وکړئ دا پخپله ترتیب کړئ.
بل، د نګینکس پراکسي مدیر عملیاتي مرحلې په لاندې ډول دي:
په 1 کې:چالانول Proxy Hosts ▼

په 2 کې:په پورتنۍ ښیې کونج کې کلیک وکړئ Add Proxy Hosts▼

3 ګام: د شکل سره سم تنظیم کړئ،بیاکتنه Save خوندي کړئ ▼

په 4 کې:کلیکEidtد تشکیلاتو مخ خلاص کړئ ▼

پنځم ګام: د SSL سند صادر کړئ او د HTTPS جبري لاسرسی فعال کړئ ▼

- پدې مرحله کې ، ریورس نسل بشپړ شوی ، او بیا تاسو کولی شئ د ډومین نوم وکاروئ چې تاسو یوازې د اپټایم کوما ته لاسرسي لپاره حل کړی.
- د اپټایم کوما ترتیب خورا ساده دی.
- دا یو چینایي انٹرفیس لري، زه باور لرم چې تاسو به یې ژر تر ژره وکاروئ.
Uptime Kuma ګټور PM2 کمانډونه
د اپټایم کوما کمانډونه پیل کړئ ، ودروئ او بیا پیل کړئ (دا کمانډ د غیر ډاکر نصبولو ته وقف شوی دی) ▼
pm2 start uptime-kuma pm2 stop uptime-kuma pm2 restart uptime-kuma
د اپټایم کوما اوسنی کنسول محصول وګورئ (دا کمانډ د غیر ډاکر نصبولو ته وقف شوی دی) ▼
pm2 monit
په پیل کې د اپټایم کوما چل کړئ (دا کمانډ غیر ډاکر تاسیساتو ته وقف شوی دی) ▼
pm2 save && pm2 startup
د اپټایم کوما څارنې سافټویر اتوماتیک بیک اپ څنګه تنظیم کړئ؟
ځکه چې ممکن د اپټایم کوما شالید ترتیباتو کې د بیک اپ فنکشن سره ځینې ستونزې شتون ولري ، نو پراختیا کونکي د بیک اپ فعالیت نه دی ساتلی اوس د بیک اپ فنکشن نور نشي کولی بشپړ بیک اپ رامینځته کړي او ټول تنظیمات بحال کړي ...
غواړئ په دې اړه نور پوه شئ چې څنګه د اپټایم کوما بیک اپ فیچر تخریب سره معامله وکړئ؟ د تفصيلي ښوونې لوستلو ته دوام ورکولو لپاره لاندې لینک باندې کلیک وکړئ ▼
د اپټایم کوما څارنې سافټویر څنګه غیر نصب کړئ؟
که چیرې اپټایم کوما د ډاکر په کارولو سره نه وي نصب شوی ، نو څنګه یې غیر نصب کړم؟
د مثال په توګه، که تاسو دا کمانډ په غیر ډاکر ډول نصبولو لپاره کاروئ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
د اپټایم کوما غیر نصبولو لپاره ، لاندې کمانډ وکاروئ ▼
- کار نه کوی
pm2 stop uptime-kuma - لارښود حذف کړئ
rm -rf /opt/uptime-kuma
د اپټایم کوما څنګه غیر نصب کړئ که تاسو دا د ډاکر په کارولو سره نصب کړئ؟
لاندې د پوښتنې کمانډ چل کړئ▼
docker ps -a
- خپل لیکل
kumaد کانټینر نوم، کوم چې کیدی شيuptime-kuma
د بندولو امر ▼
- مهرباني
container_nameپورته پوښتنې ته بدلون ورکړئkumaد کانتینر نوم.
docker stop container_name docker rm container_name
د اپټایم کوما ▼ غیر نصب کړئ
docker volume rm uptime-kuma docker rmi uptime-kuma
پایله
د اپټایم کوما انٹرفیس پاک او ساده دی ، او دا ځای په ځای کول او کارول خورا اسانه دي.
Uptime Kuma یو ډیر ښه انتخاب دی که تاسو د ویب پاڼې څارنې لپاره لوړې اړتیاوې نلرئ.
هیله ده، د چن وییلینګ په بلاګ ( https://www.chenweiliang.com/ ) کې شریک شوی "د لینکس سرور څارنې لپاره د اپټایم کوما وړیا ویب پاڼې حالت څارنې وسیله" مقاله به ستاسو لپاره ګټوره وي.
د دې مقالې لینک شریکولو لپاره وړیا احساس وکړئ: https://www.chenweiliang.com/cwl-29041.html


