Artikelgids
Ons doen gewoonlik eksterne kettingbevordering en vriendskapskakeloptimering moet gemonitor word.
As ons ons terugskakels en wederkerige skakels verloor, sal ons SEO- ranglys ook daal. Daarom is dit baie belangrik om die status van teruggeskakelde webbladsye te monitor.
Waarom Uptime Kuma gebruik om webwerwe te monitor?
Hoe om terugskakels vir SEO-doeleindes te monitor?
Nadat ons terugskakels bygevoeg en wederkerige skakels uitgeruil het, konfigureer ons gewoonlik webwerfmonitering op die Uptime Robot- wolkmoniteringsplatform om die konnektiwiteit van die terugskakelbladsye op elke webwerf na te gaan.
Met die toenemende aantal eksterne kettings en vriendskettings het die Uptime Robot-wolkplatform egter 'n beperking op die aantal monitering, en jy moet opgradeer en betaal om voort te gaan om meer wolkmoniteringitems by te voeg.
Daarom kan ons die oopbron Linux- wolkbedienermoniteringsagteware - instrument – Uptime Kuma – gebruik.
Watter sagteware is Uptime Kuma?
Uptime Kuma is 'n oopbron Linux-bedienermoniteringsinstrument met soortgelyke funksies as Uptime Robot.
In vergelyking met ander soortgelyke webwerf-moniteringsinstrumente, ondersteun Uptime Kuma dienste wat self aangebied word met minder beperkings.
Hierdie artikel sal die installering en gebruik van Uptime Kuma bekendstel.
Hoe om Uptime Kuma-moniteringsinstrument te installeer?
Uptime Kuma, ondersteun Docker-installasie.
Die volgende is 'n handleiding oor die installasiestappe van Uptime Kuma.
Die volgende opdragte is vir die installering van die program via CLI [Ubuntu/ CentOS ]. Interaktiewe CLI-installeerder, met of sonder Docker-ondersteuning ▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
- Dit word nie aanbeveel om die bogenoemde installasie-opdrag te gebruik nie: omdat Uptime Kuma op 'n nie-Docker-manier geïnstalleer is, is dit maklik om die installasie te misluk.
- (Ons beveel die installasie-opdrag hieronder aan)
Aangesien u Docker moet installeer voordat u Uptime Kuma met Docker installeer, installeer eers Docker.
Installeer Docker en Docker-compose
Dateer en installeer nodige sagteware ▼
apt-get update && apt-get install -y wget vim
As 'n 404-fout tydens die opdatering voorkom, kyk asseblief na die oplossing hieronder▼
Installeer Docker
As dit 'n buitelandse bediener is, gebruik asseblief die volgende opdrag ▼
curl -sSL https://get.docker.com/ | sh
As dit 'n huishoudelike bediener in China is, gebruik asseblief die volgende opdrag ▼
curl -sSL https://get.daocloud.io/docker | sh
Stel Docker om outomaties te begin by selflaai ▼
systemctl start docker systemctl enable docker
Installeer Docker-compose
As dit 'n buitelandse bediener is, gebruik asseblief die volgende opdrag ▼
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose sudo chmod +x /usr/local/bin/docker-compose
As dit 'n huishoudelike bediener in China is, gebruik asseblief die volgende opdrag▼
curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose
Herbegin die docker-diensopdrag▼
service docker restart
Hoe om Uptime Kuma gratis webwerfstatusmonitering-instrument te installeer?
docker volume create uptime-kuma
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1- Dan kan jy slaag
IP:3001Besoek Uptime-Kuma.
As jy die CSF-brandmuur geaktiveer het, moet jy dalk poort 3001 op die CSF-brandmuur oopmaak▼
vi /etc/csf/csf.conf # Allow incoming TCP ports TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001"
Herbegin die CSF-brandmuur ▼
csf -rInstalleer Nginx Proxy Manager
Nginx Proxy Manager is 'n Docker-gebaseerde omgekeerde proxy-sagteware.
Aangesien Nginx Proxy Manager nie nodig is nie, kan jy oorslaan om nie Nginx Proxy Manager te installeer as jy nie tyd wil mors nie.
Skep gids ▼
mkdir -p data/docker_data/npm cd data/docker_data/npm
Skep docker-compose.yml lêer ▼
nano docker-compose.yml
Vul die volgende inhoud in die lêer in, druk dan Ctrl+X om te stoor, druk Y om te verlaat ▼
version: "3"
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
restart: unless-stopped
ports:
# These ports are in format :
- '80:80' # Public HTTP Port
- '443:443' # Public HTTPS Port
- '81:81' # Admin Web Port
# Add any other Stream port you want to expose
# - '21:21' # FTP
environment:
DB_MYSQL_HOST: "db"
DB_MYSQL_PORT: 3306
DB_MYSQL_USER: "npm"
DB_MYSQL_PASSWORD: "npm"
DB_MYSQL_NAME: "npm"
# Uncomment this if IPv6 is not enabled on your host
# DISABLE_IPV6: 'true'
volumes:
- ./data:/data
- ./letsencrypt:/etc/letsencrypt
depends_on:
- db
db:
image: 'jc21/mariadb-aria:latest'
restart: unless-stopped
environment:
MYSQL_ROOT_PASSWORD: 'npm'
MYSQL_DATABASE: 'npm'
MYSQL_USER: 'npm'
MYSQL_PASSWORD: 'npm'
volumes:
- ./data/mysql:/var/lib/mysql hardloop▼
docker-compose up -d
As 'n foutboodskap soortgelyk aan die volgende verskyn: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼
[root@ten npm]# docker-compose up -d npm_db_1 is up-to-date Starting npm_app_1 ... error ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use ERROR: Encountered errors while bringing up the project.
- Dit beteken dat poort 443 reeds beset is, en die docker-compose.yml-lêer wat pas geskep is, moet geredigeer word.
Poort 443 moet na 442 ▼ verander word
- '442:442' # Public HTTPS Port
Voer dan die opdrag weer uit docker-compose up -d
'n Foutboodskap sal verskyn:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"
Moet ook poort 80 na 882 verander ▼
- '882:882' # Public HTTP Port
deur oop te maak http:// IP:81 Besoek Nginx Proxy Manager.
Vir die eerste aanmelding, gebruik die verstek aanvanklike rekening en wagwoord▼
Email: [email protected] Password: changeme
- Nadat u aangemeld het, moet u asseblief u e-posadres en wagwoord onmiddellik verander.
Omgekeerde proxy Uptime Kuma
Na die installering van Uptime Kuma, is die verstek om te gebruikIP:3001Besoek Uptime Kuma.
Ons kan toegang tot die domeinnaam verkry en die SSL-sertifikaat konfigureer deur middel van omgekeerde instaanbediener, net soos die URL wat vroeër gedemonstreer is.
Vervolgens sal ons omgekeerde generasie bewerkings uitvoer, met behulp van die voorheen geboude Nginx Proxy Manager.
deur http:// IP:81 Maak Nginx Proxy Manager oop.
Nadat u vir die eerste keer aangemeld het, moet u die gebruikersnaam en wagwoord verander, stel dit asseblief self in.
Vervolgens is die operasiestappe van Nginx Proxy Manager soos volg:
Stap 1:oop Proxy Hosts ▼

Stap 2:Klik op die regter boonste hoek Add Proxy Hosts▼

Stap 3: Konfigureer volgens die figuur,点击 Save 保存 ▼

Stap 4:klikEidtMaak die konfigurasiebladsy oop ▼

Stap 5: Reik 'n SSL-sertifikaat uit en aktiveer geforseerde HTTPS-toegang ▼

- Op hierdie stadium is die omgekeerde generering voltooi, en dan kan u die domeinnaam gebruik wat u sopas besluit het om toegang tot Uptime Kuma te verkry.
- Uptime Kuma-konfigurasie is baie eenvoudig.
- Dit het 'n Chinese koppelvlak, ek glo jy sal dit binnekort kan gebruik.
Uptime Kuma Nuttige PM2-opdragte
Begin, stop en herbegin opdragte van Uptime Kuma (hierdie opdrag is toegewy aan nie-Docker-installasie)▼
pm2 start uptime-kuma pm2 stop uptime-kuma pm2 restart uptime-kuma
Bekyk die huidige konsole-uitvoer van Uptime Kuma (hierdie opdrag is toegewy aan nie-Docker-installasie)▼
pm2 monit
Begin Uptime Kuma by opstart (hierdie opdrag is toegewy aan nie-Docker-installasies) ▼
pm2 save && pm2 startup
Hoe om outomatiese rugsteun van Uptime Kuma-moniteringsagteware op te stel?
Omdat daar 'n paar probleme met die rugsteunfunksie in die agtergrondinstellings van Uptime Kuma kan wees, het die ontwikkelaar nie die rugsteunfunksie onderhou nie. Nou is die rugsteunfunksie nie meer in staat om 'n volledige rugsteun te genereer en alle instellings te herstel nie.
Wil jy meer weet oor hoe om Uptime Kuma-rugsteunfunksie te hanteer? Klik op die skakel hieronder om voort te gaan met die lees van die gedetailleerde tutoriaal ▼
Hoe om Uptime Kuma-moniteringsagteware te verwyder?
As Uptime Kuma nie met Docker geïnstalleer is nie , hoe deïnstalleer ek dit?
Byvoorbeeld, as jy hierdie opdrag gebruik om op 'n nie-Docker manier te installeer▼
curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
Om Uptime Kuma te verwyder, gebruik die volgende opdrag ▼
- buite diens
pm2 stop uptime-kuma - vee gids uit
rm -rf /opt/uptime-kuma
Hoe om Uptime Kuma te verwyder as u dit met Docker installeer?
Voer die volgende navraagopdrag uit▼
docker ps -a
- skryf jou neer
kumaDie naam van die houer, wat mag weesuptime-kuma
stop opdrag ▼
- stuur asseblief
container_nameVerander na bogenoemde navraagkumaDie naam van die houer.
docker stop container_name docker rm container_name
Verwyder Uptime Kuma ▼
docker volume rm uptime-kuma docker rmi uptime-kuma
Afsluiting
Die koppelvlak van Uptime Kuma is skoon en eenvoudig, en dit is baie maklik om te ontplooi en te gebruik.
Uptime Kuma is 'n baie goeie keuse as u nie hoë vereistes vir webwerfmonitering het nie.
Hopelik sal die artikel "Uptime Kuma Free Website Status Monitoring Tool for Linux Servers" wat op Chen Weiliang se blog ( https://www.chenweiliang.com/ ) gedeel is, vir jou nuttig wees.
Deel gerus die skakel na hierdie artikel: https://www.chenweiliang.com/cwl-29041.html


