Uptime Kuma رایگان ابزار نظارت بر وضعیت وب سایت نرم افزار نظارت بر سرور لینوکس

ما معمولاً تبلیغ زنجیره خارجی را انجام می دهیم و بهینه سازی پیوند دوستی باید نظارت شود.

اگر بک لینک ها و لینک های متقابل خود را از دست بدهیم، رتبه سئو ما نیز کاهش خواهد یافت. بنابراین، نظارت بر وضعیت صفحات وب سایت بک لینک شده بسیار مهم است.

چرا از Uptime Kuma برای نظارت بر وب سایت ها استفاده کنیم؟

چگونه بک لینک ها را برای اهداف سئو رصد کنیم ؟

پس از افزودن بک لینک‌ها و تبادل لینک‌های متقابل، ما معمولاً مانیتورینگ وب‌سایت را در پلتفرم مانیتورینگ ابری Uptime Robot پیکربندی می‌کنیم تا اتصال صفحات بک لینک در هر وب‌سایت را بررسی کنیم.

با این حال، با افزایش تعداد زنجیره‌های خارجی و زنجیره‌های دوستان، پلتفرم ابری Uptime Robot محدودیتی در تعداد آیتم‌های نظارت دارد و برای ادامه افزودن آیتم‌های مانیتورینگ ابری بیشتر، باید ارتقا دهید و پرداخت کنید.

بنابراین، می‌توانیم از ابزار نرم‌افزاری مانیتورینگ سرور ابری لینوکس متن‌باز - Uptime Kuma - استفاده کنیم.

Uptime Kuma چه نرم افزاری است؟

Uptime Kuma یک ابزار مانیتورینگ سرور لینوکس منبع باز با عملکردهای مشابه ربات Uptime است.

در مقایسه با سایر ابزارهای مشابه نظارت بر وب سایت، Uptime Kuma از خدمات خود میزبانی با محدودیت های کمتر پشتیبانی می کند.

این مقاله نصب و استفاده از Uptime Kuma را معرفی می کند.

چگونه ابزار مانیتورینگ Uptime Kuma را نصب کنیم؟

Uptime Kuma، از نصب Docker پشتیبانی می کند.

در ادامه آموزش مراحل نصب Uptime Kuma آورده شده است.

دستورات زیر برای نصب برنامه از طریق رابط خط فرمان (CLI) [اوبونتو/ سنت او اس ] هستند. نصب‌کننده رابط خط فرمان تعاملی، با یا بدون پشتیبانی از داکر ▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
  • استفاده از دستور نصب بالا توصیه نمی شود: از آنجایی که Uptime Kuma به روش غیر Docker نصب شده است، به راحتی می توان نصب را با شکست مواجه کرد.
  • (ما دستور نصب زیر را توصیه می کنیم)

از آنجایی که قبل از نصب Uptime Kuma با استفاده از Docker باید Docker را نصب کنید، ابتدا Docker را نصب کنید.

Docker و Docker-compose را نصب کنید

به روز رسانی و نصب نرم افزار ضروری ▼

apt-get update && apt-get install -y wget vim

اگر در حین به روز رسانی خطای 404 رخ داد، لطفاً راه حل زیر را بررسی کنید

Docker را نصب کنید

اگر سرور خارجی است، لطفا از دستور ▼ استفاده کنید

 curl -sSL https://get.docker.com/ | sh 

اگر سرور داخلی در چین است، لطفاً از دستور ▼ استفاده کنید

 curl -sSL https://get.daocloud.io/docker | sh 

Docker را تنظیم کنید تا به طور خودکار در هنگام بوت ▼ شروع به کار کند

systemctl start docker 

systemctl enable docker

Docker-compose را نصب کنید 

اگر سرور خارجی است، لطفا از دستور ▼ استفاده کنید

sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

اگر سرور داخلی در چین است، لطفاً از دستور زیر استفاده کنید

curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
chmod +x /usr/local/bin/docker-compose

فرمان سرویس docker را مجدداً راه اندازی کنید

service docker restart

چگونه ابزار نظارت بر وضعیت وب سایت رایگان Uptime Kuma را نصب کنیم؟

🐳 در حالت Docker نصب کنید، یک ظرف به نام uptime-kuma ▼ ایجاد کنید

docker volume create uptime-kuma
محفظه ▼ را راه اندازی کنید
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1
  • سپس، شما می توانید عبور کنیدIP:3001از Uptime-Kuma دیدن کنید.

اگر فایروال CSF را فعال کرده اید، ممکن است لازم باشد پورت 3001 را روی فایروال CSF باز کنید ▼

vi /etc/csf/csf.conf
# Allow incoming TCP ports
 TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001" 

فایروال CSF ▼ را مجددا راه اندازی کنید

csf -r

Nginx Proxy Manager را نصب کنید

Nginx Proxy Manager یک نرم افزار پروکسی معکوس مبتنی بر Docker است.

از آنجایی که Nginx Proxy Manager ضروری نیست، اگر نمی خواهید زمان خود را تلف کنید، می توانید از نصب Nginx Proxy Manager صرفنظر کنید.

دایرکتوری ▼ ایجاد کنید

mkdir -p data/docker_data/npm
cd data/docker_data/npm

فایل docker-compose.yml ▼ را ایجاد کنید

nano docker-compose.yml

محتوای زیر را در فایل پر کنید، سپس Ctrl+X را برای ذخیره، Y را فشار دهید تا از ▼ خارج شوید

version: "3"
services:
  app:
    image: 'jc21/nginx-proxy-manager:latest'
    restart: unless-stopped
    ports:
      # These ports are in format :
      - '80:80' # Public HTTP Port
      - '443:443' # Public HTTPS Port
      - '81:81' # Admin Web Port
      # Add any other Stream port you want to expose
      # - '21:21' # FTP
    environment:
      DB_MYSQL_HOST: "db"
      DB_MYSQL_PORT: 3306
      DB_MYSQL_USER: "npm"
      DB_MYSQL_PASSWORD: "npm"
      DB_MYSQL_NAME: "npm"
      # Uncomment this if IPv6 is not enabled on your host
      # DISABLE_IPV6: 'true'
    volumes:
      - ./data:/data
      - ./letsencrypt:/etc/letsencrypt
    depends_on:
      - db

  db:
    image: 'jc21/mariadb-aria:latest'
    restart: unless-stopped
    environment:
      MYSQL_ROOT_PASSWORD: 'npm'
      MYSQL_DATABASE: 'npm'
      MYSQL_USER: 'npm'
      MYSQL_PASSWORD: 'npm'
    volumes:
      - ./data/mysql:/var/lib/mysql

اجرا کنید

docker-compose up -d

اگر پیغام خطای مشابه زیر ظاهر شد:Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼

[root@ten npm]# docker-compose up -d
npm_db_1 is up-to-date
Starting npm_app_1 ... error

ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use
ERROR: Encountered errors while bringing up the project.
  • این بدان معناست که پورت 443 از قبل اشغال شده است و فایل docker-compose.yml که ایجاد شده است باید ویرایش شود.

پورت 443 باید به 442 ▼ تغییر یابد

      - '442:442' # Public HTTPS Port

سپس، دوباره دستور را اجرا کنید docker-compose up -d

یک پیغام خطا ظاهر می شود:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"

همچنین باید پورت 80 را به 882 ▼ تغییر دهید

      - '882:882' # Public HTTP Port

با باز کردن http:// IP:81 از Nginx Proxy Manager دیدن کنید.

برای اولین ورود، از حساب اولیه و رمز عبور پیش فرض استفاده کنید

Email: [email protected]
Password: changeme
  • پس از ورود به سیستم، لطفاً بلافاصله آدرس ایمیل و رمز عبور خود را تغییر دهید.

پروکسی معکوس Uptime Kuma

پس از نصب Uptime Kuma، پیش فرض استفاده استIP:3001از Uptime Kuma دیدن کنید.

ما می توانیم به نام دامنه دسترسی داشته باشیم و گواهی SSL را از طریق پراکسی معکوس پیکربندی کنیم، درست مانند URL که قبلا نشان داده شد.

در مرحله بعد، عملیات تولید معکوس را با استفاده از Nginx Proxy Manager که قبلاً ساخته شده بود، انجام خواهیم داد.

عبور http:// IP:81 Nginx Proxy Manager را باز کنید.

پس از ورود برای اولین بار، باید نام کاربری و رمز عبور را تغییر دهید، لطفاً خودتان آن را پیکربندی کنید.

در مرحله بعد، مراحل عملکرد Nginx Proxy Manager به شرح زیر است:

مرحله 1:روشن کن Proxy Hosts ▼

Uptime Kuma رایگان ابزار نظارت بر وضعیت وب سایت نرم افزار نظارت بر سرور لینوکس

مرحله 2:روی گوشه سمت راست بالا کلیک کنید Add Proxy Hosts▼

مرحله ۲: روی «افزودن میزبان‌های پروکسی» در گوشه بالا سمت راست کلیک کنید.

مرحله 3: مطابق شکل پیکربندی کنید،کلیک کنید Save صرفه جویی ▼ 

مرحله ۳: تنظیمات را مانند تصویر انجام دهید و سپس روی ذخیره کلیک کنید.

مرحله 4:کلیکEidtصفحه پیکربندی ▼ را باز کنید

مرحله ۴: برای باز کردن صفحه پیکربندی، روی Eidt کلیک کنید

مرحله ۵: صدور گواهی SSL و فعال کردن دسترسی اجباری HTTPS ▼

مرحله 5: یک گواهی SSL صادر کنید و دسترسی اجباری Https را فعال کنید 

  • در این مرحله، تولید معکوس به پایان می رسد، و سپس می توانید از نام دامنه ای که به تازگی حل کرده اید برای دسترسی به Uptime Kuma استفاده کنید.
  • پیکربندی Uptime Kuma بسیار ساده است.
  • این یک رابط چینی دارد، فکر می کنم به زودی می توانید از آن استفاده کنید.

Uptime Kuma دستورات مفید PM2

دستورات شروع، توقف و راه اندازی مجدد Uptime Kuma (این دستور به نصب غیر داکر اختصاص داده شده است)

pm2 start uptime-kuma
pm2 stop uptime-kuma
pm2 restart uptime-kuma

خروجی کنسول فعلی Uptime Kuma را مشاهده کنید (این دستور به نصب غیر داکر اختصاص داده شده است) ▼

pm2 monit

هنگام راه اندازی Uptime Kuma را اجرا کنید (این دستور به نصب های غیر داکر اختصاص داده شده است) ▼

pm2 save && pm2 startup

چگونه از نرم افزار مانیتورینگ Uptime Kuma پشتیبان گیری خودکار تنظیم کنیم؟

از آنجایی که ممکن است در تنظیمات پس‌زمینه Uptime Kuma مشکلاتی در عملکرد پشتیبان‌گیری وجود داشته باشد، توسعه‌دهنده عملکرد پشتیبان‌گیری را حفظ نکرده است.

آیا می خواهید در مورد نحوه مقابله با از بین رفتن ویژگی پشتیبان گیری Uptime Kuma بیشتر بدانید؟ برای ادامه خواندن آموزش مفصل ▼ روی لینک زیر کلیک کنید

چگونه نرم افزار مانیتورینگ Uptime Kuma را حذف نصب کنیم؟

اگر Uptime Kuma با استفاده از Docker نصب نشده باشد ، چگونه می‌توانم آن را حذف نصب کنم؟

برای مثال، اگر از این دستور برای نصب به روش غیر داکر استفاده می‌کنید

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh

برای حذف Uptime Kuma از دستور ▼ استفاده کنید

  1. خراب  pm2 stop uptime-kuma
  2. حذف دایرکتوری rm -rf /opt/uptime-kuma

چگونه می توان Uptime Kuma را در صورت نصب با Docker حذف نصب کرد؟

دستور query زیر را اجرا کنید

docker ps -a
  • خودت را بنویس kuma نام ظرف، که ممکن است uptime-kuma

دستور توقف ▼

  • لطفا بفرستcontainer_nameبه پرس و جوی بالا تغییر دهیدkuma نام ظرف.
docker stop container_name
docker rm container_name

Uptime Kuma ▼ را حذف نصب کنید

docker volume rm uptime-kuma
docker rmi uptime-kuma

نتیجه

رابط کاربری Uptime Kuma تمیز و ساده است و استقرار و استفاده از آن بسیار آسان است.

اگر نیازهای بالایی برای نظارت بر وب سایت ندارید، Uptime Kuma انتخاب بسیار خوبی است.

امیدوارم مقاله "ابزار رایگان مانیتورینگ وضعیت وب‌سایت Uptime Kuma برای مانیتورینگ سرور لینوکس" که در وبلاگ چن ویلیانگ ( https://www.chenweiliang.com/ ) به اشتراک گذاشته شده است، برای شما مفید باشد.

لینک این مقاله را به اشتراک بگذارید: https://www.chenweiliang.com/cwl-29041.html

برای کشف ترفندهای مخفی بیشتر🔑، به کانال تلگرام ما بپیوندید!

اگر دوست داشتید به اشتراک بگذارید و لایک کنید! اشتراک گذاری ها و لایک های شما انگیزه ادامه دار ماست!

 

发表 评论

您的邮箱地址不会被公开。必填项已用*标注

رفته به بالا