Upgrade de MySQL-database van het VestaCP- paneel naar MariaDB versie 10.4.6 met behulp van een Linux- host .

Voer onverwacht het volgende commando in▼
mysql -uroot -p
- Voer wachtwoord in om in te loggenmysql.
De volgende fout treedt op
FOUT 1045 (28000): Toegang geweigerd voor gebruiker 'root'@'localhost' (met wachtwoord: JA)
Meestal wordt deze fout veroorzaakt door een verkeerd root-gebruikerswachtwoord voor MySQL-gegevens, de oplossing is natuurlijk om het wachtwoord opnieuw in te stellen.
Hoe MySQL ERROR 1045 (28000) fout?
Stap 1: Nadat u bent ingelogd via SSH , voert u de volgende opdracht in om de MySQL-database te stoppen ▼
systemctl stop mysqld
Stap 2: Start MySQL met het volgende commando, zonder de machtigingen te controleren ▼
mysqld --skip-grant-tables &
Op dit punt werd een andere fout gemeld ▼
[ERROR] Fatale fout: lees het gedeelte "Beveiliging" van de handleiding om erachter te komen hoe mysqld als root moet worden uitgevoerd!
Gelieve SSH en voer het volgende commando in ▼
mysqld --user=root --skip-grant-tables &
Stap 3: Log in bij MySQL via SSH ▼
mysql -uroot
或
mysql
Stap 4: Werk het rootwachtwoord bij
Mysql5.7 of hoger ▼
UPDATE mysql.user SET Password=PASSWORD('123456') where USER='root';Mysql5.7-versie
UPDATE mysql.user SET authentication_string=PASSWORD('123456') where USER='root';Stap 5: Machtigingen vernieuwen ▼
flush privileges;
Stap 6: MySQL afsluiten ▼
exit
或
quit
Stap 7: Log opnieuw in bij MySQL als root-gebruiker ▼
Mysql -uroot -p
- Voer wachtwoord in:
<输入刚改好的密码123456>
Hopelijk is het artikel "Solving ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)" op de blog van Chen Weiliang ( https://www.chenweiliang.com/ ) nuttig voor u.
Deel gerust de link naar dit artikel: https://www.chenweiliang.com/cwl-1094.html
