I-Uptime Kuma yeSixhobo seSimo seWebhusayithi sokuJonga isiXhobo se-Linux Server Monitoring

Sidla ngokwenza unyuso lwekhonkco lwangaphandle kunye nokuphucula ikhonkco lobuhlobo kufuneka kubekwe iliso.

Ukuba silahlekelwa zii-backlinks zethu kunye nee-reciprocal links, udidi lwethu lwe-SEO nalo luya kwehla. Ke ngoko, ukujonga imeko yamaphepha ewebhusayithi a-backlinked kubaluleke kakhulu.

Kutheni usebenzisa i-Uptime Kuma ukujonga iiWebhusayithi?

Ungayijonga njani i-backlinks ngeenjongo ze-SEO?

Emva kokongeza ii-backlinks kunye nokutshintshiselana ngee-links ezihambelanayo, sihlala simisela ukujonga iwebhusayithi kwiqonga lokujonga i-Uptime Robot ukuze sijonge uqhagamshelo lwamaphepha e-backlink kwiwebhusayithi nganye.

Nangona kunjalo, ngenani elikhulayo lamatyathanga angaphandle kunye namatyathanga omhlobo, i-platform yefu ye-Uptime Robot inomda kwinani lokubeka iliso, kwaye kufuneka uphucule kwaye uhlawule ukuqhubeka ukongeza izinto zokubeka iliso zamafu.

Ke ngoko, singasebenzisa isixhobo sesoftware yokubeka esweni iseva yelifu yeLinux esivulelekileyo – i-Uptime Kuma.

Yeyiphi isoftware ye-Uptime Kuma?

I-Uptime Kuma sisixhobo sokujonga iseva yeLinux evulekileyo enemisebenzi efanayo kwiRobhothi ye-Uptime.

Xa kuthelekiswa nezinye izixhobo zokubeka iliso zewebhusayithi ezifanayo, i-Uptime Kuma ixhasa iinkonzo ezizibambeleyo kunye nezithintelo ezimbalwa.

Eli nqaku liza kwazisa ukufakwa kunye nokusetyenziswa kwe-Uptime Kuma.

Indlela yokufaka isixhobo sokubeka iliso se-Uptime Kuma?

I-Uptime Kuma, ixhasa ukufakwa kweDocker.

Oku kulandelayo sisifundo kumanyathelo ofakelo lwe-Uptime Kuma.

Le miyalelo ilandelayo yeyokufaka inkqubo nge-CLI [Ubuntu/ CentOS ]. Umfaki we-CLI osebenzisanayo, enenkxaso ye-Docker okanye engenayo ▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh
  • Akukhuthazwa ukusebenzisa lo myalelo wofakelo ungentla: kuba i-Uptime Kuma ifakwe ngendlela engeyiyo i-Docker, kulula ukusilela ukufakela.
  • (Sicebisa lo myalelo wofakelo ngezantsi)

Kuba kufuneka ufake iDocker ngaphambi kokufaka i-Uptime Kuma usebenzisa iDocker, faka iDocker kuqala.

Faka iDocker kunye neDocker-compose

Hlaziya kwaye ufake isoftwe eyimfuneko ▼

apt-get update && apt-get install -y wget vim

Ukuba kukho impazamo ye-404 ngexesha lohlaziyo, nceda ujonge isisombululo esingezantsi▼

Faka iDocker

Ukuba yiseva yangaphandle, nceda usebenzise lo myalelo ulandelayo ▼

 curl -sSL https://get.docker.com/ | sh 

Ukuba yiseva yasekhaya eTshayina, nceda usebenzise lo myalelo ulandelayo ▼

 curl -sSL https://get.daocloud.io/docker | sh 

Seta iDocker ukuba iqale ngokuzenzekelayo kwi-boot ▼

systemctl start docker 

systemctl enable docker

Faka i-Docker-compose 

Ukuba yiseva yangaphandle, nceda usebenzise lo myalelo ulandelayo ▼

sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

Ukuba yiseva yasekhaya eTshayina, nceda usebenzise lo myalelo ulandelayo▼

curl -L https://get.daocloud.io/docker/compose/releases/download/v2.1.1/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
chmod +x /usr/local/bin/docker-compose

Qala kwakhona umyalelo wenkonzo yedocker▼

service docker restart

Uyifaka njani i-Uptime Kuma isixhobo sokujonga imeko yewebhusayithi?

🐳 Faka kwimowudi yeDocker, yenza isikhongozeli esibizwa ngokuba yi-uptime-kuma ▼

docker volume create uptime-kuma
Qala isikhongozeli ▼
docker run -d --restart=always -p 3001:3001 -v uptime-kuma:/app/data --name uptime-kuma louislam/uptime-kuma:1
  • Emva koko, ungadlulaIP:3001Ndwendwela i-Uptime-Kuma.

Ukuba uyenzile i-firewall ye-CSF, unokufuna ukuvula i-port 3001 kwi-firewall ye-CSF▼

vi /etc/csf/csf.conf
# Allow incoming TCP ports
 TCP_IN = "20,21,22,2812,25,53,80,110,143,443,465,587,993,995,2030,2031,2082,2083,2086,2087,2095,2096,3001" 

Qala kwakhona i-firewall ye-CSF ▼

csf -r

Faka uMphathi weNginx oMmeli

Umphathi we-Nginx woMmeli yi-Docker-based reverse proxy software.

Kuba uMphathi weProxy ye-Nginx ayiyomfuneko, unokutsiba ungafaki uMphathi we-Nginx oMmeli ukuba awufuni ukuchitha ixesha.

Yenza uvimba weefayili ▼

mkdir -p data/docker_data/npm
cd data/docker_data/npm

Yenza ifayile ye-docker-compose.yml ▼

nano docker-compose.yml

Gcwalisa lo mxholo ulandelayo kwifayile, uze ucinezele u-Ctrl+X ukugcina, cinezela u-Y ukuphuma ▼

version: "3"
services:
  app:
    image: 'jc21/nginx-proxy-manager:latest'
    restart: unless-stopped
    ports:
      # These ports are in format :
      - '80:80' # Public HTTP Port
      - '443:443' # Public HTTPS Port
      - '81:81' # Admin Web Port
      # Add any other Stream port you want to expose
      # - '21:21' # FTP
    environment:
      DB_MYSQL_HOST: "db"
      DB_MYSQL_PORT: 3306
      DB_MYSQL_USER: "npm"
      DB_MYSQL_PASSWORD: "npm"
      DB_MYSQL_NAME: "npm"
      # Uncomment this if IPv6 is not enabled on your host
      # DISABLE_IPV6: 'true'
    volumes:
      - ./data:/data
      - ./letsencrypt:/etc/letsencrypt
    depends_on:
      - db

  db:
    image: 'jc21/mariadb-aria:latest'
    restart: unless-stopped
    environment:
      MYSQL_ROOT_PASSWORD: 'npm'
      MYSQL_DATABASE: 'npm'
      MYSQL_USER: 'npm'
      MYSQL_PASSWORD: 'npm'
    volumes:
      - ./data/mysql:/var/lib/mysql

baleka▼

docker-compose up -d

Ukuba umyalezo wemposiso efana nale ilandelayo ivela: "Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use"▼

[root@ten npm]# docker-compose up -d
npm_db_1 is up-to-date
Starting npm_app_1 ... error

ERROR: for npm_app_1 Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use

ERROR: for app Cannot start service app: driver failed programming external connectivity on endpoint npm_app_1 (bd3512d79a2184dbd03b2a715fab3990d503c17e85c35b1b4324f79068a29969): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use
ERROR: Encountered errors while bringing up the project.
  • Kuthetha ukuba izibuko 443 sele lihleli, kwaye ifayile ye docker-compose.yml esandula ukuyilwa kufuneka ihlelwe.

Izibuko le-443 kufuneka litshintshwe libe ngu-442 ▼

      - '442:442' # Public HTTPS Port

Emva koko, sebenzisa umyalelo kwakhona docker-compose up -d

Umyalezo wemposiso uzakuvela:“Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use"

Kwakhona kufuneka utshintshe izibuko 80 ukuya 882 ▼

      - '882:882' # Public HTTP Port

ngokuvula http:// IP:81 Ndwendwela uMphathi weNginx oMmeli.

Ukungena kokuqala, sebenzisa iakhawunti yokuqala engagqibekanga kunye negama lokugqitha▼

Email: [email protected]
Password: changeme
  • Emva kokungena, nceda utshintshe idilesi ye-imeyile kunye negama lokugqitha ngoko nangoko.

Reverse proxy Uptime Kuma

Emva kokufaka i-Uptime Kuma, ukungagqibeki kukusebenzisaIP:3001Ndwendwela i-Uptime Kuma.

Singafikelela kwigama lesizinda kwaye siqwalasele isatifikethi se-SSL ngokusebenzisa ummeli obuyela umva, kanye njenge-URL ebonisiwe ngaphambili.

Okulandelayo, siya kwenza imisebenzi yokubuyisela umva, sisebenzisa uMphathi weNginx owakhiwe ngaphambili.

Ngu http:// IP:81 Vula uMphathi weNginx oMmeli.

Emva kokungena okokuqala, kufuneka utshintshe igama lomsebenzisi kunye negama lokugqitha, nceda ulungise ngokwakho.

Okulandelayo, amanyathelo okusebenza koMphathi weNginx oMmeli ami ngolu hlobo lulandelayo:

Isiqendu 1:layita Proxy Hosts ▼

I-Uptime Kuma yeSixhobo seSimo seWebhusayithi sokuJonga isiXhobo se-Linux Server Monitoring

Isiqendu 2:Cofa kwikona ephezulu ngasekunene Add Proxy Hosts▼

Inyathelo lesi-2: Cofa ku-"Yongeza ii-Proxy Hosts" kwikona ephezulu ngasekunene.

Inyathelo 3: Lungiselela ngokomfanekiso,点击 Save gcina ▼ 

Inyathelo lesi-3: Lungiselela useto njengoko kubonisiwe kumfanekiso, uze ucofe ku-Gcina.

Isiqendu 4:cofaEidtVula iphepha loqwalaselo ▼

Inyathelo lesi-4: Cofa u-Eidt ukuvula iphepha loqwalaselo

Inyathelo lesi-5: Khupha isatifikethi se-SSL uze uvule ukufikelela kwi-HTTPS okunyanzelekileyo ▼

Inyathelo lesi-5: Khupha isatifikethi se-SSL kwaye uvule i-Https enyanzelekileyo ukufikelela 

  • Ngeli xesha, isizukulwana esibuyela umva sigqityiwe, kwaye ke ungasebenzisa igama lesizinda osanda kusombulula ukufikelela kwi-Uptime Kuma.
  • Uqwalaselo lwe-Uptime Kuma lulula kakhulu.
  • Inojongano lwesiTshayina, ndiyakholelwa ukuba uya kukwazi ukuyisebenzisa kungekudala.

Uptime Kuma Eluncedo PM2 Imiyalelo

Qala, yima, kwaye uqalise kwakhona imiyalelo ye-Uptime Kuma (lo myalelo unikezelwe kufakelo olungelulo lweDocker)▼

pm2 start uptime-kuma
pm2 stop uptime-kuma
pm2 restart uptime-kuma

Jonga imveliso yangoku ye-console ye-Uptime Kuma (lo myalelo unikezelwe kwi-non-Docker ufakelo)▼

pm2 monit

Qhuba i-Uptime Kuma ekuqaleni (lo myalelo unikezelwe kwi-non-Docker ufakelo) ▼

pm2 save && pm2 startup

Useta njani ukhuphelo oluzenzekelayo lwe-Uptime Kuma esweni?

Ngenxa yokuba kunokubakho iingxaki ngomsebenzi wokulondoloza kwimimiselo yangasemva ye-Uptime Kuma, umphuhlisi akawugcinanga umsebenzi wokulondoloza.

Ngaba uyafuna ukwazi ngakumbi malunga nendlela yokujongana ne-Uptime Kuma yokugcina inqaku lokuhoxiswa? Cofa ikhonkco elingezantsi ukuze uqhubeke ufunda isifundo esineenkcukacha ▼

Uyikhupha njani i-Uptime Kuma esweni isoftware?

Ukuba i-Uptime Kuma ayifakwanga kusetyenziswa i-Docker , ndingayikhupha njani?

Umzekelo, ukuba usebenzisa lo myalelo ukufaka ngendlela engeyo-Docker▼

curl -o kuma_install.sh http://git.kuma.pet/install.sh && sudo bash kuma_install.sh

Ukukhupha i-Uptime Kuma, sebenzisa lo myalelo ulandelayo ▼

  1. Ayisebenzi  pm2 stop uptime-kuma
  2. cima ulawulo rm -rf /opt/uptime-kuma

Uyikhupha njani i-Uptime Kuma ukuba uyayifaka usebenzisa iDocker?

Yenza lo mbuzo ulandelayo umyalelo▼

docker ps -a
  • bhala phantsi eyakho kuma Igama lesikhongozeli, esinokuthi sibe uptime-kuma

misa umyalelo ▼

  • Ndiyacelacontainer_nameTshintsha kulombuzo ungentlakuma Igama lesikhongozeli.
docker stop container_name
docker rm container_name

Khipha i-Uptime Kuma ▼

docker volume rm uptime-kuma
docker rmi uptime-kuma

Ukuqukumbela

I-interface ye-Uptime Kuma icocekile kwaye ilula, kwaye kulula kakhulu ukuyihambisa kunye nokusetyenziswa.

I-Uptime Kuma lukhetho oluhle kakhulu ukuba awunazo iimfuno eziphezulu zokubeka iliso kwiwebhusayithi.

Shiya uluvo

您的邮箱地址不会被公开。必填项已用*标注

Skrolela phezulu